specs/libevent14.spec
changeset 0 10291c5dc856
equal deleted inserted replaced
-1:000000000000 0:10291c5dc856
       
     1 #
       
     2 # spec file for package: libevent14
       
     3 #
       
     4 # Copyright 2010 Guido Berhoerster.
       
     5 # This file and all modifications and additions to the pristine
       
     6 # package are under the same license as the package itself.
       
     7 #
       
     8 
       
     9 %define owner gber
       
    10 
       
    11 %include Solaris.inc
       
    12 %include oi-extra.inc
       
    13 
       
    14 Name:           libevent14
       
    15 Summary:        Library Providing an Event Handling API
       
    16 Version:        1.4.13
       
    17 License:        BSD3c
       
    18 Url:            http://monkey.org/~provos/libevent/
       
    19 Source:         http://monkey.org/~provos/libevent-%{version}-stable.tar.gz
       
    20 Group:          System/Libraries
       
    21 Distribution:   OpenIndiana
       
    22 Vendor:         OpenIndiana Community
       
    23 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
       
    24 SUNW_Basedir:   %{_basedir}
       
    25 SUNW_Copyright: %{name}.copyright
       
    26 
       
    27 %include default-depend.inc
       
    28 
       
    29 # OpenSolaris IPS Package Manifest Fields
       
    30 Meta(info.upstream):            Nick Mathewson <[email protected]> and Niels Provos <[email protected]>
       
    31 Meta(info.maintainer):          Guido Berhoerster <[email protected]>
       
    32 Meta(info.repository_url):      git://levent.git.sourceforge.net/levent/libevent
       
    33 
       
    34 %description
       
    35 The libevent library provides a mechanism to execute a function when a specific
       
    36 event on a file descriptor occurs or after a given time has passed.
       
    37 
       
    38 %prep
       
    39 %setup -q -n libevent-%{version}-stable
       
    40 
       
    41 %build
       
    42 CPUS=$(psrinfo | awk '$2=="on-line"{cpus++}END{print (cpus==0)?1:cpus}')
       
    43 export CFLAGS="%{optflags}"
       
    44 export LDFLAGS="%{_ldflags}"
       
    45 ./configure \
       
    46     --prefix=%{_prefix} \
       
    47     --mandir=%{_mandir} \
       
    48     --disable-static
       
    49 make -j$CPUS
       
    50 
       
    51 %install
       
    52 rm -rf $RPM_BUILD_ROOT
       
    53 make install DESTDIR=$RPM_BUILD_ROOT
       
    54 rm ${RPM_BUILD_ROOT}%{_libdir}/libevent*.la
       
    55 
       
    56 %clean
       
    57 rm -rf $RPM_BUILD_ROOT
       
    58 
       
    59 %files
       
    60 %defattr(-, root, bin)
       
    61 %doc README ChangeLog
       
    62 %doc %{_mandir}/man3/*
       
    63 %dir %attr (0755, root, bin) %{_prefix}
       
    64 %dir %attr (0755, root, bin) %{_bindir}
       
    65 %dir %attr (0755, root, bin) %{_libdir}
       
    66 %dir %attr (0755, root, bin) %{_includedir}
       
    67 %{_bindir}/event_rpcgen.py
       
    68 %{_includedir}/*.h
       
    69 %{_libdir}/libevent.so
       
    70 %{_libdir}/libevent_*.so*
       
    71 %{_libdir}/libevent-1.4.so.*
       
    72 
       
    73 %changelog
       
    74 * Wed Oct  6 2010 - [email protected]
       
    75 - Initial version.