specs/mawk.spec
changeset 0 179dae5bc04a
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/specs/mawk.spec	Mon Oct 25 22:02:51 2010 +0200
@@ -0,0 +1,68 @@
+#
+# spec file for package: mawk
+#
+# This file and all modifications and additions to the pristine
+# package are under the same license as the package itself.
+#
+
+%define owner gber
+
+%include Solaris.inc
+
+Name:           mawk
+Summary:        implementation of New/POSIX AWK
+Version:        1.3.4
+License:        GPLv2
+Url:            http://invisible-island.net/mawk/mawk.html
+Source:         ftp://invisible-island.net/mawk/mawk-%{version}.tgz
+Group:          Applications/System Utilities
+Distribution:   OpenIndiana
+Vendor:         OpenIndiana
+BuildRoot:      %{_tmppath}/%{name}-%{version}-build
+SUNW_Basedir:   %{_basedir}
+SUNW_Copyright: %{name}.copyright
+
+%include default-depend.inc
+
+# OpenSolaris IPS Package Manifest Fields
+Meta(info.upstream):            http://invisible-island.net/mawk/mawk.html
+Meta(info.maintainer):          Thomas E. Dickey <[email protected]>
+#Meta(info.repository_url):      
+
+%description
+mawk is an interpreter for the AWK Programming Language. It implements the AWK
+language as defined in Aho, Kernighan and Weinberger, The AWK  Programming
+Language, Addison-Wesley Publishing, 1988. Furthermore, it conforms to the
+POSIX 1003.2 (draft 11.3) definition of the AWK language and additionally
+provides a small number of extensions.
+
+%prep
+%setup -q
+
+%build
+CPUS=$(psrinfo | awk '$2=="on-line"{cpus++}END{print (cpus==0)?1:cpus}')
+export CFLAGS="$RPM_OPT_FLAGS"
+./configure \
+    --prefix="%{_prefix}" \
+    --mandir="%{_mandir}"
+make -j$CPUS
+
+%install
+rm -rf $RPM_BUILD_ROOT
+make install DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-, root, bin)
+%doc CHANGES README ACKNOWLEDGMENT
+%doc examples/ct_length.awk examples/decl.awk examples/deps.awk
+%doc examples/eatc.awk examples/gdecl.awk examples/hcal examples/hical
+%doc examples/nocomment.awk examples/primes.awk examples/qsort.awk
+%doc %{_mandir}/man1/mawk.1
+%{_bindir}/mawk
+
+%changelog
+* Fri Oct 22 2010 - [email protected]
+- Initial version.