eel.spec
author dcarbery
Mon, 23 Oct 2006 12:46:17 +0000
branchgnome-2-14
changeset 19195 352a4716f1f3
parent 7042 79b2d7321216
child 7671 c66593d71c36
permissions -rw-r--r--
2006-10-23 Damien Carbery <[email protected]> * docs/ssa/*: Remove these, as they're now up on the JDS project pages under 'Tasks/Single Sys Admin'.

#
# spec file for package eel
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         eel
License:      LGPL
Group:        System/Libraries/GNOME
Version:      2.14.1
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Eazel Extensions Library
Source:       http://ftp.gnome.org/pub/GNOME/sources/eel/2.14/eel-%{version}.tar.bz2
URL:          http://www.gnome.org
Patch1:       eel-01-multibyte-bookmark-menu.diff	
Patch2:       eel-02-assertion.diff
Patch3:       eel-03-popup-menu-i18n.diff
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/doc
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%define libgnomeui_version 2.6.0
%define librsvg_version 2.5.0
%define libxml2_version 2.6.7
%define gnome_vfs_version 2.6.0
%define gail_version 1.6.3
%define GConf_version 2.6.1
%define gnome_desktop_version 2.1.4

BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: librsvg-devel >= %{librsvg_version}
BuildRequires: gail-devel >= %{gail_version}
BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
Requires: libgnomeui >= %{libgnomeui_version}
Requires: librsvg >= %{librsvg_version}
Requires: gail >= %{gail_version}
Requires: gnome-desktop >= %{gnome_desktop_version}

%description
This library extends the Gtk+ library with some useful routines for
applications like Nautilus.

%package devel
Summary:      Eazel Extensions Development Library
Group:        Development/Libraries/GNOME
Requires:     %{name} = %{version}
Requires:     libxml2-devel >= %{libxml2_version}
Requires:     gnome-vfs-devel >= %{gnome_vfs_version}
Requires:     GConf-devel >= %{GConf_version}

%description devel
This library extends the Gtk+ library with some useful routines for
applications like Nautilus.

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}		\
	    --sysconfdir=%{_sysconfdir}
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
rm $RPM_BUILD_ROOT%{_libdir}/*.la
                                                                                                                                                             
%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%defattr (-, root, root)
%{_libdir}/*.so.*
%{_datadir}/locale/*/LC_MESSAGES/*.mo

%files devel
%defattr (-, root, root)
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
%{_includedir}/eel-2

%changelog
* Tue Apr 11 2006 - [email protected]
- Bump to 2.14.1.

* Mon Mar 13 2006 - [email protected]
- Bump to 2.14.0.
- Remove upstream patch, 04-a11y-330995.

* Tue Feb 28 2006 - [email protected]
- Bump to 2.13.92.
- Add upstream patch, 04-a11y-330995. Fixes 330995.

* Mon Feb 13 2006 - [email protected]
- Bump to 2.13.91.

* Tue Jan 31 2006 - [email protected]
- Bump to 2.13.90.

* Tue Jan 17 2006 - [email protected]
- Bump to 2.13.4

* Tue Jan 03 2006 - [email protected]
- Bump to 2.13.3.

* Tue Nov 29 2005 - [email protected]
- Bump to 2.12.2.

* Tue Oct 11 2005 - [email protected]
- Bump to 2.12.1

* Sat Sep 17 2005 - [email protected]
- Bump to 2.12.0

* Mon Sep 05 2005 - [email protected]
- Bump to 2.11.92.

* Tue Aug 23 2005 - [email protected]
- Add gnome-desktop build and install dependencies.

* Mon Aug 15 2005 - [email protected]	
- Bump to 2.11.91.

* Wed Aug 03 2005 - [email protected]
- remove upstream patch cancel-rename.diff

* Fri May 13 2005 - [email protected]
- Bump to 2.10.1 

* Fri May 13 2005 - [email protected]
- Added patch eel-05-cancel-rename.diff, this patch does not allow
  timeout dialog to pop up if gnome-auth-mananger dialog is visible.
  Fixex bug#6264644.

* Wed Mar 23 2005 - [email protected]
- Added patch eel-04-gok-crash.diff to fix nautilus crash when 
  folder is opened with gok. Fixes bug #6234837.

* Tue Feb 15 2005 - [email protected]
- Added patch eel-03-popup-menu-i18n.diff to translate "Select All"
  and "Input Methods" messages in nautilus. Fixes bug #5072488.

* Tue Jan 25 2005 - [email protected]
- Added patch eel-02-assertion.diff to fix assertion failure
  messages in nautilus. Fixes bug #4899270.

* Mon Dec 08 2004 - [email protected]
- Added patch #01 to fix the cutoff of long multibyte directory
  bookmarks. Fixes bug #6184582. Applied to linux trunk only.

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to eel-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- ported to rpm4
                                                                                
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed May 12 2004 - [email protected]
- Updated l10n content to eel-l10n-po-1.1.tar.bz2

* Fri May 07 2004 - <[email protected]>
- Bump to 2.6.1

* Thu Apr 15 2004 - <[email protected]>
- Bump to 2.6.0

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to eel-l10n-po-1.0.tar.bz2

* Tue Mar 16 2004 - <[email protected]>
- Bump to 2.5.91

* Wed Mar 10 2004 - <[email protected]>
- Bump to version 2.5.90 and update dependency pkg versions to something
  a bit more recent.
- Remove patches, they are merged into the lastest version.

* Wed Feb 18 2004 - <[email protected]>
- Updated l10n tarball to 0.8

* Tue Feb 17 2004 - <[email protected]>
- new tarball, removed patch #3

* Thu Feb 12 2004 - <[email protected]>
- added patches 01, 02 and 03: compilation fixes, add a -uninstalled-pc file,
  fix errors in Makefile.am
- autotoolize the build stage

* Wed Jan 07 2004 - <[email protected]>
- Updated to 2.5.4

* Tue Dec 16 2003 - <[email protected]>
- Updated to 2.5.3

* Mon Oct 13 2003 - <[email protected]>
- Updated to 2.4 

* Thu Aug 14 2003 - <[email protected]>
- remove *.a, *.la

* Wed Jul 09 2003 - <[email protected]>
- add in sun po files

* Thu Jul 03 2003 - [email protected]
- version 2.2.4
* Thu May 01 2003 - [email protected]
- initial Sun release.