gcalctool.spec
author dcarbery
Mon, 23 Oct 2006 12:46:17 +0000
branchgnome-2-14
changeset 19195 352a4716f1f3
parent 7373 284aa636d250
child 7692 1b0e1c16e2be
permissions -rw-r--r--
2006-10-23 Damien Carbery <[email protected]> * docs/ssa/*: Remove these, as they're now up on the JDS project pages under 'Tasks/Single Sys Admin'.

#
# spec file for package gcalctool
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#


Name:         gcalctool
License:      GPL
Group:        System/GUI/GNOME
Version:      5.7.32
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      GNOME Calculator
Source:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/5.7/%{name}-%{version}.tar.bz2
Source1:      gnome-calculator.1.gz
Source2:      gcalctool.1.gz
Patch1:       gcalctool-01-menu-entry.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on

%define glib2_version 2.6.0
%define pango_version 1.2.5
%define gtk2_version 2.6.0
%define GConf_version 1.1.9
%define libgnome_version 2.4.0
%define scrollkeeper_version 0.3.12

Requires:       libgnome >= %{libgnome_version}
Requires:  	glib2 >= %{glib2_version}
Requires:  	gtk2 >= %{gtk2_version}
Prereq:         GConf >= %{GConf_version}
BuildRequires:  glib2-devel >= %{glib2_version}
BuildRequires:  pango-devel >= %{pango_version}
BuildRequires:  gtk2-devel >= %{gtk2_version}
BuildRequires:  GConf-devel >= %{GConf_version}
BuildRequires:  libgnome-devel >= %{libgnome_version}
BuildRequires:	scrollkeeper >= %{scrollkeeper_version}

%description
This package contains a calculator for the GNOME Desktop. This calculator
has 3 different modes - Basic, Scientific and Financial.


%prep
%setup -q
%patch1 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
	--prefix=%{_prefix} \
	--sysconfdir=%{_sysconfdir} \
        --mandir=%{_mandir} \
	--localstatedir=/var/lib
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make -i install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/man1


#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/

%clean
rm -rf $RPM_BUILD_ROOT

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS=" gcalctool.schemas "
for S in $SCHEMAS; do
        gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%files
%defattr (-, root, root)
%{_bindir}/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/omf/gcalctool
%{_datadir}/gnome/help
%{_sysconfdir}/gconf/schemas
%{_datadir}/applications
%{_mandir}/man1/

%changelog
* Fri Jun 01 2006 - [email protected]
- Add menu entry patch.

* Mon Mar 13 2006 - [email protected]
- Bump to 5.7.32.

* Mon Feb 27 2006 - [email protected]
- Bump to 5.7.30.

* Mon Feb 13 2006 - [email protected]
- Bump to 5.7.29.

* Mon Jan 30 2006 - [email protected]
- Bump to 5.7.28.

* Mon Jan 23 2006 - [email protected]
- Bump to 5.7.27.

* Fri Jan 20 2006 - [email protected]
- Bump to 5.7.26.

* Sun Jan 15 2006 - [email protected]
- Bump to 5.7.23.

* Tue Jan 03 2006 - [email protected]
- Bump to 5.7.18.

* Tue Nov 29 2005 - [email protected]
- remove javahelp stuff

* Mon Sep 05 2005 - [email protected]
- Bump to 5.6.31.

* Mon Aug 15 2005 - [email protected]
- Bump to 5.6.26.

* Fri Jul 01 2005 - [email protected]
- -02-pkgconfig patch for solaris build

* Thu May 19 2005 - [email protected]
- ported to 5.5.42

* Wed May 18 2005 - [email protected]
- Updated l10n help patch to add pt_BR

* Tue Jan 25 2005 - [email protected]
- Add patch from Rich to fix #162998.

* Fri Jan 14 2005 - [email protected]
- Updated l10n help tarball for cinnabar-linux

* Fri Nov 12 2004 - [email protected]
- Updated l10n help tarball and patch

* Thu Oct 28 2004 - [email protected]
- Updated l10n help tarball and added pt_BR

* Wed Aug 25 2004 - [email protected]
- Added l10n help contents

* Thu Aug 05 2004 - [email protected]
- Incorporate new docs tarball from [email protected].

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gcalctool-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- ported to rpm4
                                                                                
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Mon May 31 2004 - [email protected]
- Add patch gcalctool-01-update-display.diff to fix bugzilla bug #134376

* Fri May 28 2004 - [email protected]
- Incorporate new docs tarball from [email protected].

* Wed May 12 2004 - [email protected]
- Updated l10n content to gcalctool-l10n-po-1.1.tar.bz2

* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris

* Thu Apr 15 2004 - [email protected]
- Bump to 4.3.51

* Thu Apr 01 2004 - [email protected]
- javahelp conversion

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to gcalctool-l10n-po-1.0.tar.bz2

* Tue Mar 16 2004 - [email protected]
- Remove the man page and localized doc patches
  since they're upstream and we'll pick them up 
  with the next release. Bump to 4.3.50.

* Mon Mar 01 2004 - [email protected]
- fix aclocal options
- s$/usr/share/man$%{_mandir}$
- s$/usr/share%{_datadir}$

* Thu Feb 23 2004 - [email protected]
- fix non-portable tar commands

* Mon Feb 23 2004 - [email protected]
- Bump to 4.3.46, re-order patches, l10n update

* Wed Dec 17 2003 - [email protected]
- Bump to 4.3.29

* Fri Oct 31 2003 - [email protected]
- Remove the Sun Supported keyword since we're
  moving away from extras menu.

- Remove the Sun Supported keyword since we're
  moving away from extras menu.

- Remove the Sun Supported keyword since we're
  moving away from extras menu.

- Remove the Sun Supported keyword since we're
  moving away from extras menu.

* Fri Oct 10 2003 - [email protected]
- Update to 3.4.4

* Fri Aug 01 2003 - [email protected]
- Add menu entry supported category.

* Wed Jul 30 2003 - [email protected]
- New release. Bump version, reset release.

* Fri Jul 25 2003 - [email protected]
- Uses scrollkeeper for postinstall. Add a dependency

* Tue Jul 01 2003 - [email protected]
- Initial Sun release