gedit.spec
author dcarbery
Mon, 23 Oct 2006 12:46:17 +0000
branchgnome-2-14
changeset 19195 352a4716f1f3
parent 7509 33597f80a7ed
child 7751 db4707cf4d75
permissions -rw-r--r--
2006-10-23 Damien Carbery <[email protected]> * docs/ssa/*: Remove these, as they're now up on the JDS project pages under 'Tasks/Single Sys Admin'.

#
# spec file for package gedit
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:		gedit
License:	GPL
Group:		System/GUI/GNOME
Version:	2.14.3
Release:	1
Distribution:	Java Desktop System
Vendor:		Sun Microsystems, Inc.
Summary:	Text Editor for GNOME
Source:		http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.14/%{name}-%{version}.tar.bz2
Source1:	gedit.1.gz
Source2:	gnome-text-editor.1.gz
Patch1:		gedit-01-spellcheck-fallback-to-enus.diff
Patch2:		gedit-02-gtksourceview-binding.diff
Patch3:         gedit-03-no-zh_TW-help.diff
Patch4:         gedit-04-menu-entry.diff
URL:            http://www.gnome.org
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Docdir:         %{_docdir}/doc
Autoreqprov:    off
Prereq:         GConf

%define major_minor 2.12

%define eel_version 2.6.1
%define gtksourceview_version 1.0.0
%define libglade_version 2.3.6
%define libgnomeprintui_version 2.6.0
%define libgnomeui_version 2.6.0
%define scrollkeeper_version 0.3.14
%define intltool_version 0.31.3

BuildRequires: eel-devel >= %{eel_version}
BuildRequires: gtksourceview-devel >= %{gtksourceview_version}
BuildRequires: libglade-devel >= %{libglade_version}
BuildRequires: libgnomeprintui-devel >= %{libgnomeprintui_version}
BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: scrollkeeper >= %{scrollkeeper_version}
BuildRequires: intltool >= %intltool_version
Requires: eel >= %{eel_version}
Requires: gtksourceview >= %{gtksourceview_version}
Requires: libglade >= %{libglade_version}
Requires: libgnomeprintui >= %{libgnomeprintui_version}
Requires: libgnomeui >= %{libgnomeui_version}

%description
GEdit is a graphical text editor for GNOME

%package devel
Summary:      Developer files for gedit
Group:        Development/Libraries/GNOME
Requires:     %name = %version-%release

%description devel
GEdit is a graphical text editor for GNOME.  This package contains files
required for building or developing gedit plugins.

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

intltoolize --copy --force --automake
libtoolize --force
aclocal $ACLOCAL_FLAGS -I m4
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS"				\
./configure --prefix=%{_prefix}			\
	    --sysconfdir=%{_sysconfdir}		\
	    --localstatedir=%{_localstatedir}   \
	    --mandir=%{_mandir}			\
	    --disable-scrollkeeper
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1    
make DESTDIR=$RPM_BUILD_ROOT install
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL   
rm -rf $RPM_BUILD_ROOT%{_mandir}/man1
rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/man1


#remove unpackaged files
rm $RPM_BUILD_ROOT%{_libdir}/gedit-2/plugins/*.la
rm -f $RPM_BUILD_ROOT%{_libdir}/gedit-2/plugins/*.pyo
rm -f $RPM_BUILD_ROOT%{_libdir}/gedit-2/plugins/*/*.pyo

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="gedit.schemas"
for S in $SCHEMAS; do
  gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-, root, root)
%{_bindir}/*
%{_libdir}/gedit-2/plugins/*.so
%{_libdir}/gedit-2/plugins/*/*.py
%{_libdir}/gedit-2/plugins/*/*.pyc
%{_libdir}/gedit-2/plugins/*.py
%{_libdir}/gedit-2/plugins/*.pyc
%{_libdir}/gedit-2/plugins/*.gedit-plugin
%{_libdir}/gedit-2/plugins/*/*.glade
%{_sysconfdir}/gconf/schemas/gedit.schemas
%{_datadir}/applications/*.desktop
%{_datadir}/gedit-2
%{_datadir}/gnome/help/gedit
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/omf/gedit
%{_datadir}/pixmaps/*.png
%{_mandir}/man1/*

%files devel
%defattr(-, root, root)
%{_includedir}/*
%{_libdir}/pkgconfig/*

%changelog
* Fri Jun 23 2006 - [email protected]
- Bump to 2.14.3.

* Fri Jun 01 2006 - [email protected]
- Add menu entry patch.

* Mon Apr 10 2006 - [email protected]
- Bump to 2.14.2.

* Thu Mar 16 2006 - [email protected]
- Bump to 2.14.1.

* Tue Mar 14 2006 - [email protected]
- Add patch, 02-gtksourceview-binding, to skip non-existant python binding file.
  The file is not in pygtk2 like the other .defs files.
- Add patch, 03-no-zh_TW-help, to skip zh_TW help as it crashes xml2po.

* Mon Mar 13 2006 - [email protected]
- Bump to 2.14.0.

* Mon Mar  6 2006 - [email protected]
- Bump to 2.13.93.

* Mon Feb 27 2006 - [email protected]
- Bump to 2.13.92.

* Wed Feb 22 2006 - [email protected]
- Remove patch, 02-no-zh-help, as issue resolved in latest tarball.

* Tue Feb 14 2006 - [email protected]
- Bump to 2.13.91.

* Tue Jan 31 2006 - [email protected]
- Bump to 2.13.90.

* Fri Jan 27 2006 - [email protected]
- Add patch, 02-no-zh-help, to workaround #328888.

* Sat Jan 21 2006 - [email protected]
- Bump to 2.13.4

* Tue Jan 17 2006 - [email protected]
- Bump to 2.13.3

* Sun Jan 15 2006 - [email protected]
- Bump to 2.13.2

* Sat Jan 07 2006 - [email protected]
- Point aclocal to module's m4 files.

* Tue Jan 03 2006 - [email protected]
- Remove obsolete patches, 

* Tue Dec 20 2005 - [email protected]
- Bump to 2.13.0

* Tue Nov 29 2005 - laca.com
- remove javahelp stuff

* Tue Oct 11 2005 - [email protected]
- Bump to 2.12.1

* Sat Sep 17 2005 - [email protected]
- Bump to 2.12.0

* Mon Aug 15 2005 - [email protected]
- Bump to 2.11.91.

* Wed Jun 15 2005 - [email protected]
- Bump to 2.10.3

* Thu May 19 2005 - [email protected]
- Really port to 2.10.2

* Fri May 05 2005 - [email protected]
- updating l10n po tarball for CR 6265858

* Thu Mar 31 2005 - [email protected]
- Added intltoolize to get the latest intltool-update/merge to fix 
  intall errors. Fixes bug #6243610.

* Tue Jan 25 2005 - [email protected]
- Update docs with Linux specific tarball from [email protected].

* Fri Jan 14 2005 - [email protected]
- Updated l10n help tarball for cinnabar-linux
                                                                                
* Wed Dec 22 2004 - [email protected]
- Added patch gedit-11-a11y_page_setup.diff so that gnopernicus
  does not read the labels of File->Pagesetup->font tab multiple times.
  Fixes Bug #6199112.

* Wed Dec 22 2004 - [email protected]
- Added patch gedit-10-a11y_open_location.diff so that gnopernicus 
  reads the label of File->Open Location dialog. Fixes Bug #6199089. 

* Wed Nov 17 2004 - [email protected]
- #6195855, install correct manpage

* Fri Nov 12 2004 - [email protected]
- Added patch : gedit-09-spellcheck-fallback-to-enus.diff, #6194573

* Fri Nov 12 2004 - [email protected]
- Added patch : gedit-08-g11n-i18n-ms-euc.diff for bug 6194514

* Thu Oct 28 2004 - [email protected]
- Updated l10n help tarball and added pt_BR

* Fri Sep 24 2004 [email protected]
- Added patch gedit-06-help.diff to fix help issues.
  Fixes bugs #5094026,5094027,5094029,5101694.
 
* Wed Aug 25 2004 [email protected]
- Updated help tar name for Cinnabar

* Fri Aug 20 2004 [email protected]
- Integrated updated docs tarball from [email protected].

* Fri Aug 20 2004 [email protected]
- Removed  gedit-06-spellchecker-plugin.diff as it won't work on Solaris,
  and also because it has to do with a problem in aspell being built using
  a version of libtool older than 1.5.

* Fri Aug 20 2004 [email protected]
- Added gedit-06-spellchecker-plugin.diff to check the apsell library correctly
  so that spellchecker plugin is built. Fixed bug 5084894.

* Thu Aug 12 2004 [email protected]
- Added gedit-05-g11n-i18n-ui.diff to localize taglist. Fixed 5068944.

* Thu Aug 05 2004 [email protected]
- Incorporate new docs tarball from [email protected].

* Mon Jul 26 2004 - [email protected]
- added gedit-04-command-pipe.diff to fix bugtraq #5046785

* Fri Jul 23 2004 - [email protected]
- added gedit-03-g11n-utf8-autodect.diff to fix bugtraq
  5063167

* Tue Jul 20 2004 - [email protected]
- Bump to 2.6.2

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gedit-l10n-po-1.2.tar.bz2

* Thu Jul 08 2004 - [email protected]
- ported to rpm4/suse91

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Thu Jun 24 2004 - [email protected]
- Add gedit-03-g11n-i18n-ui.diff to localize open dialog. bugzilla #144525

* Wed Jun 02 2004 [email protected]
- Incorporate new docs tarball from [email protected].

* Wed May 12 2004 - [email protected]
- Updated l10n content to gedit-l10n-po-1.1.tar.bz2

* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris

* Thu Apr 01 2004 - [email protected]
- javahelp conversion

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to gedit-l10n-po-1.0.tar.bz2

* Tue Mar 17 2004 - [email protected]
- Add bak schema patch, since we still need it.

* Tue Mar 17 2004 - [email protected]
- Bump to 2.5.92. Remove man page, schema includes, pixmap sources
  build fix and desktop g11n patch.

* Mon Mar 15 2004 - [email protected]
- Replaced gedit-04-default-schemas.diff with gedit-04-g11n-schemas.diff 
  to fix 4924569 and 4996253
- Added gedit-06-g11n-desktop.diff to fix 4969602
- Added gedit-07-g11n-potfiles.diff

* Wed Feb 18 2004 - <[email protected]>
- Bump to 2.5.3, add l10n online line
- Ported default schemas patch 04

* Fri Jan 09 2004 - <[email protected]>
- Patch to remove extra includes

* Wed Dec 17 2003 - <[email protected]>
- Bump to 2.5.0

* Fri Oct 31 2003 - <[email protected]>
- Remove the Sun Supported keyword patch since we're removing
  the Extras menu.

* Tue Oct 21 2003 - <[email protected]>
- Updated to GNOME 2.4.0 version, updated POTFILES.in patch,
  and add patch to use libgnomeprintui 2.3.0 instead of 2.3.1.

* Fri Sep 26 2003 - <[email protected]>
- integrate Sun docs

* Wed Jul 09 2003 - <[email protected]>
- add in sun po files

* Wed May 14 2003 - [email protected]
- Initial Sun Release