gnome-games.spec
author dcarbery
Mon, 23 Oct 2006 12:46:17 +0000
branchgnome-2-14
changeset 19195 352a4716f1f3
parent 7526 1c45442fa37f
child 7690 fb882da4b797
permissions -rw-r--r--
2006-10-23 Damien Carbery <[email protected]> * docs/ssa/*: Remove these, as they're now up on the JDS project pages under 'Tasks/Single Sys Admin'.

#
# spec file for package gnome-games
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         gnome-games
License:      GPL
Group:        Amusements/Games
Version:      2.14.2
Release:      3
Distribution: Java Desktop System
Vendor:	      Sun Microsystems, Inc.
Summary:      GNOME games
Source:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.14/%{name}-%{version}.tar.bz2
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on
Prereq:       GConf

%define libgnomeui_version 2.2.0
%define scrollkeeper_version 0.3.11

BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: scrollkeeper >= %{scrollkeeper_version}
BuildRequires: intltool
Requires:      libgnomeui >= %{libgnomeui_version}

%description
The gnome-games package includes some small games that come with the
GNOME desktop environment but can be used under any desktop.
The games are mostly puzzle or solitaire games.

%prep
%setup -q

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

./configure --prefix=%{_prefix} 	\
	    --sysconfdir=%{_sysconfdir} \
	    --bindir=%{_bindir} \
	    --libdir=%{_libdir} \
            --includedir=%{_includedir} \
	    --libexecdir=%{_libexecdir}

make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
%makeinstall localstatedir=%{_localstatedir}/lib
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL

rm -rf $RPM_BUILD_ROOT%{_datadir}/xbill
rm -f $RPM_BUILD_ROOT%{_bindir}/gnome-xbill
rm -f $RPM_BUILD_ROOT%{_bindir}/gnometris
rm -f $RPM_BUILD_ROOT%{_datadir}/applications/gnometris.desktop
rm -f $RPM_BUILD_ROOT%{_datadir}/applications/xbill.desktop
rm -rf $RPM_BUILD_ROOT%{_datadir}/pixmaps/gnometris
rm -f $RPM_BUILD_ROOT%{_datadir}/pixmaps/xbill.png
rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gnometris.schemas
rm -f $RPM_BUILD_ROOT%{_datadir}/pixmaps/gnome-xbill.png
rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/gnometris.schemas

## things we just don't want in the package

rm -rf $RPM_BUILD_ROOT/var/lib/scrollkeeper

## install desktop files

%find_lang %{name}

#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="blackjack.schemas gataxx.schemas glines.schemas gnect.schemas gnibbles.schemas gnobots2.schemas gnomine.schemas gnotravex.schemas gtali.schemas iagno.schemas mahjongg.schemas same-gnome.schemas"
for S in $SCHEMAS; do
  gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S > /dev/null
done

%clean
rm -rf $RPM_BUILD_ROOT

%files -f %{name}.lang
%defattr(-, root, root)
%doc AUTHORS COPYING ChangeLog

# these are not setgid games
%{_bindir}/games-server.py
%{_bindir}/gnect
%{_bindir}/blackjack

%{_localstatedir}/lib

# these are setgid games
%attr(2551, root, games) %{_bindir}/gnomine
%attr(2551, root, games) %{_bindir}/same-gnome
%attr(2551, root, games) %{_bindir}/mahjongg
%attr(2551, root, games) %{_bindir}/gtali
%attr(2551, root, games) %{_bindir}/gnobots2
%attr(2551, root, games) %{_bindir}/gataxx
%attr(2551, root, games) %{_bindir}/gnotravex
%attr(2551, root, games) %{_bindir}/gnotski
%attr(2551, root, games) %{_bindir}/gnibbles
%attr(2551, root, games) %{_bindir}/glines
%attr(2551, root, games) %{_bindir}/iagno

%{_datadir}/applications
%{_datadir}/blackjack
%{_datadir}/gnect
%{_datadir}/gnibbles
%{_datadir}/gnobots2
%{_datadir}/gnome
%{_datadir}/gnome-games
%{_datadir}/locale/zh_HK/LC_MESSAGES
%{_datadir}/omf
%{_datadir}/pixmaps
%{_datadir}/sounds
%{_sysconfdir}/gconf/schemas/*
%config %{_sysconfdir}/sound/events/*

%changelog
* Mon Jun 26 2006 - [email protected]
- remove patch menu-entry.diff since gnome-games is moving back to /usr
* Fri Jun 23 2006 - [email protected]
- Bump to 2.14.2.
* Fri Apr 10 2006 - [email protected]
- Bump to 2.14.
* Mon Mar 13 2006 - [email protected]
- Bump to 2.14.
* Thu Feb 23 2006 - [email protected]
- Bump to 2.13.8.
* Mon Feb 13 2006 - [email protected]
- Bump to 2.13.7.
* Sat Jan 21 2006 - [email protected]
- Remove upstream patch, 02-illegal-cast.
* Tue Jan 17 2006 - [email protected]
- Bump to 2.13.5
* Sun Jan 15 2006 - [email protected]
- Bump to 2.13.4.
* Sat Jan 07 2006 - [email protected]
- Add patch, 02-illegal_cast, to fix compilation errors; bugzilla 326024.
* Tue Dec 20 2005 - [email protected]
- Bump to 2.13.3
* Fri Dec 02 2005 - [email protected]
- Added gnome-games-01-sfw-path.diff to use the absolute path of the 
  executable in the .desktop file as usr/sfw/bin should not be 
  included in $PATH.
  Fixes bug #6345489.
* Tue Nov 29 2005 - laca.com
- remove javahelp stuff
* Tue Nov 29 2005 - [email protected]
- Bump to 2.12.2.
* Wed Oct 12 2005 - [email protected]
- Remove patch as offending struct is no longer empty.
* Tue Oct 11 2005 - [email protected]
- Bump to 2.12.1
* Sat Sep 17 2005 - [email protected]
- Bump to 2.12.0
* Mon Sep 05 2005 - [email protected]
- Bump to 2.11.5.
* Fri Sep 02 2005 - [email protected]
- Add patch to fix zero sized struct Solaris build error.
* Wed Aug 24 2005 - [email protected]
- Add patch to remove blank line 1 from same-gnome.xml (javahelp had prob).
* Mon Aug 15 2005 - [email protected]
- Bump to 2.11.4.
* Fri May 20 2005 - [email protected]
- Bump to 2.10.1
* Wed May 11 2005 - [email protected]
- added gnome-games-05-g11n-desktop-fix.diff 
- to fix CR 6266891
* Wed Apr 27 2005 - [email protected]
- added gnome-games-04-po-install-fixes.diff for CR 6243601
* Fri Nov 12 2004 - [email protected]
- added --libdir and --bindir to configure opts so they can be redirected on
  Solaris
* Mon Sep 20 2004 - [email protected]
- removed sol from files
* Thu Sep 04 2004 - [email protected]
- packaged sol
* Thu Aug 26 2004 - [email protected]
- Put scores files in %{_localstatedir}/lib.
* Wed Aug 25 2004 - [email protected]
- Add unpackaged files to %files.
* Mon Aug 23 2004 - [email protected]
- remove auto*-jds tool dependencies
* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gnome-games-l10n-po-1.2.tar.bz2
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds
* Tue Jun 1 2004 - [email protected]
- Fix up schema install
* Wed May 12 2004 - [email protected]
- Updated l10n content to gnome-games-l10n-po-1.1.tar.bz2
* Fri May 07 2004 - [email protected]
- Bump to 2.6.1
* Wed Apr 21 2004 - [email protected]
- disable javahelp conversion for stuff not built on Solaris
* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris
* Fri Apr 02 2004 - [email protected]
- Added patch 03 to fix Solaris Makefile issue, and added libexecdir to
  configure line.
* Thu Apr 01 2004 - [email protected]
- javahelp conversion
* Mon Mar 29 2004 - [email protected]
- Updated l10n content to gnome-games-l10n-po-1.0.tar.bz2
* Wed Mar 24 2004 - [email protected]
- Use JDS autotools
* Tue Mar 23 2004 - [email protected]
- Bump to 2.6.0. Remove 2 potfile patches and 
  replace with a single one.
* Thu Mar 11 2004 - [email protected]
- added gnome-games-03-g11n-potfiles.diff
* Fri Feb 06 2004 - <[email protected]>
- Bump up 2.5.5, remove intltool-merge patch
- re-engineered patch-01, as automake etc is commented out.
- This could be changed again if automake 1.7 was being used not 1.6 !!
* Thu Jan 29 2004 - <[email protected]>
- add patch 03 for intltool-merge and dep. on intltool
* Fri Dec 29 2003 - <[email protected]>
- comment out libtool, aclocal etc. which 
  is causing build failure
* Fri Dec 29 2003 - <[email protected]>
- Bump to 2.5.3
* Wed Dec 17 2003 - <[email protected]>
- Bump to 2.5.2
* Fri Oct 31 2003 - <[email protected]>
- Remove the Sun Supported keyword from the desktop 
  files. We're removing the Extras menu.
* Wed Oct 22 2003 - <[email protected]>
- Add blackjack into the build
* Tue Oct 21 2003 - <[email protected]>
- Updated to GNOME 2.4.0 version
- Removed freecell entries
- Moved gnome-games-03-menu-entry.diff patch to 
  gnome-games-01-menu-entry.diff
- Dropped gnome-games-04-glines-preferences.diff patch.
* Thu Aug 14 2003 - <[email protected]>
- remove *.so, *.a, *.la
* Wed Aug 06 2003 - <[email protected]>
- fix glines preference dialog
* Thu Jul 17 2003 - <[email protected]>
- remove more xbill stuff
* Wed Jul 09 2003 - <[email protected]>
- add in sun po files
* Tue Jul 08 2003 - [email protected]
- Add menu icon for freecell, and add aclocal, automake checks
* Tue May 13 2003 - [email protected]
- Created new spec file for gnome-games