gnome-themes.spec
author dcarbery
Mon, 23 Oct 2006 12:46:17 +0000
branchgnome-2-14
changeset 19195 352a4716f1f3
parent 7506 e22a91ae2cf3
child 7706 2582c8fc8329
permissions -rw-r--r--
2006-10-23 Damien Carbery <[email protected]> * docs/ssa/*: Remove these, as they're now up on the JDS project pages under 'Tasks/Single Sys Admin'.

#
# spec file for package gnome-themes
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:			gnome-themes
License:		GPL
Group:			System/GUI/GNOME
Version:		2.14.2
Release:		3
Distribution:		Java Desktop System
Vendor:			Sun Microsystems, Inc.
Summary:		GNOME themes
Source:			http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.14/%{name}-%{version}.tar.bz2
Source1:                accessibility-icons.tar.gz 
Source2:                staroffice8-accessibility-icons.tar.gz
Patch1:			gnome-themes-01-accessibility-icons.diff
Patch2:			gnome-themes-02-add-so8-a11y-icons.diff
URL:			http://www.gnome.org/
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
BuildArchitectures:     noarch
Autoreqprov:		on
Prereq:                 /sbin/ldconfig

%define gtk2_engines_version 2.2.0

BuildRequires: gtk2-engines >= %{gtk2_engines_version}
BuildRequires: libgnomeui-devel
BuildRequires: intltool
Requires:      gtk2-engines >= %{gtk2_engines_version}

%description
Additional GNOME themes.

%prep
%setup -q
%patch1 -p1
%patch2 -p1
gzip -dc %SOURCE1 | tar xvf -
gzip -dc %SOURCE2 | tar xvf -


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

glib-gettextize -f
libtoolize --force
intltoolize --copy --force --automake
aclocal $ACLOCAL_FLAGS
automake -a -c -f
autoconf

export CFLAGS="$RPM_OPT_FLAGS"
./configure \
                --prefix=%{_prefix} \
                --libdir=%{_prefix}/%_lib \
                --sysconfdir=%{_sysconfdir}
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%doc AUTHORS COPYING ChangeLog NEWS README
%defattr(-, root, root)
%{_datadir}/icons/*
%{_datadir}/themes/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo

%changelog
* Fri Jun 23 2006 - [email protected]
- Bump to 2.14.2.

* Mon Mar 13 2006 - [email protected]
- Bump to 2.14.0.

* Mon Feb 27 2006 - [email protected]
- Bump to 2.13.90.

* Tue Jan 31 2006 - [email protected]
- Bump to 2.13.90.

* Wed Dec 21 2005 - [email protected]
- Bump to 2.13.2

* Tue Oct 11 2005 - [email protected]
- Bump to 2.12.1

* Sat Sep 17 2005 - [email protected]
- Bump to 2.12.0

* Mon Aug 15 2005 - [email protected]
- Bump to 2.11.91.

* Fri May 27 2005 - [email protected]
- Add high contrast StarOffice8 icons, which were previously
  installed by staroffice-menuintegration. (Any upstream version
  of this patch should probably be tailored to OpenOffice 2.0)
  Fixes 6273621.

* Fri May 06 2005 - [email protected]
- Bump to 2.10.1

* Wed Apr 20 2005 - [email protected]
- Add high and low contrast launch menu backgrounds and spinners,
  and fix a minor typo in patch 06 that was generating a warning.
  Fixes 5072859, 6255199, and at the very least downgrades
  5072848.

* Fri Apr 08 2005 - [email protected]
- Remove icons being installed into some of the icon
  themes, when they aren't different from the original
  hicolor theme. The correct fix was to install them into 
  hicolor theme in the panel source.

* Thu Apr 07 2005 - [email protected]
- Added gnome-themes-06-add-printer-icons.diff and
  updated ext-sources/gnome-themes-icons.tar.gz to install
  printer icons in order to fix #5035243.

* Wed Feb 23 2005 - [email protected]
- Added gnome-themes-05-add-missing-hc-launch-icons.diff 
  to add some missing High Contrast and High Contrast Inverse
  icons to the launch menu; fixes CR 6219531.

* Thu Feb 10 2005 - [email protected]
- Updated gnome-themes-04-add-panel-icons.diff and
  ext-sources/gnome-themes-icons.tar.gz to include
  gnome-main-menu.png.

* Fri Jan 28 2005 - [email protected]
- Added gnome-themes-04-add-panel-icons.diff and
  ext-sources/gnome-themes-icons.tar.gz to install panel
  icons in order to fix #5088581.

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gnome-themes-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- ported to rpm4
                                                                                
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Fri Jun 25 2004 - [email protected]
- run glib-gettextize and intltoolize

* Tue Jun 8 2004 - [email protected]
- Bump to 2.6.2

* Tue Jun 1 2004 - [email protected]
- Bump to 2.6.1

* Wed May 12 2004 - [email protected]
- Updated l10n content to gnome-themes-l10n-po-1.1.tar.bz2

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to gnome-themes-l10n-po-1.0.tar.bz2

* Fri Mar 12 2004 - <[email protected]>
- remove "rm -rf" from install stage.

* Fri Feb 06 2004 - <[email protected]>
- Bump to 2.5.4, remove gnome-theme-02-intltool-merge.diff

* Thu Jan 29 2004 - <[email protected]>
- add patch 02 for intltool-merge and dep. on intltool

* Mon Dec 15 2003 - [email protected]
- Bump to 2.5.1

* Tue Oct 20 2003 - [email protected]
- New tarball. Whee.

* Thu Aug 14 2003 - <[email protected]>
- remove *.a, *.la

* Wed Jul 09 2003 - <[email protected]>
- add in sun po files

* Thu Jul 03 2003 - [email protected]
- Actually install the engines 

* Tue Jul 01 2003 - [email protected]
- New tarball, bump version, reset release

* Wed May 14 2003 - [email protected]
- initial release