gnome-utils.spec
author dcarbery
Mon, 23 Oct 2006 12:46:17 +0000
branchgnome-2-14
changeset 19195 352a4716f1f3
parent 7200 e0903c1a8112
child 7743 b9bc3fb4d8b2
permissions -rw-r--r--
2006-10-23 Damien Carbery <[email protected]> * docs/ssa/*: Remove these, as they're now up on the JDS project pages under 'Tasks/Single Sys Admin'.

#
# spec file for package gnome-utils
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         gnome-utils
License:      GPL
Group:        System/GUI/GNOME
Version:      2.14.0
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Basic Utilities for the GNOME 2.0 Desktop
Source:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.14/%{name}-%{version}.tar.bz2
Source1:      gnome-search-tool.1.gz
Source2:      gfloppy.1.gz
Source3:      gnome-dictionary.1.gz
Source4:      gnome-screenshot.1.gz
Patch1:       gnome-utils-01-logview.diff
Patch2:       gnome-utils-02-gfloppy-permission.diff
Patch3:       gnome-utils-03-gnome-screenshot.diff
Patch4:       gnome-utils-04-gnome-dictionary.diff
Patch5:       gnome-utils-05-search-menu-entry.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on
Prereq:       GConf

%define glib2_version 2.4.0
%define pango_version 1.4.0
%define gtk2_version 2.4.0
%define libgnome_version 2.6.0
%define libgnomeui_version 2.6.0
%define gail_version 1.6.3
%define gnome_panel_version 2.6.1
%define scrollkeeper_version 0.3.14

Requires:       libgnome >= %{libgnome_version}
Requires:       libgnomeui >= %{libgnomeui_version}
BuildRequires:  glib2-devel >= %{glib2_version}
BuildRequires:  pango-devel >= %{pango_version}
BuildRequires:  gtk2-devel >= %{gtk2_version}
BuildRequires:  libgnome-devel >= %{libgnome_version}
BuildRequires:  libgnomeui-devel >= %{libgnomeui_version}
BuildRequires:  gail-devel >= %{gail_version}
BuildRequires:  gnome-panel >= %{gnome_panel_version}
BuildRequires:  scrollkeeper >= %{scrollkeeper_version}
BuildRequires:  e2fsprogs-devel

%description
This package contains some essential utilities for the GNOME2 Desktop.


%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
	--prefix=%{_prefix} \
	--sysconfdir=%{_sysconfdir} \
        --libexecdir=%{_libexecdir} \
        --mandir=%{_mandir} \
	--disable-scrollkeeper
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make -i install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE4 $RPM_BUILD_ROOT%{_mandir}/man1

#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/

rm -rf $RPM_BUILD_ROOT/usr/var/scrollkeeper
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
rm -f $RPM_BUILD_ROOT%{_libdir}/*.a

%clean
rm -rf $RPM_BUILD_ROOT

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="gdict.schemas gfloppy.schemas gnome-screenshot.schemas gnome-search-tool.schemas logview.schemas"
for S in $SCHEMAS; do
        gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%files
%defattr (-, root, root)
%{_bindir}/*
%{_libdir}/bonobo/servers/*
%{_libdir}/lib*.so.*
%{_libexecdir}/*
%{_datadir}/applications
%{_datadir}/gnome/help
%{_datadir}/gnome-2.0/ui/*
%{_datadir}/gnome-screenshot/
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/gnome-utils
%{_datadir}/pixmaps
%{_datadir}/gnome-dictionary
%{_datadir}/gnome-system-log
%{_datadir}/gdict-1.0
%{_datadir}/omf
%{_mandir}/man1/*
%{_sysconfdir}/gconf/schemas
#FIXME: -devel subpkg?
%{_includedir}/*
%{_datadir}/gtk-doc
%{_libdir}/pkgconfig

%changelog
* Wed May 05 2006 - [email protected]
- Add patch to call things 'Find Files...'

* Fri Apr 21 2006 - [email protected]
- Add patch 4 to correct a core dumping problem with gnome-dictionary,
  printing a NULL string.

* Mon Mar 13 2006 - [email protected]
- Bump to 2.14.0.

* Sun Mar  5 2006 - [email protected]
- Bump to 2.13.95.

* Fri Feb 24 2006 - [email protected]
- Bump to 2.13.93.

* Mon Feb 13 2006 - [email protected]
- Bump to 2.13.92.

* Mon Jan 30 2006 - [email protected]
- Bump to 2.13.91.

* Tue Jan 17 2006 - [email protected]
- Bump to 2.13.5

* Sun Jan 15 2006 - [email protected]
- Bump to 2.13.4

* Tue Dec 20 2005 - [email protected]
- Bump to 2.13.3.

* Tue Nov 29 2005 - laca.com
- remove javahelp stuff

* Tue Nov 29 2005 - [email protected]
- Bump to 2.12.2.

* Tue Oct 11 2005 - [email protected]
- Bump to 2.12.1
- Remove javahelp code. No longer used.

* Sat Sep 17 2005 - [email protected]
- Bump to 2.12.0

* Mon Sep 05 2005 - [email protected]
- Bump to 2.11.92.

* Mon Aug 15 2005 - [email protected]
- Bump to 2.11.91.

* Thu Aug 04 2005 - [email protected]
- remove upstream patch searchtool-ceasing.diff

* Mon May 23 2005 - [email protected]
- Move the screenshot stuff here

* Wed May 18 2005 - [email protected]
- Updated l10n help patch to add gfloppy help file

* Wed May 11 2005 - [email protected]
- Bump to 2.10.1
 
* Fri May 06 2005 - [email protected]
- Added patch gnome-utils-10-searchtool-ceasing.diff to fix searchtool ceasing to
  search after entering a regular expression. Fixes #6262944. 

* Mon May 02 2005 - [email protected]
- Added patch gnome-utils-09-gfloppy-permission.diff to fix 6222777.
 
* Fri Apr 22 2005 - [email protected]
- Updated docs tarball (gnome-utils_docs-0.9linux) from [email protected].

* Tue Apr 05 2005 - [email protected]
- Updated docs tarball (gnome-utils_docs-0.8linux) from [email protected].

* Thu Mar 31 2005 - [email protected]
- Updated docs tarball (gnome-utils_docs-0.7linux) from [email protected].

* Wed Mar 16 2005 - [email protected]
- Added patch which fixes the issue of opening a directory in nautilus
  when double clicked in case of multihead. Fixes #6234957.

* Wed Feb 28 2005 - [email protected]
- Update docs with tarball (_docs-0.6linux) from [email protected].

* Fri Feb 11 2005 - [email protected]
- Added patch to correct the behaviour of searchtool with
  regular expressions involving '?'.Fixes #6227053.

* Thu Feb 10 2005 - [email protected]
- Add patch to fix gdict tooltip. Fixes #4918783.

* Wed Jan 26 2005 - [email protected]
- Update docs with Linux specific tarball from [email protected].

* Fri Jan 14 2005 - [email protected]
- Updated l10n help tarball for cinnabar-linux
                                                                                
* Fri Nov 12 2004 - [email protected]
- Updated l10n help tarball and patch

* Thu Oct 28 2004 - [email protected]
- Updated l10n help tarball and added pt_BR

* Wed Aug 25 2004 [email protected]
- Updated l10n help contents for Cinnabar with patch

* Thu Aug 05 2004 [email protected]
- Incorporate new docs tarball from [email protected].

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gnome-utils-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed Jun 02 2004 [email protected]
- Incorporate new docs tarball from [email protected].

* Thu May 27 2004 - [email protected]
- Incorporate new docs tarball from [email protected].

* Tue May 25 2004 - [email protected]
- Added gnome-utils-04-g11n-potfiles.diff

* Wed May 12 2004 - [email protected]
- Updated l10n content to gnome-utils-l10n-po-1.1.tar.bz2

* Mon May 10 2004 - [email protected]
- added patch gnome-utils-03-gdict-applet-load.diff to fix 5030822.
 
* Fri May 07 2004 - [email protected]
- Bump to 2.6.2

* Wed Apr 21 2004 - [email protected]
- disable javahelp conversion of gfloppy docs on Solaris

* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris

* Thu Apr 01 2004 - [email protected]
- javahelp conversion

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to gnome-utils-l10n-po-1.0.tar.bz2

* Wed Mar 24 2004 - [email protected]
- Bump to 2.6.0. Refactor potfiles patch, remove ui
  and man page patches.

* Mon Mar 15 2004 - [email protected]
- Added gnome-utils-03-g11n-potfiles.diff
- Added gnome-utils-04-g11n-i18n-ui.diff to fix 4954404

* Tue Feb 24 2004 - [email protected]
- Dump all Matt's work on the patches since we've 
  merged most of them upstream. Some of them don't
  apply to HEAD.

* Mon Feb 23 2004 - [email protected]
- Bump to 2.5.2
- Remerge patch 01/02
- Port patches 03/04/05
- Update %files

* Thu Jan 08 2004 - [email protected]
- Fix incorrect pango version 1.30 -> 1.3.1

* Wed Dec 17 2003 - [email protected]
- Bump to 2.5.0

* Wed Nov 04 2003 - [email protected]
- Remove the dictionary application, but retain
  the applet

* Fri Oct 31 2003 - [email protected]
- Remove the Sun Supported keyword from the
  desktop since we're removing Extras menu.

* Sat Oct 18 2003 - [email protected]
- update patches

* Sat Oct 18 2003 - [email protected]
- update to 2.4.0

* Fri Sep 26 2003 - [email protected]
- integrate Sun docs

* Tue Sep 09 2003 - [email protected]
- patch from wipro to stop defunct processes

* Thu Aug 07 2003 - [email protected]
- added scrollkeeper to base dependencies

* Thu Jul 17 2003 - [email protected]
- Don't install a non-existant logview schema.

* Wed Jul 09 2003 - <[email protected]>
- add in sun po files

* Mon Jul 07 2003 - [email protected]
- Do not install gnome-system-log either

* Tue Jul 01 2003 - [email protected]
- Correct gfloppy icon

* Tue Jul 01 2003 - [email protected]
- Disable gcalc, gcharmap & gdialog from build.

* Tue Jul 01 2003 - [email protected]
- Update version on tarball

* Tue May 13 2003 - [email protected]
- Initial Sun release