gnome-volume-manager.spec
author dcarbery
Mon, 23 Oct 2006 12:46:17 +0000
branchgnome-2-14
changeset 19195 352a4716f1f3
parent 19106 f9b9e050b4d7
child 7839 83afe8589a89
permissions -rw-r--r--
2006-10-23 Damien Carbery <[email protected]> * docs/ssa/*: Remove these, as they're now up on the JDS project pages under 'Tasks/Single Sys Admin'.

#
# spec file for package gnome-volume-manager
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         gnome-volume-manager
License:      GPL
Group:        System/GUI/GNOME
Version:      1.5.15
Release:      2
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      The GNOME 2.x Display Manager
Source:       http://ftp.gnome.org/pub/GNOME/sources/gnome-volume-manager/1.5/gnome-volume-manager-%{version}.tar.bz2
Patch1:       gnome-volume-manager-01-fixcompile.diff
Patch2:       gnome-volume-manager-02-autoplay.diff
Patch3:       gnome-volume-manager-03-libexec.diff
URL:          www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}
Autoreqprov:  on
Prereq:       /usr/sbin/groupadd
Prereq:       /usr/sbin/useradd
Prereq:       /sbin/nologin
Prereq:       sed
Prereq:       coreutils

%description
GNOME daemon that acts as a policy agent on top of the kernel, udev, d-bus, and HAL.  It supports automount of new media and hot-plugged devices, autorun, autoplay for CD's and DVD's, and automatic camera management.

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

export CFLAGS="$RPM_OPT_FLAGS"
autoheader
autoconf
libtoolize --force
glib-gettextize -c -f
intltoolize --copy --force --automake
aclocal $ACLOCAL_FLAGS
autoconf
autoheader
automake -a -c -f
%ifos solaris
ENABLE_MULTIUSER=--enable-multiuser=no
%else
ENABLE_MULTIUSER=--enable-multiuser=yes
%endif 

./configure \
	--prefix=%{_prefix} \
	--sysconfdir=%{_sysconfdir} \
	--localstatedir=/var/lib \
	--mandir=%{_mandir} \
	--libexecdir=%{_libexecdir} $ENABLE_MULTIUSER
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL

%clean
rm -rf $RPM_BUILD_ROOT

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="gnome-volume-manager.schemas"
for S in $SCHEMAS; do
        gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%files
%config %attr(-,gdm,gdm) %{_sysconfdir}/X11/gdm
%config %attr(-,root,root) %{_sysconfdir}/X11/dm
%{_datadir}/locale/*/LC_MESSAGES/gdm*.mo
%{_sbindir}/*
%{_bindir}/*
%{_libdir}/gtk-2.0/modules/*.so
%{_libexecdir}/*
%{_datadir}/gdm
%{_datadir}/applications/*
%{_datadir}/pixmaps/*.png
%{_datadir}/pixmaps/faces/*.jpg
%{_datadir}/pixmaps/faces/*.png
%{_datadir}/icons
%{_datadir}/gnome/help/*
%{_datadir}/xsessions/*
%{_mandir}/man1/*
%{_datadir}/omf/*
%attr(-,gdm,gdm) /var/lib/gdm
%config /etc/pam.d/*
%config /etc/security/*

%changelog
* Tue Jul 25 2006 - <[email protected]>
- Move gnome-volume-manager to libexec.
* Fri Jul 14 2006 - <[email protected]>
- Add patch to use sound-juicer as autoplay for CD's.
* Tue May 02 2006 - <[email protected]>
- Fix gconf stuff.
* Mon May 01 2006 - <[email protected]>
- Created