howl.spec
author dcarbery
Mon, 23 Oct 2006 12:46:17 +0000
branchgnome-2-14
changeset 19195 352a4716f1f3
parent 5518 235b0b4aa324
permissions -rw-r--r--
2006-10-23 Damien Carbery <[email protected]> * docs/ssa/*: Remove these, as they're now up on the JDS project pages under 'Tasks/Single Sys Admin'.

#
# spec file for package howl
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         howl
License:      Other
Group:        System/Libraries
Version:      1.0.0
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Cross platform implementation of Zeroconf networking
Source:       http://www.porchdogsoft.com/download/%{name}-%{version}.tar.gz
URL:          http://www.porchdogsoft.com/products/howl/
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:	      %{_defaultdocdir}/doc
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%description
Howl is a cross-platform implementation of Zeroconf networking. Zeroconf brings 
a new ease of use to IP networking.

%package devel
Summary:      Cross platform implementation of Zeroconf networking
Group:        Development/Libraries
Requires:     %{name} = %{version}

%description devel
Howl is a cross-platform implementation of Zeroconf networking. Zeroconf brings 
a new ease of use to IP networking.

%prep
%setup -q

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi
CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}		\
            --sysconfdir=%{_sysconfdir} \
            --libexecdir=%{_libexecdir} \
	    --mandir=%{_mandir}		\
            --enable-gtk-doc
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
rm $RPM_BUILD_ROOT%{_libdir}/libhowl*.a
rm $RPM_BUILD_ROOT%{_libdir}/libhowl*.la
rm $RPM_BUILD_ROOT%{_libdir}/libmDNSResponder*.a
rm $RPM_BUILD_ROOT%{_libdir}/libmDNSResponder*.la

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%clean 
rm -rf $RPM_BUILD_ROOT

%files 
%defattr(-, root, root)
%{_bindir}/*
%{_libdir}/libhowl.so.*
/usr/lib/libmDNSResponder.so.*

%files devel
%defattr(-, root, root)
%{_includedir}/howl/*
%{_libdir}/pkgconfig/*
%{_libdir}/*.so
%{_datadir}/howl/*
%{_datadir}/man/*

%changelog
* Wed Jun 15 2005 - [email protected]
- Bump to 1.0.0

* Tue May 17 2005 - [email protected]
- add %{_libdir}/*.so to devel

* Thu May 12 2005 - [email protected]
- Initial spec file for howl.