libbonoboui.spec
author dcarbery
Mon, 23 Oct 2006 12:46:17 +0000
branchgnome-2-14
changeset 19195 352a4716f1f3
parent 6952 2cdd272c838c
child 7878 2bb7a2c1914f
permissions -rw-r--r--
2006-10-23 Damien Carbery <[email protected]> * docs/ssa/*: Remove these, as they're now up on the JDS project pages under 'Tasks/Single Sys Admin'.

#
# spec file for package libbonoboui 
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         libbonoboui 
License:      LGPL
Group:        System/Libraries/GNOME 
Version:      2.14.0
Release:      2
Distribution: Java Desktop System
Vendor:	      Sun Microsystems, Inc.
Summary:      Bonobo Base User Interface Library
Source:       http://ftp.gnome.org/pub/GNOME/sources/libbonoboui/2.14/libbonoboui-%{version}.tar.bz2 
Source1:      libbonoboui-2.3.gz
Patch1:	      libbonoboui-01-solaris-backcompat.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:	      %{_defaultdocdir}/doc
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%define libgnomecanvas_version 2.6.0
%define libglade_version 2.3.6
%define libbonobo_version 2.6.0
%define libgnome_version 2.6.0

Requires: libgnomecanvas >= %{libgnomecanvas_version}
Requires: libbonobo >= %{libbonobo_version}
Requires: libglade >= %{libglade_version}
Requires: libgnome >= %{libgnome_version}
BuildRequires: libgnomecanvas-devel >= %{libgnomecanvas_version}
BuildRequires: libbonobo-devel >= %{libbonobo_version}
BuildRequires: libglade-devel >= %{libglade_version}
BuildRequires: libgnome-devel >= %{libgnome_version}

%description
libbonoboui is one of the base user interface libraries for the GNOME Desktop, containing
convenient API for writing reusable components.

%package devel
Summary:      Bonobo Base User Interface Development Library
Group:        Development/Libraries/GNOME
Requires:     %name = %version-%release
Requires:     libbonobo-devel >= %{libbonobo_version}

%description devel
libbonoboui is one of the base user interface libraries for the GNOME Desktop, containing
convenient API for writing reusable components.

%prep
%setup -q
%ifos solaris
%patch1 -p1
%endif

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS -I .
autoheader
automake -a -c -f
autoconf
CFLAGS="$RPM_OPT_FLAGS"		\
./configure --prefix=%{_prefix}		\
            --sysconfdir=%{_sysconfdir} \
            --libexecdir=%{_libexecdir} \
            --enable-gtk-doc
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
install -d $RPM_BUILD_ROOT/usr/share/man/man3
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT/usr/share/man/man3
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*.la
rm $RPM_BUILD_ROOT%{_libdir}/libglade/2.0/*.a
rm $RPM_BUILD_ROOT%{_libdir}/libglade/2.0/*.la
rm $RPM_BUILD_ROOT%{_datadir}/applications/*

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%{_datadir}/locale/*/LC_MESSAGES/libbonoboui-2.0.mo
%{_libdir}/libbonoboui-2*so.*
%{_libdir}/libglade/2.0/libbonobo*so*

%files devel
%{_bindir}/test-moniker
%{_bindir}/bonobo-browser
%{_includedir}/libbonoboui-2.0/*.h
%{_includedir}/libbonoboui-2.0/bonobo/*.h
%{_libdir}/libbonoboui-2*so
%{_libdir}/bonobo-2.0/samples/*
%{_libdir}/bonobo/servers/*.server
%{_datadir}/gnome-2.0/ui/*.xml
%{_libdir}/pkgconfig/*.pc
%{_datadir}/gtk-doc/html/*
%{_mandir}/man3/*.gz

%changelog
* Wed Mar 15 2006 - [email protected]
- Bump to 2.14.0.

* Tue Feb 21 2006 - [email protected]
- Specify --libexecdir in configure to have correct path in CanvDemo.server 
  file.

* Tue Jan 17 2006 - [email protected]
- Bump to 2.13.1

* Wed Dec 21 2005 - [email protected]
- Bump to 2.13.0.

* Tue Sep 27 2005 - [email protected]
- Bump to 2.10.1.

* Mon Aug 15 2005 - [email protected]
- Bump to 2.10.0.

* Wed Jun 15 2005 - [email protected]
- Add more libs to LDADD so that it builds with the new pkgconfig

* Thu May 19 2005 - [email protected]
- Added patch libbonoboui-05-nautilus-crash.diff to fix a nauitlus crash 
  Bug #6250742.

* Fri May 06 2005 - [email protected]
- Bump to 2.8.1

* Thu Jan 13 2005 - [email protected]
- URL updated.

* Wed Nov 23 2004 - [email protected]
- Added patch 4 to support bonobo UI xml integration point that we
  used in GNOME 2.0.

* Wed Aug 18 2004 - [email protected]
- added --enable-gtk-doc

* Thu Aug 12 2004 - [email protected]
- Added libbonoboui-03-g11n-i18n-ui.diff to localize Evolution help menu. 
- Fixed 5078956.

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to libbonoboui-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- Ported to rpm4

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Fri Jun 25 2004 - [email protected]
- Added patch libbonoboui-02-gmessage.diff to fix a crash 
  in ggv. Bug #5052487.

* Wed May 12 2004 - [email protected]
- Updated l10n content to libbonoboui-l10n-po-1.1.tar.bz2

* Tue Apr 06 2004 - [email protected]
- Bump to 2.6.0, remove uninstalled pc patch, rename
  potfiles and remove broken g11n-ui patch.

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to libbonoboui-l10n-po-1.0.tar.bz2

* Mon Mar 22 2004 - <[email protected]>
- Added libbonoboui-03-g11n-i18n-ui.diff to fix 4955030

* Wed Feb 11 2004 - <[email protected]>
- Bump to 2.5.2, add l10n-07 tarball, and manpage.
  Port 02-potfiles_in patch

* Fri Feb 06 2004 - <[email protected]>
- add ACLOCAL_FLAGS to aclocal invocation

* Tue Jan 13 2004 - <[email protected]> 2.5.1-1
- Update to 2.5.1

* Thu Oct 09 2003 - <[email protected]> 2.4.0-1
- Update to 2.4.0

* Thu Aug 14 2003 - <[email protected]>
- move lib*.so to -devel, remove *.a, *.la

* Tue Aug 12 2003 - <[email protected]> 2.2.4-1
- Upgrade to 2.2.4

* Fri Aug 01 2003 - <[email protected]> 2.2.3-1
- Upgrade to 2.2.3

* Wed Jul 09 2003 - <[email protected]>
- add in sun po files

* Tue May 13 2003 - <[email protected]>
- Create new spec file for libbonoboui