libcdio.spec
author dcarbery
Mon, 23 Oct 2006 12:46:17 +0000
branchgnome-2-14
changeset 19195 352a4716f1f3
parent 7507 634844f1769a
child 8467 3d3ded076d56
permissions -rw-r--r--
2006-10-23 Damien Carbery <[email protected]> * docs/ssa/*: Remove these, as they're now up on the JDS project pages under 'Tasks/Single Sys Admin'.

#
# spec file for package libcdio
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Note Patch libcdio-01-noc++lib.diff is used to turn off building
# and installing of the C++ includes and library.  These are just
# C++ interfaces so C++ programs can access the libcdio interfaces.
# We have to turn these off because since we build this with gcc, we 
# can not ship C++ interfaces.  Also, Forte C++ compiler has more
# problems than the Forte C compiler with recognizing flexible arrays.
# If these issues get resolved, then we could start shipping the
# libcdio C++ code.

Name:         libcdio
License:      LGPL
Group:        System Environment/Libraries
Version:      0.77
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Utilities for CD interaction
Source:       http://ftp.gnu.org/gnu/libcdio/%{name}-%{version}.tar.gz
Patch1:       libcdio-01-noc++lib.diff
URL:          http://ftp.gnu.org/
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on

%description
Utilities for CD interaction

%package devel
Summary: Headers for developing programs that will use libcdio
Group:      Development/Libraries
Requires:   %{name}

%description   devel
This package contains the headers that programmers will need to develop
applications which will use libcdio.

%prep
%setup -q
%patch1 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS -I .
automake -a -c -f
autoconf
  ./configure \
	--prefix=%{_prefix} \
	--sysconfdir=%{_sysconfdir} \
	--mandir=%{_mandir} \
	--disable-cpp-progs
make -j $CPUS

%install
make -i install DESTDIR=$RPM_BUILD_ROOT

#Clean up unpackaged files
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*la

%clean
rm -rf $RPM_BUILD_ROOT

%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig

%files
%defattr (-, root, root)
%{_libdir}/*.so.*

%files devel
%defattr(-, root, root)
%{_libdir}/*.so

%changelog
* Tue Mar 22 2006 - [email protected]
- Initial spec file checkin