libical.spec
author dcarbery
Mon, 23 Oct 2006 12:46:17 +0000
branchgnome-2-14
changeset 19195 352a4716f1f3
parent 6095 9b5695a63003
child 8465 a5ba59d8de94
permissions -rw-r--r--
2006-10-23 Damien Carbery <[email protected]> * docs/ssa/*: Remove these, as they're now up on the JDS project pages under 'Tasks/Single Sys Admin'.

#
# spec file for package libical
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

Name:         libical
License:      LGPL
Group:        System/Libraries
Version:      0.23
Release:      52
Distribution: Java Desktop System
Vendor:	      Sun Microsystems, Inc.
Summary:      A library for iCal (RFC2445) parsing
Source:       http://www.softwarestudio.org/download/libical-%{version}.tar.gz
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%description
This package contains iCal (RFC2445) parser and other relevant 
routines and data structures.

%prep
%setup -q


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
    --prefix=%{_prefix} \
    --libdir=%{_libdir} \
    --enable-python_bindings=no

make -j $CPUS

%install
make install DESTDIR=$RPM_BUILD_ROOT
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%defattr(-,root,root)
%doc AUTHORS ChangeLog COPYING THANKS NEWS README TODO
%{_libdir}/*.so*
%{_includedir}/*

%changelog
* Fri Jul 09 2004 - [email protected]
- ported to rpm4

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed Feb 18 2004 - <[email protected]>
- Update Distro to Cinnabar

* Thu Aug 14 2003 - <[email protected]>
- remove *.a, *.la

* Fri Jul 11 2003 - <[email protected]>
- Initial spec file