openh323.spec
author dcarbery
Mon, 23 Oct 2006 12:46:17 +0000
branchgnome-2-14
changeset 19195 352a4716f1f3
parent 5564 d324f371b995
permissions -rw-r--r--
2006-10-23 Damien Carbery <[email protected]> * docs/ssa/*: Remove these, as they're now up on the JDS project pages under 'Tasks/Single Sys Admin'.

#
# spec file for package openh323
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:		openh323
License: 	MPL
Group: 		System Environment/Libraries
Version: 	1.15.3
Release: 	34
Distribution: 	Java Desktop System
Vendor:       	Sun Microsystems, Inc.
Summary: 	Library for H323 spec.
URL: 		http://www.openh323.org/
Source0: 	http://www.openh323.org/bin/%{name}-%{version}.tar.bz2
# WTF??
Patch1:  	openh323-01-libname.diff
BuildRoot: 	%{_tmppath}/%{name}-root
Docdir:		%{_defaultdocdir}/doc
Prereq:         /sbin/ldconfig

%define pwlib_version 1.8.4
%define xfee86_version 4.3.0

Requires: pwlib >= %{pwlib_version}
BuildRequires: pwlib-devel >= %{pwlib_version}
BuildRequires: XFree86-devel >= %{xfree86_vresion}

%description
Implementation of the ITU H.323 teleconferencing protocol.

%package devel
Summary: Development package for openh323
Group: Development/Libraries
Requires: openh323 = %{version}

%description devel
Static libraries and header files for development with openh323.

%prep
%setup -q
%patch1 -p1 


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

(mkdir pwlibdir; cd pwlibdir;
ln -s %{_datadir}/pwlib/make make
ln -s %{_datadir} share
ln -s %{_includedir} include
ln -s %{_libdir} lib
#mkdir -p tools
#ln -s %{_bindir}/asnparser tools/asnparser
ln -s %{_bindir} bin
)

export PWLIBDIR=`pwd`/pwlibdir
export PWLIB_BUILD="yes"
export PTLIB_CONFIG=`which ptlib-config`

./configure --prefix=%{_prefix} 	\
	--sysconfdir=%{_sysconfdir}
	

make optshared

%install
mkdir -p $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/openh323,%{_bindir},%{_datadir}/misc}
cp -d lib/lib*.so* $RPM_BUILD_ROOT%{_libdir}
install include/*.h $RPM_BUILD_ROOT%{_includedir}/openh323

sed -e's@\$(OPENH323DIR)/include@&/openh323@' < openh323u.mak \
	> $RPM_BUILD_ROOT%{_datadir}/misc/openh323u.mak

%clean
rm -rf $RPM_BUILD_ROOT

%post 
/sbin/ldconfig

%postun 
/sbin/ldconfig

%files
%defattr(-,root,root)
%doc ReadMe.txt mpl-1.0.htm
%{_libdir}/*.so.*

%files devel
%defattr(-,root,root)
%{_libdir}/*.so
%{_includedir}/*
%{_datadir}/misc/*

%changelog
* Wed Jun 22 2005 - [email protected]
- Bump to 1.15.3

* Mon Sep 20 2004 - [email protected]
- fixed typo in changelog

* Wed Sep 15 2004 - [email protected]
- Upreved to 1.13.4 and removed all the Solaris specific patches.
  so that it can be built for gm-1.0.2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Fri Apr 09 2004 - [email protected]
- Added needed Solaris patch 05.

* Thu Apr 06 2004 - [email protected]
- Added needed Solaris patches 02, 03, 04.

* Fri Feb 27 2004 - [email protected]
  - Built tarball 1.13.2 for g-m 1.0

* Fri Feb 27 2004 - [email protected]
- Update Distro

* Thu Feb 26 2004 - [email protected]
  - Updated tarballs to 1.12.2

* Wed Jul 16 2003 - [email protected]
- Initial Sun Release