perl-XML-Simple.spec
author dcarbery
Mon, 23 Oct 2006 12:46:17 +0000
branchgnome-2-14
changeset 19195 352a4716f1f3
parent 6923 45fbffcf5f44
permissions -rw-r--r--
2006-10-23 Damien Carbery <[email protected]> * docs/ssa/*: Remove these, as they're now up on the JDS project pages under 'Tasks/Single Sys Admin'.

#
# spec file for package perl-XML-Simple
#
# includes module(s): Perl XML::Simple module
#
# Copyright (c) 2006 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

Name:                    perl-XML-Simple
Summary:                 XML::Simple PERL modules
Version:                 2.14
Release:		 1
Source:                  http://search.cpan.org/CPAN/authors/id/G/GR/GRANTM/XML-Simple-%{version}.tar.gz
BuildRoot:               %{_tmppath}/%{name}-%{version}-build
Group:			 Development/Languages/Perl
License:		 Public Domain
Requires:                perl
Requires:		 expat

%define perl_version %(cd %{_libdir}/perl5/vendor_perl && echo 5.?.?)
%define picflags -fpic

%description
Simple XML Parser module for Perl.

%prep
%setup -q -n XML-Simple-%version

%build
export CC=gcc
perl Makefile.PL \
    PREFIX=%{_prefix} \
    INSTALLSITELIB=%{_libdir}/perl5/vendor_perl/%{perl_version} \
    INSTALLSITEARCH=%{_libdir}/perl5/vendor_perl/%{perl_version} \
    INSTALLSITEMAN1DIR=%{_mandir}/man1 \
    INSTALLSITEMAN3DIR=%{_mandir}/man3 \
    INSTALLMAN1DIR=%{_mandir}/man1 \
    INSTALLMAN3DIR=%{_mandir}/man3
make CC=$CC CCCDLFLAGS="%picflags" OPTIMIZE="%optflags" LD=$CC

%install
make install DESTDIR=$RPM_BUILD_ROOT

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%{_libdir}/perl5
%{_mandir}/man3/*

%changelog
* Fri Mar 10 2006 - [email protected]
- initial version added to CVS