pygtk2.spec
author dcarbery
Mon, 23 Oct 2006 12:46:17 +0000
branchgnome-2-14
changeset 19195 352a4716f1f3
parent 7004 d9f3eebc93fe
child 7706 2582c8fc8329
permissions -rw-r--r--
2006-10-23 Damien Carbery <[email protected]> * docs/ssa/*: Remove these, as they're now up on the JDS project pages under 'Tasks/Single Sys Admin'.

#
# spec file for package pygtk2
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:			pygtk2
License:		LGPL	
Group:			System/Library
Version:		2.9.0
Release:		2
Distribution:		Java Desktop System
Vendor:			Sun Microsystems, Inc.
Summary:		Python bindings for GTK+
Source:			http://ftp.gnome.org/pub/GNOME/sources/pygtk/2.9/pygtk-%{version}.tar.bz2	
Patch1:                 pygtk2-01-uninstalled.pc.diff
URL:			http://www.gnome.org
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
Docdir:			%{_defaultdocdir}/doc
Autoreqprov:		on

%define libglade_version 2.4.0
%define glib2_version 2.6.0
%define gtk2_version 2.6.0
%define atk_version 1.8.0
%define pango_version 1.8.0
%define python_version 2.4

Requires:		libglade >= %{libglade_version}
Requires:		gtk2 >= %{gtk2_version}
Requires:		glib2 >= %{glib2_version}
Requires:		atk >= %{atk_version}
Requires:		pango >= %{pango_version}
Requires:		python >= %{python_version}
BuildRequires: 		gtk2-devel >= %{gtk2_version}
BuildRequires:		libglade-devel >= %{libglade_version}
BuildRequires:		glib2-devel >= %{glib2_version}
BuildRequires:		atk-devel >= %{atk_version}
BuildRequires:		pango-devel >= %{pango_version}

%description
PyGTK is an extension module for python that gives you access to the GTK+
widget set.  Just about anything you can write in C with GTK+ you can write
in python with PyGTK (within reason), but with all the benefits of python.

%package devel
Summary: files needed to build wrappers for GTK+ addon libraries
Group: Development/Languages
Requires: %{name} = %{version}

%description devel
This package contains files required to build wrappers for GTK+ addon
libraries so that they interoperate with pygtk.

%prep
%setup -q -n pygtk-%{version}
%patch1 -p1

%build
autoconf
%ifos solaris
# Disable optimizations on x86 to workaround compiler bug 6382078.
%ifarch sparc
CFLAGS="$RPM_OPT_FLAGS"				\
%else
CFLAGS="$RPM_OPT_FLAGS -xO0"			\
%endif
%endif
./configure 	--prefix=%{_prefix}		\
	    	--sysconfdir=%{_sysconfdir}
make

%install
make install DESTDIR=$RPM_BUILD_ROOT \
    pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
    pythondir=%{_libdir}/python%{python_version}/vendor-packages
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm -f {} ';'

%clean
rm -rf $RPM_BUILD_ROOT

%post

%postun

%files
%defattr(-, root, root)
%{_libdir}/python?.?/vendor-packages/*

%files devel
%defattr(-, root, root)
%doc examples
%doc AUTHORS NEWS README MAPPING ChangeLog
%{_bindir}/*
%{_includedir}/*
%{_libdir}/pkgconfig/*
%{_libdir}/pygtk/*
%{_datadir}/pygtk/*

%changelog -n pygtk2
* Tue Apr  4 2006 - [email protected]
- Bump to 2.9.0.

* Fri Mar 31 2006 - [email protected]
- Bump to 2.8.5.

* Wed Feb 15 2006 - [email protected]
- Disable optimizations on x86 to workaround compiler bug 6382078.

* Sun Jan 15 2006 - [email protected]
- Bump to 2.8.4

* Tue Dec 20 2005 - [email protected]
- Bump to 2.8.2

* Thu Oct 27 2005 - [email protected]
- add patch uninstalled.pc.diff so the pygtk can be included in the same
  Solaris pkg as gnome-python
- move from site-packages to vendor-packages

* Tue Sep 27 2005 - [email protected]
- Bump to 2.7.4.

* Thu Aug 25 2005 [email protected]
- Adjusted the defattr lines to have three parameters, not four.

* Tue Aug 16 2005 - [email protected]
- Bump to 2.7.3.

* Mon Aug 04 2003 - [email protected]
- Initial Sun release