dasher.spec
author dermotm
Mon, 24 Jul 2006 12:30:39 +0000
branchgnome-2-10
changeset 19949 94f49bf19351
parent 19719 d184ca39d269
permissions -rw-r--r--
access control test #4

#
# spec file for package dasher
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:		dasher
License:	GPL
Group:		System/GUI/GNOME
Version:	3.2.15
Release:	1
Distribution:	Java Desktop System
Vendor:		Sun Microsystems, Inc.
Summary:	Predictive text entry system
Source:		http://ftp.gnome.org/pub/GNOME/sources/dasher/3.2/%{name}-%{version}.tar.bz2
URL:		http://www.gnome.org
BuildRoot:	%{_tmppath}/%{name}-%{version}-build
Docdir:		%{_defaultdocdir}/%{name}
Autoreqprov:	on

%define gtk2_version 2.3.1
%define GConf_version 2.4.0.1
%define libgnomeui_version 2.6.0
%define libwnck_version 2.6.0
%define gnome_speech_version 0.3.0

Requires:	gtk2 >= %{gtk2_version}
Requires:	GConf >= %{GConf_version}
Requires:	libgnomeui >= %{libgnomeui_version}
Requires:	libwnck >= %{libwnck_version}
Requires:	gnome-speech >= %{gnome_speech_version}
BuildRequires:  gtk2-devel >= %{gtk2_version}
BuildRequires:  GConf-devel >= %{GConf_version}
BuildRequires:  libgnomeui-devel >= %{libgnomeui_version}
BuildRequires:  libwnck-devel >= %{libwnck_version}
BuildRequires:  gnome-speech-devel >= %{gnome_speech_version}
BuildRequires:  intltool

%description
Dasher is a zooming predictive text entry system, designed for situations
where keyboard input is impractical (for instance, accessibility or PDAs). It
is usable with highly limited amounts of physical input while still allowing
high rates of text entry.

%prep
%setup -q


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
	--prefix=%{_prefix} \
	--sysconfdir=%{_sysconfdir} \
	--mandir=%{_mandir}
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make -i install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, root)
%{_bindir}/*
%{_datadir}/applications
%{_datadir}/dasher
%{_datadir}/gnome/help
%{_datadir}/icons
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/man
%{_datadir}/omf

%changelog
* Tue May 24 2005 - [email protected]
- Initial spec