gdm.spec
author dermotm
Mon, 24 Jul 2006 12:30:39 +0000
branchgnome-2-10
changeset 19949 94f49bf19351
parent 19883 e55bf06836ae
permissions -rw-r--r--
access control test #4

#
# spec file for package gdm
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         gdm
License:      GPL
Group:        System/GUI/GNOME
Version:      2.8.0.1
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      The GNOME 2.x Display Manager
Source:       http://ftp.gnome.org/pub/GNOME/sources/gdm/2.8/gdm-%{version}.tar.bz2
Source1:      gdm-stop.1m.gz
Source2:      gdmconfig.1m.gz
Source3:      gdm-binary.1.gz
Source4:      gdm.1.gz
Source5:      gdmXnest.1.gz
Source6:      gdmXnestchooser.1.gz
Source7:      gdmchooser.1.gz
Source8:      gdmflexiserver.1.gz
Source9:      gdmgreeter.1.gz
Source10:     gdmlogin.1.gz
Source11:     gdmphotosetup.1.gz
Source12:     gdmsetup.1.gz
Source13:     gdmthemetester.1.gz
Source14:     gdm-restart.1m.gz
Source15:     gdm-safe-restart.1m.gz
%ifos solaris
Patch1:	      gdm-02-branding-defaults-solaris.diff
%else
Patch1:	      gdm-01-branding-defaults-linux.diff
%endif
Patch3:       gdm-03-branding-general.diff
Patch4:	      gdm-04-pam-security-setup.diff
Patch5:       gdm-05-zh-hk-greeter-languages.diff
Patch6:       gdm-06-normalise-locale-xiim-broken-filenames.diff
Patch7:       gdm-07-g11n-truncated-username.diff
Patch8:       gdm-08-fix-a11y-crash.diff
Patch9:       gdm-09-current-locale.diff
Patch10:      gdm-10-system-locale.diff
URL:          www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}
Autoreqprov:  on
Prereq:       /usr/sbin/groupadd
Prereq:       /usr/sbin/useradd
Prereq:       /sbin/nologin
Prereq:       sed
Prereq:       coreutils

%define pango_version 1.4.0
%define gtk2_version 2.4.0
%define libglade_version 2.3.6
%define libgnomeui_version 2.6.0
%define libgnomecanvas_version 2.6.0
%define librsvg_version 2.5.0
%define libxml2_version 2.6.7
%define scrollkeeper_version 0.3.14
%define pam_version 0.77
%define gail_version 1.6.3
%define XFree86_version 4.3.99
%define usermode_version 1.68
%define openssl_version 0.9.7d

%define dsp_mgr_file /etc/sysconfig/displaymanager
%define xdm_rc_file /etc/init.d/xdm


Requires: gtk2 >= %{gtk2_version}
Requires: sun-gdm-themes
Requires: libglade >= %{libglade_version}
Requires: libgnomeui >= %{libgnomeui_version}
Requires: libgnomecanvas >= %{libgnomecanvas_version}
Requires: librsvg >= %{librsvg_version}
Requires: libxml2 >= %{libxml2_version}
Requires: pam >= %{pam_version}
Requires: usermode >= %{usermode_version}
Requires: openssl >= %{openssl_version}

BuildRequires: scrollkeeper >= %{scrollkeeper_version}
BuildRequires: pango-devel >= %{pango_version}
BuildRequires: gtk2-devel >= %{gtk2_version}
BuildRequires: libglade-devel >= %{libglade_version}
BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: libgnomecanvas-devel >= %{libgnomecanvas_version}
BuildRequires: librsvg-devel >= %{librsvg_version}
BuildRequires: libxml2-devel >= %{libxml2_version}
BuildRequires: pam-devel >= %{pam_version}
BuildRequires: XFree86-devel >= %{XFree86_version}
BuildRequires: gail-devel >= %{gail_version}
BuildRequires: usermode >= %{usermode_version}
BuildRequires: openssl-devel >= %{openssl_version}

%description
This version of GDM, the GNOME Display manager is based on
GTK2 and suited for the GNOME 2.4 Desktop Environment. GDM
is a flexible X-Window Display Manager that allows to set
many options, usable for remote login, and provides a good
looking graphical interface.

%prep
%setup -q
%patch1 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

export CFLAGS="$RPM_OPT_FLAGS"
autoheader
autoconf

ENABLE_CONSOLE_HELPER=
%ifos linux
ENABLE_CONSOLE_HELPER="--enable-console-helper"
%endif

AT_BINDIR_CONFIG=""
BINDIR_CONFIG=""
%ifos solaris
AT_BINDIR_CONFIG="--with-at-bindir=/usr/sfw/bin"
BINDIR_CONFIG="--with-post-path=/usr/openwin/bin"
%endif

libtoolize --force
glib-gettextize -c -f
intltoolize --copy --force --automake
aclocal $ACLOCAL_FLAGS
autoconf
autoheader
automake -a -c -f
./configure \
	--prefix=%{_prefix} \
	--sysconfdir=%{_sysconfdir}/X11 \
	--localstatedir=%{_localstatedir}/lib \
	--mandir=%{_mandir} \
	--with-pam-prefix=%{_sysconfdir} \
	--libexecdir=%{_libexecdir} \
	--enable-ipv6=yes $ENABLE_CONSOLE_HELPER $AT_BINDIR_CONFIG $BINDIR_CONFIG
make -j $CPUS

%install
make install DESTDIR=$RPM_BUILD_ROOT
# no flexiserver thing, Xnest is too broken ??
# rm -f $RPM_BUILD_ROOT%{_datadir}/applications/gdmflexi*.desktop
rm -rf $RPM_BUILD_ROOT%{_mandir}/man1
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE4 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE5 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE6 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE7 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE8 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE9 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE10 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE11 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE12 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE13 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE14 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE15 $RPM_BUILD_ROOT%{_mandir}/man1

#Clean up unpackaged files
rm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.a
rm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%pre
/usr/sbin/groupadd -r -g 50 gdm
/usr/sbin/useradd -r -o -g gdm -u 50 -s /sbin/nologin \
-c "Gnome Display Manager daemon" -d /var/lib/gdm gdm 2> /dev/null || :


%post
if [ -f %{dsp_mgr_file} ]; then
	sed -e 's/^DISPLAYMANAGER=.*/DISPLAYMANAGER="gdm"/' %{dsp_mgr_file} > /tmp/displaymanager.$$

	if [ $? -eq 0 ]; then
		mv /tmp/displaymanager.$$ %{dsp_mgr_file}
	fi
fi

if [ -f %{xdm_rc_file} ]; then
	sed -e 's#^\( *gdm.*DISPLAYMANAGER=\)\(.*\)#\1/usr/bin/gdm ;;#' %{xdm_rc_file} > /tmp/xdm.$$

	if [ $? -eq 0 ]; then
		mv /tmp/xdm.$$ %{xdm_rc_file}
		chmod 755 %{xdm_rc_file}
	fi
fi


%files
%config %attr(-,gdm,gdm) %{_sysconfdir}/X11/gdm
%config %attr(-,root,root) %{_sysconfdir}/X11/dm
%{_datadir}/locale/*/LC_MESSAGES/gdm*.mo
%{_sbindir}/*
%{_bindir}/*
%{_libdir}/gtk-2.0/modules/*.so
%{_libexecdir}/*
%{_datadir}/gdm
%{_datadir}/applications/*
%{_datadir}/pixmaps/*.png
%{_datadir}/pixmaps/faces/*.jpg
%{_datadir}/icons
%{_datadir}/gnome/capplets/*
%{_datadir}/gnome/help/*
%{_datadir}/xsessions/*
%{_mandir}/man1/*
%{_datadir}/omf/*
%attr(-,gdm,gdm) /var/lib/gdm
%config /etc/pam.d/*
%config /etc/security/*

%changelog
* Wed Aug 03 2005 - [email protected]
- remove upstream patch xnext-remote-session.diff

* Thu Jul 14 2005 - [email protected]
- Add unpackaged files to %files (pixmaps/faces and gnome/capplets).

* Wed Jul 13 2005 - [email protected]
- Upgraded to 2.8.0.1

* Fri Jun 10 2005 - [email protected]
- Re-applied patch 01 linux branding
- Added patch 04/05 to build

* Tue May 10 2005 - [email protected]
- Added patch gdm-45-xnest-remote-session.diff to allow remote login
  using XDMCP chooser in nested window. Fixes bug #6245415.

* Tue Apr 19 2005 - [email protected]
- Reinstated xevie-enabling patch on Linux, via gdm-44-linux-xevie.diff.

* Fri Apr 1 2005 - [email protected]
- Add patch 43 so that we set the Xserver on Solaris to 
  /usr/X11/bin/Xserver instead of /usr/X11/bin/X as per ARQ
  request.  Also now put /usr/openwin/bin in the user default
  patch here instead of in SUNWdtlogin-integration.spec.

* Thu Mar 17 2005 - [email protected]
- Add patch 42 to allow configure to specify the full path to the
  a11y AT programs used in the gesture listener configuration files.
  Patch in gdm CVS head.

* Thu Mar 10 2005 - [email protected]
- Fix gdm to fork user's session with "system locale" if "Default" option
  at the language menu being selected. [CR Id: 5032088]

* Thu Mar 03 2005 - [email protected]
- Fix XDMCP logic so that it works when an IPv4 address requests a 
  connection and IPV6 is enabled in GDM.  Patch40 fixes this.

* Tue Mar 01 2005 - [email protected]
- remove patch 40 (XEVIE) - break new X server

* Fri Feb 25 2005 - [email protected]
- Added patch 40 to turn on XEVIE on Linux by default for the
  standard server to meet a11y requirements.  Fixes bug 6226645.

* Thu Feb 24 2005 - [email protected]
- Added branding patch 39 to change the GNOME string to "Java Desktop
  System" in a number of places in the c-code.

* Tue Feb 22 2005 - [email protected]
- Backed out patch 39/40 since ARC determined that these flags should
  not be set by default after initially indicating it was okay.

* Mon Feb 14 2005 - [email protected]
- Added patch 39/40 to support setting the Xserver with needed 
  a11y Xserver flags.  Fixes CR 6226645. 

* Tue Feb 08 2005 - [email protected]
- Removed --with-post-path argument since /usr/dt/bin and
  /usr/openwin/bin are added also by the /usr/dt/config/Xinitrc.jds.
  No need to have them in the PATH twice.  Also we do not
  need to add /usr/demo/jds/bin since all the *.desktop files
  have full-paths defined.

* Mon Feb 07 2005 - [email protected]
- Added patch-38 to more cleanly set the default PATH.  This replaces
  patches gdm-15-default.path.diff and gdm-16-reboot-shutdown-option.diff.
  The new patch sets more sensible definitions for Halt, Reboot, Shutdown
  commands on Solaris.  Also updated gdm-18-help.diff so it forwards
  the user to the right subsection when running gdmsetup help.

* Fri Jan 21 2005 - [email protected]
- Now only apply patch 37 when building on Linux.  Modified patch 37 to
  include needed changes for Solaris.

* Tue Jan 18 2005 - [email protected]
- Added patch gdm-37-branding.diff to fix branding issue in gnome.desktop
  file.  Also updated gdm-21-fix-a11y-crash.diff patch so it works on
  JDS Linux.

* Fri Jan 14 2005 - [email protected]
- Updated l10n help tarball for cinnabar-linux
                                                                                
* Thu Dec 30 2004 - [email protected]
- #6213083 - Add note that legacy locales are NOT SUPPORTED for linux platform.

* Wed Dec 22 2004 - [email protected]
- Added gdm-35-flexi-xdmcp-option.diff to make XDMCP chooser work in 
  flexiserver. Fixes bug #4992853.

* Fri Nov 26 2004 - [email protected]
- Added gdm-34-xsession-use-ksh.diff to execute Xsession script using
  ksh on Solaris. Fixes stopper bug #6199960.

* Wed Nov 24 2004 - [email protected]
- #6196675 - all single byte locales removed.

* Thu Nov 18 2004 - [email protected]
- #5081827 - run /usr/dt/config/Xsession.jds instead of gnome-session
for gnome session vid gdm. Solaris only.

* Wed Nov 17 2004 - [email protected]
- #6195855 Install correct man page

* Wed Nov 10 2004 - [email protected]
- Added gdm-31-current-locale.diff to fix bug#5100351

* Wed Nov 10 2004 - [email protected]
- Remove gdm-26-start-gnome-volcheck.diff as gnome-volcheck is now
  started by gnome-session.

* Mon Nov 09 2004 - [email protected]
- Added new patch 31. It fixes #6182860: IPv6 logic is broken for New
  Login in a Nested Window, so the enable-ipv6 parameter of configure
  is "yes" again.

* Mon Nov 01 2004 - [email protected]
- Modify gdm-07-set-lc-messages-to-lang.diff. set LANG from RC_LANG
  in /etc/sysconfig/language when it is NULL. (CR 6188663)

* Fri Oct 29 2004 - [email protected]
- Add gdm-30-xorg-conf.diff to fix 6185918. configure.in checks for Xorg
  binary before looking for X (Xsun) binary.

* Thu Oct 28 2004 - [email protected]
- Added gdm-binary.1.gz, gdm.1.gz, gdmXnest.1.gz, gdmXnestchooser.1.gz,
  gdmchooser.1.gz, gdmflexiserver.1.gz, gdmgreeter.1.gz, gdmlogin.1.gz,
  gdmphotosetup.1.gz, gdmsetup.1.gz, gdmthemetester.1.gz, gdm-restart.1m.gz,
  gdm-safe-restart.1m.gz, gdm-stop.1m.gz, gdmconfig.1m.gz man pages

* Thu Oct 28 2004 - [email protected]
- Updated l10n help tarball and added pt_BR

* Fri Oct 22 2004 - [email protected]
- "Source" entry updated

* Thu Oct 21 2004 - [email protected]
- Removed ipv6 support (--enable-ipv6=no) since this is breaking 
  gdm's ability to "login in a nested window".  Created bug 6182860
  so that issue gets fixed.

* Wed Oct 20 2004 - [email protected]
- Added patch gdm-27-alt-meta-mapping.diff to restore 'Alt' and 'Meta' 
  mappings on sparc Solaris. Fixes bug 6173594.

* Wed Oct 20 2004 - [email protected]
- Added patch gdm-26-start-gnome-volcheck.diff to start gnome-volcheck
  if Xserver is local. Fixes bug #5107205.

* Fri Oct 15 2004 - [email protected]
- Correct GreenLine integration.  The problem with disabling core dumps
  in the GreenLine XML file is that this causes GreenLine to ignore 
  core dumps for all programs, including gdm.  Now using patch 25
  we use ctrun to specify that only programs launched from gdm's 
  Xsession script (the user's session) are run in a separate GreenLine
  contract that ignores core dumps.  This way if gdm itself core dumps,
  GreenLine will correctly default back to the console login.

* Thu Oct 14 2004 - [email protected]
- Added patch gdm-24-sanitize-conf.diff to clean up language in
  gdm.conf file.  Fixes bug 5097046.  

* Wed Oct 06 2004 - [email protected]
- Add patch gdm-22-xserver-location.diff to set GDM_XSERVER_LOCATION 
  with the x server type. Fixes bug #6174802

* Wed Oct 06 2004 - [email protected]
- Added patch gdm-21-fix-a11y-crash.diff to remove
  /var/tmp/orbit-gdm/bonobo-activation-server-ior.F ixes bug #5103715.

* Tue Oct 05 2004 - [email protected]
- Modified patch gdm-15-default-path.diff to add 
  /usr/openwin/bin to the path. Fixes bug #5106790

* Mon Oct 04 2004 - [email protected]
- Added gdm-20-g11n-i18n-button.diff to fix bug#5109970

* Wed Sep 29 2004 - <[email protected]>
- updated gdm-03-locale-alias.diff to remove non-UTF-8
locale entries from Traditional Chinese (big5 and big5hkscs)

* Mon Sep 20 2004 - [email protected]
- Added chmod xdm in post-install script

* Fri Sep 17 2004 - [email protected]
- Added patch gdm-20-gdmwm-struts.diff, to fix bugzilla
  #143634.

* Thu Sep 16 2004 - [email protected]
- Added post install script to set gdm as displaymanager

* Wed Sep 15 2004 - [email protected]
- Patch added gdm-19-add-acroread-path.diff
  Fixes bug# 5087934

* Thu Aug 26 2004 - [email protected]
- Patch gdm-18-help.diff provide help link.

* Thu Aug 26 2004 - [email protected]
- Updated patch gdm-10-a11y-gestures.diff.

* Tue Aug 24 2004 - [email protected]
- Enabling ipv6.

* Tue Aug 24 2004 - [email protected]
- Add back icons

* Tue Aug 24 2004 - [email protected]
- removed some icons

* Thu Aug 19 2004 - [email protected]
- Integrate updated docs tarball from [email protected].

* Fri Aug 13 2004 - [email protected]
- Update patch gdm-10-a11y-gestures.diff.  Fixes bug #5067111.

* Thu Jul 29 2004 - [email protected]
- use version 2.6.0.3 (fix for bugzilla 144920 and related GOK problem)
- remove patches gdm-08-gdmtranslate.diff and gdm-09-fix-which.diff,
  since they are included in 2.6.0.3.

* Thu Jul 22 2004 - [email protected]
- add patch to remove reboot/shutdown option on Solaris box

* Thu Jul 22 2004 - [email protected]
- add patch gdm-15-default-path.diff to add /usr/dt/bin and /usr/sfw/bin
  to PATH for Solaris. 

* Wed Jul 14 2004 - [email protected]
- add patch from Johan to invoke jds registration on first login

* Thu Jul 08 2004 - [email protected]
- add patch to pass X server options instead of hardcoding 
  it in the gdm.conf.in

* Wed Jul 07 2004 - [email protected]
- ported to rpm4
                                                                                
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed Jun 23 2004 - [email protected]
- Update a11y-gestures patch to add HAVE_XINPUT to acconfig.h.
  Remove xdmcp-enable patch (10) for app security reasons and move 13 to 10.

* Thu Jun 10 2004 - [email protected]
- Add patch 12 to add 'docs/C/figures' directory to the build.

* Mon May 31 2004 - [email protected]
- bump to 2.6.0.2

* Wed May 12 2004 - [email protected]
- Updated l10n content to gdm-l10n-po-1.1.tar.bz2

* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris

* Thu Apr 08 2004 - <[email protected]>
- bumped to 2.6.0.0 and updated dependencies

* Sat Apr 03 2004 - [email protected]
- added gdm-11-g11n-truncated-username.diff to fix 4955151

* Thu Apr 01 2004 - [email protected]
- javahelp conversion

* Wed Mar 31 2004 - <[email protected]>
- updated gdm-03-locale-alias.diff to fix 4884887

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to gdm-l10n-po-1.0.tar.bz2

* Tue Mar 23 2004 - <[email protected]>
- Remove photo setup from %files since we didn't want it part of the 
  menus by default [$datadir/gnome/capplets/..]

* Mon Mar 22 2004 - <[email protected]>
- simplify %build

* Fri Mar 19 2004 - <[email protected]>
- Move autoheader and autoconf out of the platform specific section because
  it is common to both platforms.

* Fri Mar 19 2004 - <[email protected]>
- Change '\' to ';' so autoheader and autoconf run separately.

* Thu Mar 18 2004 - <[email protected]>
- Add patch 8 that fixes gdmtranslate so it compiles with -g, add
  patch 9 to fix scripts so that they don't call which (since which
  doesn't work on Solaris without an associated TTY), and add patch
  10 to turn on XDMCP support by default.

* Tue Mar 09 2004 - <[email protected]>
- bump to 2.5.90.2

* Mon Mar 01 2004 - <[email protected]>
- s$/usr/share$%{_datadir}$

* Thu Feb 26 2004 - <[email protected]>
- Fix small typos in description and change tar commmand to bzcat/tar.
- Remove --enable-console-helper on Solaris.

* Fri Feb 06 2004 - <[email protected]>
- Bump to 2.5.90.0, add docs, and ported QS patches

* Wed Jan 07 2004 - <[email protected]>
- Update to 2.4.4.7 for gnome-2.5.x
- Regenerated gdm-07-enable-tcp-by-default.diff

* Fri Oct 31 2003 - <[email protected]>
- Remove the Sun Supported menu entry patch, and reorder.

* Tue Oct 14 2003 - <[email protected]> 2.4.4.3-2
- Add patch from Toshi to normalize the locale environment
  variables to be the same as LANG if they are unset.

* Fri Oct 10 2003 - <[email protected]> 2.4.4.3
- Update to 2.4.4.3 for gnome-2.4

* Wed Oct 01 2003 - <[email protected]> 2.4.2.101-14
- Add patch from Chookij to fix bug 4901817 (ja_JP.eucJP name)

* Thu Sep 18 2003 - <[email protected]> 2.4.2.101-12
- Add patch from Leena to set AlwaysRestartServer to true.

* Thu Aug 21 2003 - <[email protected]> 2.4.2.101-1
- Upgrade to 2.4.2.101

* Mon Aug 18 2003 - <[email protected]> 2.4.2.99-7
- Set DisallowTCP to false by default.

* Fri Aug 08 2003 - <[email protected]> 2.4.2.99-3
- Updated locale.alias patch with a fix for zh_HK and a tweak
  for ja_JP.sjis (now ja_JP.SJIS). Fixing bug 4899317.
- Added a dependancy on openssl-devel. My build failed because 
  it was missing. I've also added openssl for good measure.

* Thu Aug 07 2003 - <[email protected]> 2.4.2.99-2
- Patched /etc/X11/gdm/Xsession so ~/.xim or /etc/skel/.xim is sourced which
  ensures that XIM input methods are started.

* Fri Aug 01 2003 - <[email protected]> 2.4.2.99-1
- Upgrade to 2.4.2.99.

* Fri Aug 01 2003 - <[email protected]>
- Add supported menu category.

* Sun Jul 27 2003 - <[email protected]>
- Update to 2.4.2.98
- Remove POTFILES.in patch. Seems to be in new tarball.

* Tue Jul 22 2003 - <[email protected]>
- Added a patch to update the POTFILES.in.

* Mon Jul 21 2003 - <[email protected]>
- Changed category of gdmsetup.desktop, so it appears in 
  the system menu again.

* Mon Jul 21 2003 - <[email protected]>
- Added zh_HK (Hong Kong Chinese) to the available languages.

* Fri Jul 18 2003 - <[email protected]>
- Patched locale.alias to include more Asian locale codeset 
  variants as requested by the Asian teams.

* Thu Jul 17 2003 - <[email protected]>
- Fixed up the PAM configuration files.
- Removed the sysconfig/displaymanager hack

* Thu Jul 17 2003 - <[email protected]>
- update to version 2.4.2.97, release 0
- removed patches gdm-04-setlocale.diff and
  gdm-05-potfiles_in.diff, which are integrated upstream
- Changed sysconfdir to /etc/X11 so that new common sessions
  configuration directory (/etc/X11/dm/Sessions) can be shared
  with kdm etc.
- New common sessions dir /etc/X11/dm added to %files

* Fri Jul 11 2003 - <[email protected]>
- added setlocal patch - No more Welsh :) (or Czech!)

* Tue Jul 08 2003 - <[email protected]>
- Remove .desktop capplets from %files since photo setup
  is gone.

* Mon Jul 07 2003 - <[email protected]>
- Remove the photo setup .desktop menu item from the
  Settings menu.

* Tue Jul 01 2003 - <[email protected]>
- Move the pam and branding stuff to patches, and not 
  dirty copy hacks ;)

* Tue Jul 01 2003 - <[email protected]>
- Make gdm now depend on sun-gdm-themes which is a new
  package, replacing the old one.

* Fri Jun 30 2003 - <[email protected]>
- Make gdm now depend on Sundt-gdm-theme. This may be
  crack that we shouldn't do, but until I figure out
  how things work, let's go with it. 

* Fri Jun 30 2003 - <[email protected]>
- New tarball, bump version and reset release. Remove
  the old greeter theme, since we probably don't want
  it installed anyway

* Fri May 02 2003 - <[email protected]>
- Initial Sun release.