gnome-terminal.spec
author dermotm
Mon, 24 Jul 2006 12:30:39 +0000
branchgnome-2-10
changeset 19949 94f49bf19351
parent 19838 42a3a4365a3b
permissions -rw-r--r--
access control test #4

#
# spec file for package gnome-terminal
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         gnome-terminal
License:      GPL
Group:        System/GUI/GNOME
Version:      2.10.0
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      GNOME Terminal
Source:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.10/%{name}-%{version}.tar.bz2
Source1:      gnome-terminal.1.gz
Patch1:       gnome-terminal-01-encodings.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on
Prereq:       GConf

%define libglade_version 2.0.1
%define libgnomeui_version 2.4.0
%define vte_version 0.11.10
%define startup_notification_version 0.5
%define scrollkeeper_version 0.3.12

BuildRequires: libglade-devel >= %{libglade_version}
BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: vte-devel >= %{vte_version}
BuildRequires: startup-notification-devel >= %{startup_notification_version}
BuildRequires: scrollkeeper >= %{scrollkeeper_version}
Requires:      libglade >= %{libglade_version}
Requires:      libgnomeui >= %{libgnomeui_version}
Requires:      vte >= %{vte_version}
Requires:      startup-notification >= %{startup_notification_version}

%description
GNOME Terminal application, which uses the VTE terminal emulation widget.

%prep
%setup -q
%patch1 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}		\
	    --sysconfdir=%{_sysconfdir}
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make DESTDIR=$RPM_BUILD_ROOT install
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man1 
chmod 644 $RPM_BUILD_ROOT%{_datadir}/gnome/help/gnome-terminal/*/*.xml
rm -rf $RPM_BUILD_ROOT/usr/var/scrollkeeper

#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/

%clean
rm -rf $RPM_BUILD_ROOT

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="gnome-terminal.schemas"
for S in $SCHEMAS; do
        gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%files
%defattr (-, root, root)
%{_datadir}/application-registry/*.applications
%{_datadir}/applications/gnome-terminal.desktop
%{_datadir}/gnome/help/gnome-terminal
%{_datadir}/omf/gnome-terminal
%{_datadir}/locale/*/LC_MESSAGES/gnome-terminal.mo
%{_libdir}/bonobo/servers/gnome-terminal.server
%{_sysconfdir}/gconf/schemas/gnome-terminal.schemas
%{_datadir}/pixmaps/gnome-terminal.png
%{_datadir}/gnome-terminal/glade/gnome-terminal.glade2
%{_bindir}/gnome-terminal
%{_mandir}/man1/*

%changelog
* Fri May 13 2005 [email protected]
- Bump 2.10.1

* Tue Jan 25 2005 [email protected]
- Incorporate Linux specific docs tarball from [email protected].

* Fri Jan 14 2005 - [email protected]
- Updated l10n help tarball for cinnabar-linux
                                                                                
* Thu Oct 28 2004 - [email protected]
- Updated l10n help tarball and added pt_BR

* Wed Aug 25 2004 - [email protected]
- Updated l10n help contents with patch

* Mon Aug 16 2004 - [email protected]
- Updated /usr/share/gnome/help/gnome-terminal/*/*.xml to 0644 for Solaris
  integration.

* Thu Aug 05 2004 [email protected]
- Incorporate new docs tarball from [email protected].

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gnome-terminal-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Fri Jun 25 2004 [email protected]
- Modified gnome-terminal-04-encodings.diff to correct the
  encoding names.

* Wed Jun 09 2004 [email protected]
- Added gnome-terminal-04-encodings.diff to fix the problem of 
  encodings not being listed on Solaris. Bug #5043182.
  Uploaded the patch in bugzilla - bug #144000.

* Wed Jun 02 2004 [email protected]
- Incorporate new docs tarball from [email protected].

* Tue May 25 2004 - [email protected]
- Added gnome-terminal-03-g11n-potfiles.diff

* Wed May 12 2004 - [email protected]
- Updated l10n content to gnome-terminal-l10n-po-1.1.tar.bz2

* Fri May 07 2004 - [email protected]
- Updated tarball to 2.6.1

* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris

* Fri Apr 02 2004 - [email protected]
- Updated tarball to 2.6.0

* Thu Apr 01 2004 - [email protected]
- Javahelp conversion

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to gnome-terminal-l10n-po-1.0.tar.bz2

* Tue Mar 16 2004 - [email protected]
- Added gnome-terminal-01-g11n-schemas.diff to fix 4980332
- Added gnome-terminal-02-g11n-potfiles.diff
* Wed Feb 18 2004 - <[email protected]>
- Bump to 2.5.5

* Tue Dec 16 2003 - <[email protected]>
- Bump to 2.5.1

* Fri Oct 31 2003 - <[email protected]>
- Remove the Sun Supported keyword, since we're removing 
  Extras now.

* Fri Oct 17 2003 - <[email protected]>
- Upgraded to 2.4.0 for Quicksilver build.
  removed patch  gnome-terminal-01-config-add-1l0n-help.diff
  and modified patch gnome-terminal-02-menu-entry.diff
  to make it gnome-terminal-01-menu-entry.diff

* Fri Sep 26 2003 Laszlo Peter <[email protected]>
- Intergate Sun docs

* Tue Aug 26 2003 Michael Twomey <[email protected]>
- Updated to 0.2 l10n docs tarball to fix seriesid issues.
- Added GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL to make install.

* Fri Aug 01 2003 - [email protected]
- Add supported menu category

* Fri Jul 25 2003 - [email protected]
- uses scrollkeeper for postinstall - add a dependency

* Wed Jul 09 2003 - <[email protected]>
- add in sun po files

* Wed May 14 2003 - [email protected]
- Created new spec file for gnome-terminal