gnomemeeting.spec
author dermotm
Mon, 24 Jul 2006 12:30:39 +0000
branchgnome-2-10
changeset 19949 94f49bf19351
parent 19838 42a3a4365a3b
permissions -rw-r--r--
access control test #4

#
# spec file for package gnomemeeting
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:		gnomemeeting
License:	GPL
Group:		X11/GNOME/Applications
Version:	1.2.1
Release:	1
Vendor:		Sun Microsystems, Inc.
Distribution:	Java Desktop System
Summary:	A GNOME based H.323 video conferencing application
Source:		%{name}-%{version}.tar.bz2
Patch1:		gnomemeeting-01-correct-desktop-filename.diff
Patch2:		gnomemeeting-02-configure-solaris.diff
URL:		http://www.gnomemeeting.org
BuildRoot:	%{_tmppath}/%{name}-root
Docdir:       	%{_docdir}/%{name}
Autoreqprov:  	on

%define pwlib_version 1.8.4
%define openh323_version 1.13.4
%define GConf_version 2.4.0.1
%define gtk2_version 2.3.1
%define openldap2_devel_version 2.1.4
%define SDL_devel_version 1.2.4
%define intltool_version 0.27
%define libgnomeui_version 2.4.0.1
%define des_version 4.04
%define heimdal_version 0.4
%define cyrus_sasl_version 1.5.27
%define openssl_version 0.9.6
%define flex_version 2.5.4
%define slang_version 1.4.5
%define pam_version 0.76
%define db_version 4.0.14
%define gdbm_version 1.8.0
%define howl_version 1.0.0

Requires: pwlib >= %{pwlib_version}
Requires: openh323 >= %{openh323_version}
Requires: GConf >= %{GConf_version}
Requires: libgnomeui >= %{libgnomeui_version}
BuildRequires: gtk2-devel >= %{gtk2_version}
BuildRequires: GConf-devel >= %{GConf_version}
BuildRequires: openh323-devel >= %{openh323_version}
BuildRequires: pwlib-devel >= %{pwlib_version}
BuildRequires: SDL-devel >= %{SDL_devel_version}
BuildRequires: intltool >= %{intltool_version}
BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: des >= %{des_version}
BuildRequires: heimdal-devel >= %{heimdal_version}
BuildRequires: cyrus-sasl-devel >= %{cyrus_sasl_version}
BuildRequires: openssl-devel >= %{openssl_version}
BuildRequires: openldap2-devel >= %{openldap2_devel_version}
BuildRequires: flex >= %{flex_version}
BuildRequires: slang-devel >= %{slang_version}
BuildRequires: pam-devel >= %{pam_version}
BuildRequires: db-devel >= %{db_version}
BuildRequires: gdbm-devel >= %{gdbm_version}
Requires: howl >= %{howl_version}
BuildRequires: howl-devel >= %{howl_version}
Prereq:        GConf

%description
GnomeMeeting is a GNOME based application that allows user to communicate
with video and audio over the internet. It uses the H323 protocol and is 
compatible with Microsoft Netmeeting.


%prep
%setup -q -n gnomemeeting-%{version}
%patch1 -p1
%patch2 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

autoconf
CFLAGS="$RPM_OPT_FLAGS"		\
  ./configure 			\
    --prefix=%{_prefix} 	\
    --sysconfdir=%{_sysconfdir} \
    --with-pwlib-dir=%{_prefix} \
    --mandir=%{_mandir} \
    --with-openh323-dir=%{_prefix}

make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make DESTDIR=$RPM_BUILD_ROOT install
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL

# 6227253: Change xml file in gnomemeeting-C.omf from gnomemeeting.xml to 
# sample_apps_info.xml (part of gnome-user-docs).
sed 's/%{name}.C.%{name}.xml/sample_apps_info\/C\/sample_apps_info.xml/' $RPM_BUILD_ROOT%{_datadir}/omf/%{name}/%{name}-C.omf >/tmp/%{name}-C.omf
rm $RPM_BUILD_ROOT%{_datadir}/omf/%{name}/%{name}-C.omf
mv /tmp/%{name}-C.omf $RPM_BUILD_ROOT%{_datadir}/omf/%{name}/%{name}-C.omf

%clean
rm -rf $RPM_BUILD_ROOT

%post 
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="gnomemeeting.schemas"
for S in $SCHEMAS; do
        gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%files
%defattr(-,root,root)
%doc FAQ AUTHORS NEWS
%dir %{_datadir}/gnomemeeting/xdap
%dir %{_datadir}/sounds/gnomemeeting
#%{_datadir}/man/man1/gnomemeeting.1.gz
%{_bindir}/gnomemeeting*
%{_datadir}/locale/*/LC_MESSAGES/gnomemeeting.mo
%{_datadir}/applications/gnomemeeting.desktop
%{_datadir}/sounds/gnomemeeting/*
%{_datadir}/pixmaps/gnomemeeting*
%{_libdir}/bonobo/servers/gnomemeeting.server
%{_datadir}/gnomemeeting/xdap/*
%{_sysconfdir}/gconf/schemas/gnomemeeting.schemas
%{_datadir}/gnome/*
%{_datadir}/omf/*
%{_mandir}/man1/*


%changelog -n gnomemeeting
* Fri Jun 24 2005 - [email protected]
- add howl dependency

* Fri May 13 2005 - [email protected]
- Update to 1.2.1

* Mon Apr 18 2005 - [email protected]
- 6227253: Change xml file in gnomemeeting-C.omf from gnomemeeting.xml to
  sample_apps_info.xml (part of gnome-user-docs). Bit of a hack but a very easy
  one to maintain.

* Mon Mar 14 2005 - [email protected]
- uncomment omf entries from %files section

* Mon Mar 14 2005 - [email protected]
- Remove 'rm' of gnomemeeting omf files.

* Wed Feb 16 2005 - [email protected]
- Integrate docs tarball (gnomemeeting-docs-0.1linux) from [email protected].

* Fri Jan 28 2005 - [email protected]
- #6222336 : Remove gnomemeeting docs from yelp

* Tue Jan 25 2005 - [email protected]
- #6219561 : Remove gnomemeeting docs from jdstoc, take two

* Fri Jan 21 2005 - [email protected]
- #6219561 : Remove gnomemeeting docs from jdstoc

* Wed Jan 12 2005 - [email protected]
- Added gnomemeeting l10n help as dummy to show in top TOC

* Wed Dec 22 2004 - ghee,[email protected]
- Fixes 6211758 to refer to gnomemeeting own serieid rather than gedit's
  series id when generating help text. Patched this with 
  gnomemeeting-04-help-seriesid.diff which can be removed as the change
  is in CVS HEAD and OPAL.

* Mon Dec 06 2004 - [email protected]
- #6199919 : convert help files for for javahelp and deliver helpsets

* Wed Sep 15 2004 - [email protected]
- Upreved to 1.0.2 to that version released uptodate.

* Thu Aug 26 2004 - [email protected]
- Add unpackaged files to %files.
- Specify mandir in configure.

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gnomemeeting-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed May 12 2004 - [email protected]
- Updated l10n content to gnomemeeting-l10n-po-1.1.tar.bz2

* Mon Apr 12 2004 - [email protected]
- Add --with-pwlib-dir and --with-openh323-dir to configure line to
  allow compiling on Solaris.

* Thu Apr  1 2004 - [email protected]
- Removed gnomemeeting-03-g11n-schemas.diff because it is none sense 

* Wed Mar 31 2004 - [email protected]
- replace tar jxf with the more solaris friendly
  bzcat piped through tar

* Mon Mar 29 2004 - [email protected]
- Adding gnomemeeting-l10n-po-1.0.tar.bz2 l10n content

* Tue Mar 16 2004 - [email protected]
- Added gnomemeeting-02-g11n-potfiles.diff
- Added gnomemeeting-03-g11n-schemas.diff to fix 4996253
* Mon Mar 01 2004 - [email protected]
- Recreate patch gnomemeeting-01-correct-desktop-filename.diff so that the
  it appears correctly on the launch menu.

* Fri Feb 27 2004 - [email protected]
- Built gnomemeeting 1.00. The patches may not be necessary. Will look at these
  next week.

* Mon Jan 12 2004 - <[email protected]>
- Patched build problem due to a change in version of libxml2 and gtk2 from QS.

* Fri Oct 17 2003 - <[email protected]>
- Updated to version 0.98.5 from GNOME 2.4 for QS build.

* Mon Aug 18 2003 - [email protected]
- Now that we got the corrected heimdal-devel rpm to build gnomemeeting
  for Merucry. Added the patch to match the UI spec.

* Tue Jul 16 2003 - [email protected] 
- Initial release for gnomemeeting