gnopernicus.spec
author dermotm
Mon, 24 Jul 2006 12:30:39 +0000
branchgnome-2-10
changeset 19949 94f49bf19351
parent 19838 42a3a4365a3b
permissions -rw-r--r--
access control test #4

#
# spec file for package gnopernicus
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         gnopernicus
License:      LGPL
Group:        System/Libraries
Version:      0.11.1
Release:      242
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Integrated screen reader and magnifier for GNOME
Source:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.11/%{name}-%{version}.tar.bz2
Source1:      srcore.1.gz
Patch1:       gnopernicus-01-configure.diff
Patch2:       gnopernicus-02-immortal-speech.diff
Patch3:       gnopernicus-03-table-search-limit.diff
URL:          http://developer.gnome.org/projects/gap/
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on
Prereq:	      /sbin/ldconfig
Prereq:       GConf

%define gtk2_version 2.2.4
%define atk_version 1.6.0
%define gail_version 1.5.7
%define gnome_speech_version 0.3.0
%define libgnomeui_version 2.4.0
%define at_spi_version 1.5.4

BuildRequires: gtk2-devel >= %{gtk2_version}
BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: gnome-speech >= %{gnome_speech_version}
BuildRequires: gail-devel >= %{gail_version}
BuildRequires: at-spi >= %{at_spi_version}
Requires:      gtk2 >= %{gtk2_version}
Requires:      libgnomeui >= %{libgnomeui_version}
Requires:      gail >= %{gail_version}

%description
The Gnopernicus project aims to enable users with limited vision, or no vision, to use the Gnome 2 desktop and Gnome/GTK+-2 applications effectively. By providing automated focus tracking and fullscreen magnification, Gnopernicus aids low-vision Gnome users, and its screen reader features allow low-vision and blind users access to standard GTK+2 and Java-based GUI applications via speech and braille output.

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}			\
            --sysconfdir=%{_sysconfdir}		\
	    --libdir=%{_libdir}			\
	    --bindir=%{_bindir}			\
            --libexecdir=%{_libexecdir}		\
	    --includedir=%{_includedir}		\
	    --mandir=%{_mandir}			\
            --disable-gtk-doc
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man1

# Delete items that we don't want in the package.
rm -rf $RPM_BUILD_ROOT/usr/var/scrollkeeper

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig
SCHEMAS="brlmonitor.schemas	\
	gnopernicus.schemas	\
	remote.schemas"
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
for S in $SCHEMAS; do
  gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%postun
/sbin/ldconfig

%files
%defattr(-,root,root)
%{_bindir}/*
%{_libexecdir}/*
%{_includedir}/gnopernicus-1.0/*/*
%{_libdir}/gnopernicus-1.0/*
%{_libdir}/pkgconfig/*.pc
%{_datadir}/applications/*
%{_datadir}/gnopernicus
%{_datadir}/pixmaps/*
%{_datadir}/gnome/help/*
%{_datadir}/locale/*/*/*
%{_datadir}/omf/gnopernicus/*.omf
%{_sysconfdir}/gconf/schemas/*.schemas
%{_sysconfdir}/gnopernicus-1.0/translation_tables/*.a2b
%{_mandir}/man1/*

%changelog 
* Mon Jun 13 2005 - [email protected]
- Revised patch gnopernicus-09-table-search-limit.diff
  adds fix for #6282447, and change patch level to -p1.

* Thu Jun 09 2005 - [email protected]
- Added patch gnopernicus-09-table-search-limit.diff
  fix for bug #6283137. (Approved by Karl and Peter, pending test).

* Tue May 31 2005 - [email protected]
- Added patch gnopernicus-05-immortal-speech.diff, 
  fix for bug #6275999. (Approved by Karl and Peter).

* Wed May 18 2005 - [email protected]
- Revved to 0.11.1  This fixes the build issue more satisfactorily, and gives 
  us fixes for bugs #6260702, #6241438, #6261265, #6224601.

* Mon May 16 2005 - [email protected]
- Bump to 0.10.9

* Thu May 05 2005 - [email protected]
- Temporary workaround to fix the build.

* Wed May 04 2005 - [email protected]
- Revved to 0.10.9.1  Removed obsolete patch gnopernicus-03-g11n-alllinguas.diff

* Wed Apr 20 2005 - [email protected]
- Revved to 0.10.7, bugfix for 6193299.

* Mon Apr 18 2005 - [email protected]
- Revved to 0.10.6, bugfixes for 6241438, bugzilla 171865, 171564.

* Wed Mar 23 2005 - [email protected]
- Revved to 0.10.5, bugfixes for 6219003, 6232202, 6232197, 
  6239339, 6241438.

* Tue Mar 15 2005 - [email protected]
- adding in fix for CR 6240135 - reverting to version 13 of tarball

* Tue Mar 15 2005 - [email protected]
- Back out gnopernicus-l10n-po-1.16.tar.bz2 change as it breaks product.

* Thu Mar 10 2005 - [email protected]
- Remove scrollkeeper files as they are not needed in the package.

* Wed Mar 09 2005 - [email protected]
- Revved to 0.10.4, removed patches 5, 6, and 7 as they are now 
  in the tarball.

* Wed Feb 09 2005 - [email protected]
- #6227299 - Deliver figures dir, update patch 07-figures.diff

* Wed Jan 26 2005 - [email protected]
- Update docs with Linux specific tarball from [email protected].

* Thu Jan 20 2005 - [email protected]
- Added gnopernicus-07-single-line-speech.diff, for bug 6186020
  fix completion.  Added as %patch6, sorry.
- Added gnopernicus-08-no-focus.diff, for bug 6216594.

* Wed Jan 19 2005 - [email protected]
- Bumped to 0.10.0
- Added patch gnopernicus-06-text-patch.diff, for bug 6207171.
  Should be removed when 0.10.1 is used.

* Fri Jan 07 2005 - [email protected]
- Bumped to 0.9.19.
- Fixes for 6186020, 6191352, 6193299, 6193205, 5083128, 
  6208841, 6205765, 6205770, 6202337, 6200573, 5095976.

* Mon Dec 27 2004 - [email protected]
- Updated l10n help tarball and patch for 6197780

* Fri Nov 19 2004 - [email protected]
- add --bindir=%{_bindir}, --libdir=%{_libdir} and --includedir=%{_includedir}
  to configure opts.

* Fri Nov 12 2004 - [email protected]
- Added workaround fix for 6193354

* Fri Nov 12 2004 - [email protected]
- Integrate updated docs tarball from [email protected].

* Wed Nov 10 2004 - [email protected]
- Bump to 0.9.17; Remove patches -04 and -05. 

* Tue Nov 09 2004 - [email protected]
- Add docs tarball from [email protected]. Add patch so figures are picked up.

* Thu Nov 04 2004 - [email protected]
- Added gnopernicus-06-g11n-potfiles.diff to update POTFILES.in

* Thu Oct 28 2004 - [email protected]
- Add patch gnopernicus-05-read-text.diff for bugzilla #156466.

* Thu Oct 28 2004 - [email protected]
- Add srcore.1 man page

* Thu Oct 28 2004 - [email protected]
- Modified patch gnopernicus-04-layered-pane-selection-changed.diff
  (Added the second patch attached to bugzilla bug #149146)

* Tue Oct 19 2004 - [email protected]
- Add patch gnopernicus-04-layered-pane-selection-changed.diff
  to report 'object:selection-changed' inside a 'layered pane'

* Thu Oct 14 2004 - [email protected]
- Bump to 0.9.16

* Fri Oct 01 2004 - [email protected]
- Bump to 0.9.14

* Wed Sep 29 2004 - [email protected]
- Bump to 0.9.13
- Added patch gnopernicus-01-check-speech-retval.diff for bug 150518 as it is
in tarball..

* Mon Sep 20 2004 - [email protected]
- Added gnopernicus-03-g11n-alllinguas.diff to include hu,zh_TW linguas.

* Tue Sep 14 2004 - [email protected]
- Added gnopernicus-02-g11n-potfiles.diff

* Tue Sep 14 2004 - [email protected]
- Specify libexecdir in configure. This will set it to /usr/lib on Solaris.

* Thu Sep 2 2004 - [email protected]
- libexecdir packaged
* Wed Sep 1 2004 - [email protected]
- Added %requires rule for at-spi, BuildRequires >= 1.5.4.

* Tue Aug 31 2004 - [email protected]
- Revved to 0.9.10, to get bug fixes (partial and complete)
  for 145258, 149785, 149789, 150377, 151114.
- Added patch gnopernicus-01-check-speech-retval.diff for bug 150518.
- Removed older patches, they are now in the tarball.

* Mon Aug 30 2004 - [email protected]
- Added patch gnopernicus-03-mozilla-newline-fix.diff, to fix 151114.
- Should be reverted (along with other patches) when we rev our version.

* Wed Aug 18 2004 - [email protected]
- Add patch gnoperncius-02-fix-crashes.diff to fix bugs 150377, 150261,
150048, 149408 and 150278.

* Thu Aug 05 2004 - [email protected]
- Add patch gnoperncius-01-fix-compile.diff to fix compile error on Solaris.

* Tue Aug 03 2004 - [email protected]
- Bump to 0.9.8

* Fri Jul 30 2004 - [email protected]
- Bump to 0.9.7, remove patches

* Wed Jul 14 2004 - [email protected]
- Added patch 02 to fix but 143588.

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gnopernicus-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Fri Jun 18 2004 - <[email protected]>
- Add patch gnopernicus-01-remove-layer5.diff to fix bugzilla #143588.

* Wed Jun 09 2004 - <[email protected]>
- Bump to 0.9.5

* Thu May 27 2004 - <[email protected]>
- Bump to 0.9.4; remove previous patch.

* Thu May 27 2004 - <[email protected]>
- Add patch gnopernicus-01-fix-schema.diff to fix build problem on Solaris

* Wed May 26 2004 - <[email protected]>
- Bump to 0.9.3

* Fri May 14 2004 - <[email protected]>
- Bump to 0.9.2

* Wed May 12 2004 - [email protected]
- Updated l10n content to gnopernicus-l10n-po-1.1.tar.bz2

* Wed May 12 2004 - <[email protected]>
- Add entry in %files to translation tables

* Fri Apr 30 2004 - <[email protected]>
- Bump to 0.9.1

* Thu Apr 22 2004 - <[email protected]>
- Bump to 0.9.0

* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris

* Wed Apr 07 2004 - <[email protected]>
- Bump to 0.8.2

* Thu Apr 01 2004 - [email protected]
- Javahelp conversion

* Wed Mar 31 2004 - [email protected]
- replace tar jxf with the more solaris friendly
  bzcat piped through tar

* Mon Mar 29 2004 - [email protected]
- Adding gnopernicus-l10n-po-1.0.tar.bz2 l10n content

* Wed Mar 24 2004 - <[email protected]>
- Fix up the build requirements a little so it should 
  build gail first.

* Tue Mar 23 2004 - <[email protected]>
- Bump to 0.8.1

* Thu Mar 11 2004 - <[email protected]>
- Reset release to 1.

* Wed Mar 10 2004 - [email protected]
- Bump to 0.7.6

* Tue Feb 24 2004 - [email protected]
- Created new spec file for gnopernicus