libgsf.spec
author dermotm
Mon, 24 Jul 2006 12:30:39 +0000
branchgnome-2-10
changeset 19949 94f49bf19351
parent 19719 d184ca39d269
permissions -rw-r--r--
access control test #4

#
# spec file for package libgsf
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

#####################################
##   Package Information Section   ##
#####################################

Name:			libgsf
License:		LGPL
Group:			System/Libraries
Version:		1.12.1
Release:	 	1	
Distribution:		Java Desktop System
Vendor:			Sun Microsystems, Inc.
Summary:		The GNOME Structured File Library
Source:			http://ftp.gnome.org/pub/gnome/sources/libgsf/1.12/%{name}-%{version}.tar.bz2
Patch0:			libgsf-01-uninstalled-pc.diff
URL:			http://ftp.gnome.org/pub/gnome/sources/libgsf/
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
Docdir:			%{_defaultdocdir}/doc
Autoreqprov:		on
Prereq:                 /sbin/ldconfig

#####################################
##     Package Defines Section     ##
#####################################

%define			glib2_version	2.6.0
%define			zlib_version	1.2.1
%define			libxml2_version	2.6.7
%define			bzip2_version	1.0.2
%define			libbonobo_version	2.6.0
%define			gnome_vfs_version	2.6.0

#####################################
##  Package Requirements Section   ##
#####################################

Requires:		glib2	>=	%{glib2_version}
Requires:		libxml2	>=	%{libxml2_version}
Requires:		zlib	>=	%{zlib_version}
Requires:		bzip2	>=	%{bzip2_version}
Requires:		libbonobo	>=	%{libbonobo_version}
Requires:		gnome-vfs	>=	%{gnome_vfs_version}
BuildRequires:		glib2-devel >= %{glib2_version}
BuildRequires:		libxml2-devel	>=	%{libxml2_version}
BuildRequires:		zlib-devel	>=	%{zlib_version}
BuildRequires:		bzip2	>=	%{bzip2_version}
BuildRequires:		libbonobo-devel	>=	%{libbonobo_version}
BuildRequires:		gnome-vfs-devel	>=	%{gnome_vfs_version}

#####################################
##   Package Description Section   ##
#####################################

%description
libgsf project aims to provide an efficient extensible i/o abstraction for
dealing with different structured file formats.

#####################################
##   Package Development Section   ##
#####################################

%package devel
Summary:		libgsf development headers
Group:			Development/Libraries
Requires:		%{name} = %{version}
Requires:		glib2-devel >= %{glib2_version}
Requires:		libxml2-devel	>=	%{libxml2_version}
Requires:		zlib-devel	>=	%{zlib_version}
Requires:		bzip2	>=	%{bzip2_version}
Requires:		libbonobo-devel	>=	%{libbonobo_version}
Requires:		gnome-vfs-devel	>=	%{gnome_vfs_version}

%description devel
libgsf development headers

#####################################
##   Package Preparation Section   ##
#####################################

%prep
%setup -q
%patch0 -p1

#####################################
##      Package Build Section      ##
#####################################


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CFLAGS="$RPM_OPT_FLAGS"			\
aclocal $ACLOCAL_FLAGS
automake -a -c -f
autoconf
./configure --prefix=%{_prefix}			\
	    --bindir=%{_bindir}			\
	    --libdir=%{_libdir}			\
            --includedir=%{_includedir}         \
	    --sysconfdir=%{_sysconfdir}		\
	    --with-gnome			\
	    --with-bz2				\
	    --enable-gtk-doc			\
	    --with-html-dir=%{_datadir}/gtk-doc/html/libgsf
make -j $CPUS

%install
make install DESTDIR=$RPM_BUILD_ROOT
#Clean up unpackaged files
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*.la

%clean
rm -rf $RPM_BUILD_ROOT

#########################################
##  Package Post[Un] Install Section   ##
#########################################

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

#####################################
##      Package Files Section      ##
#####################################

%files
%defattr(-,root,root)
%{_libdir}/*.so.*

%files devel
%defattr(-,root,root)
%{_includedir}/*
%{_libdir}/*.so
%{_libdir}/pkgconfig/*
%{_datadir}/gtk-doc/html/libgsf/*

%changelog
* Wed Jun 15 2005 - [email protected]
- Bump to 1.12.1

* Tue May 24 2005 - [email protected]
- Turn on --enable-gtk-doc on Solaris since it works now.

* Tue May 24 2005 - [email protected]
- libgsf-02-gtkdoc.diff removed

* Thu May 19 2005 - [email protected]
- ported to 2.10

* Fri Nov 12 2004 - [email protected]
- added --libdir and --bindir to configure opts so they can be redirected
  on Solaris

* Mon Sep 20 2004 - [email protected]
- added patch 01 (gtkdoc) back - it's needed to build on linux

* Mon Sep 13 2004 - [email protected]
- Disable gtk-doc on Solaris to get module to build.

* Wed Sep 01 2004 - [email protected]
- fixed gtk-doc path problem

* Tue Aug 24 2004 - [email protected]
- Enabling gtk-docs and setting with-html-dir to place them in
  the standard gtk-doc location.

* Thu Jul 07 2004 - [email protected]
- ported to rpm4

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Mon Apr 12 2004 - <[email protected]
- Added patch 1 to add uninstalled.pc file for Solaris build.

* Tue Feb 24 2004 - <[email protected]>
- Fixed distro typo

* Tue Feb 24 2004 - <[email protected]>
- Update Distro

* Tue Oct 21 2003 - <[email protected]>
- Updated to 1.8.2.

* Thu Aug 14 2003 - <[email protected]>
- move lib*.so to -devel, remove *.a, *.la

* Thu Jul 17 2003 - [email protected]
- Initial package