magicdev.spec
author dermotm
Mon, 24 Jul 2006 12:30:39 +0000
branchgnome-2-10
changeset 19949 94f49bf19351
parent 19733 2ce91108f14e
permissions -rw-r--r--
access control test #4

#
# spec file for package magicdev
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         magicdev
License:      GPL
Group:        Applications/System
Version:      1.1.7
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      A GNOME daemon for automatically mounting/playing CDs.
Source:       magicdev-%{version}.tar.bz2
Patch1:       magicdev-01-autorun-and-subfs.diff
Patch2:       magicdev-02-disable-CDR-DVD.diff
Patch3:	      magicdev-03-window-icon.diff
Patch4:	      magicdev-04-settings-menu-reorder.diff
Patch5:       magicdev-05-no-mount.diff
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
AutoReqProv:  on

%define gnome_mime_data_version 2.2.0
%define libgnomeui_version 2.2.0.1
%define libglade_version 2.0.1

Requires:      gnome-mime-data >= %{gnome_mime_data_version}
BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: libglade-devel >= %{libglade_version}

%description
Magicdev is a daemon that runs within the GNOME environment and
detects when a CD is removed or inserted. Magicdev handles running
autorun programs on the CD, updating the File Manager, and playing
audio CDs.

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

%configure
libtoolize --force
aclocal
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS" \
  ./configure --prefix=%{_prefix} \
	--sysconfdir=%{_sysconfdir}
make -j $CPUS

%install
rm -rf $RPM_BUILD_ROOT

export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL


%clean
rm -rf $RPM_BUILD_ROOT

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="magicdev.schemas"
for S in $SCHEMAS; do
  gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S > /dev/null
done

%files
%defattr(-,root,root)
%{_bindir}/*
%{_datadir}/control-center-2.0/capplets
%{_datadir}/magicdev
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_sysconfdir}/gconf/schemas/*.schemas

%changelog
* Wed Jun 15 2005 - [email protected]
- Bumped to 1.1.7
- Remove/Re-Apply/Merge patches

* Tue Feb 15 2005 - [email protected]
- Added magicdev-10-autorun.diff for Cinnabar to fix 6227215.
  Approved by Niall.

* Tue Jan 24 2005 - [email protected]
- Added magicdev-09-handle-subfs.diff for Cinnabar to fix 6199800.
  Patch produced by Alo and tested by me.

* Fri Jan 21 2005 - [email protected]
- Added magicdev-08-no-mount.diff to fix bug #6219527

* Fri Nov 05 2004 - [email protected]
- Added magicdev-07-g11n-autorun.diff to fix autorun.

* Thu Oct 07 2004 - [email protected]
- Added magicdev-06-g11n_alllinguas.diff to add ko locale

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to magicdev-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Mon Jun 07 2004 - [email protected]
- Updated patch magicdev-05-help.diff with 
  the correct xml filename.

* Wed May 12 2004 - [email protected]
- Updated l10n content to magicdev-l10n-po-1.1.tar.bz2

* Wed Mar 31 2004 - [email protected]
- replace tar jxf with the more solaris friendly
  bzcat piped through tar

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to magicdev-l10n-po-1.0.tar.bz2

* Wed Mar 03 2004  <[email protected]>
- Added a help button to the cd device options capplet

* Wed Feb 11 2004 Matt Keenan <[email protected]>
- Bump to 1.1.5, re-apply patches 3 & 4. Add l10n 0.7

* Mon Jul 21 2003 Glynn Foster <[email protected]>
- Add patch for settings menu reordering

* Fri Jun 27 2003 Glynn Foster <[email protected]>
- Add patch for a nice little window icon

* Fri May 30 2003 Niall Power <[email protected]>
- Initial Sun release.