usermode.spec
author dermotm
Mon, 24 Jul 2006 12:30:39 +0000
branchgnome-2-10
changeset 19949 94f49bf19351
parent 19733 2ce91108f14e
permissions -rw-r--r--
access control test #4

#
# spec file for package usermode
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

Name:			usermode
License:		GPL
Group:			Applications/System
Version:		1.68
Release:		263
Distribution:		Java Desktop System
Vendor:			Sun Microsystems, Inc.
Summary:		Tools for certain user account management tasks.
Source:			usermode-%{version}.tar.bz2
Patch1:			usermode-01-dont-use-desktop-file-install.diff
Patch2:                 usermode-02-dont-use-libuser.diff
Patch3:                 usermode-03-remove-console-apps-user-support.diff
Patch4:                 usermode-04-bad-passwd-message.diff 
Patch5:                 usermode-05-maintain-http-proxy.diff
Patch6:                 usermode-06-enable-deprecated-widgets.diff
Patch7: 		usermode-07-g11n-i18n-ui.diff
Patch8: 		usermode-08-protocol.diff
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
Docdir:			%{_defaultdocdir}/doc
Autoreqprov:		on

%define gtk2_version 2.2.1
%define startup_notification_version 0.5
%define libglade_version 2.0.1

Requires: pam, util-linux

BuildRequires: pam-devel, util-linux
BuildRequires: gtk2-devel >= %{gtk2_version}
BuildRequires: startup-notification-devel >= %{startup_notification_version}
BuildRequires: libglade-devel >= %{libglade_version}

%description
The usermode package contains the userhelper program, which can be
used to allow configured programs to be run with superuser privileges
by ordinary users.


%package gtk
Summary:		Graphical tools for certain user account management tasks.
Group:			Applications/System
Requires:		usermode = %{version}-%{release}

%description gtk
The usermode-gtk package contains several graphical tools for users:
userinfo, usermount and userpasswd. Userinfo allows uses to change
their finger information. Usermount allows users to mount, unmount,
and format their filesystems. Userpasswd allows users to change their
passwords.


%prep
%setup -q
%patch1
%patch2
%patch3
%patch4 -p1
%patch5
%patch6 -p1
%patch7 -p1
%patch8 -p1


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

aclocal
automake -a --copy --force
autoconf
CFLAGS="$RPM_OPT_FLAGS"				\
./configure --prefix=%{_prefix}			\
	    --mandir=%{_mandir}			\
	    --sysconfdir=%{_sysconfdir}
make -j $CPUS

%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT

for iii in poweroff halt reboot; do
  ln -s consolehelper $RPM_BUILD_ROOT%{_bindir}/${iii}
  install -m 644 -D shutdown.pamd $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/$iii
done

#Remove the stuff we don't want to deliver
rm $RPM_BUILD_ROOT%{_bindir}/shutdown
rm $RPM_BUILD_ROOT%{_bindir}/usermount
rm $RPM_BUILD_ROOT%{_datadir}/control-center-2.0/capplets/userinfo.desktop
rm $RPM_BUILD_ROOT%{_datadir}/control-center-2.0/capplets/usermount.desktop
rm $RPM_BUILD_ROOT%{_mandir}/man1/userinfo*
rm $RPM_BUILD_ROOT%{_mandir}/man1/usermount*

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root)
%{_sysconfdir}/pam.d/*
%{_sysconfdir}/security/console.apps/*
%{_bindir}/consolehelper
%{_bindir}/poweroff
%{_bindir}/halt
%{_bindir}/reboot
%{_mandir}/man8/consolehelper*
%{_mandir}/man8/userhelper*
%attr(4711,root,root) %{_prefix}/sbin/userhelper
%{_prefix}/share/locale/*/LC_MESSAGES/*.mo


%files gtk
%defattr(-,root,root)
%{_bindir}/consolehelper-gtk
%{_bindir}/userpasswd
%{_bindir}/pam-panel-icon
%{_mandir}/man1/userpasswd.1*
%{_datadir}/control-center-2.0/capplets/userpasswd.desktop
%{_datadir}/pixmaps/*
%{_datadir}/usermode


%changelog
* Wed Jul 27 2005 - <[email protected]>
- Removed patch usermode-08-exit-status.diff as it was added specifically
  to fix an issue with nfs mount/share features. But these features have
  been removed from cinnabar release onwards. Renamed other patches.

* Thu May 20 2005 - [email protected]
- Added patch usermode-10-protocol.diff to fix #5101042

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to usermode-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- ported to rpm4

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed May 12 2004 - [email protected]
- Updated l10n content to usermode-l10n-po-1.1.tar.bz2

* Wed Mar 31 2004 - [email protected]
- replace tar jxf with the more solaris friendly
  bzcat piped through tar

* Mon Mar 29 2004 - [email protected]
- Adding usermode-l10n-po-1.0.tar.bz2 l10n content

* Mon Mar 22 2004 - <[email protected]>
- Added usermode-09-g11n-i18n-ui.diff to fix 4951360

* Fri Feb 27 2004 - <[email protected]>
- Added patch usermode-08-exit-status.diff to make userhelper return 
  correct exit code.

* Wed Jan 07 2004 - <[email protected]>
- Add patch to enable compilation of deprecated widgets.

* Fri Nov 07 2003 - <[email protected]> 1.68-20
- Add patch to not unset $http_proxy and $ftp_proxy.

* Tue Sep 23 2003 - <[email protected]>
- Produce an error message that's actully useful
  for PAM_AUTHTOK_ERR occurences.

* Mon Jul 28 2003 - <[email protected]>
- Eek. Authenticate as root, not the user.

* Sun Jul 27 2003 - <[email protected]>
- Kill %config flags.

* Sun Jul 27 2003 - <[email protected]>
- Remove support for specifying USER in console.apps/*

* Sun Jul 27 2003 - <[email protected]>
- Install manpages in correct location

* Sat Jul 26 2003 - <[email protected]>
- Install pam-panel-icon

* Wed Jul 23 2003 - <[email protected]>
- Fixed POTFILES.in

* Tue Jul 22 2003 - <[email protected]>
- Remove libuser dependancy. userinfo doesn't really make
  much sense for us.

* Mon Jul 21 2003 - <[email protected]>
- install userpasswd

* Wed Jul 09 2003 - <[email protected]>
- Initial spec file