aspell.spec
author hh150184
Tue, 24 Jan 2006 11:56:37 +0000
branchgnome-2-12
changeset 19207 b59a653a3329
parent 6244 f5e4528b4be9
child 6414 aba60f23ccf0
permissions -rw-r--r--
* evolution-jescs.spec: Bump to 2.4.4, Remove unused define evolution_imagesdir and evolution_libsdir, Remove hard code 1.2, 2.4. * Solaris/SUNWevolution-jescs.spec: Remove *.la under /usr/lib when install, s/evolution-data-server-1.2/evolution-data-server-*/g.

#
# License (c) 2005 Sun Microsystems Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

Name:     	aspell
Version: 	0.50.3
Release:        356
Vendor:		Sun Microsystems, Inc.
Distribution:	Java Desktop System
License:	LGPL
BuildRoot:	%{_tmppath}/%{name}-%{version}-build
Docdir:         %{_datadir}/doc
Autoreqprov:	on
URL:		http://www.sun.com/software/javadesktopsystem/
Epoch:		2
Source:		ftp://ftp.gnu.org/gnu/aspell/%{name}-%{version}.tar.gz
Patch:		aspell-01-forte.diff
Summary:	A spelling checker.
Group:		Applications/Text
Obsoletes:	pspell < 0.50
Obsoletes:	aspell-en-gb < 0.50
Obsoletes:	aspell-en-ca < 0.50
Obsoletes:	aspell-en < 0.50

%description
Aspell is a spelling checker designed to eventually replace Ispell.
It also has support for checking (La)TeX and Html files, and run time
support for other non-English languages.

%files
%defattr(-, root, root)
%doc README TODO manual/man-html manual/man-text
%{_bindir}/*
%{_datadir}/aspell
%{_libdir}/lib*.so.*


%package -n aspell-devel
Summary:	Static libraries and header files for aspell
Group:		Applications/Text
Requires:	aspell => %{version}-%{release}
Obsoletes:	pspell-devel < 0.50

%description -n aspell-devel
Aspell is a spelling checker. The aspell-devel package includes the
static libraries and header files needed for Aspell development.  Note
that the recommend way to use aspell is through the Pspell library.

%files -n aspell-devel
%defattr(-, root, root)
%{_libdir}/*.so*
%{_includedir}/*

%prep
%setup  -q -n %{name}-%{version}
%patch -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS
autoconf
automake -a -c -f
CFLAGS="$RPM_OPT_FLAGS" ./configure \
    --prefix=%{_prefix} \
    --sysconfdir=/etc \
    --mandir=%{_mandir} \
    --infodir=%{_datadir}/info \
    --localstatedir=/var

# The -Qoption ld thingie: workaround for forte bug 5053572
# The postdeps thingie: libtool is being too smart
cp libtool libtool.orig && \
    sed \
        -e 's/^wl="-Qoption ld "/wl=""/' \
        -e 's/^postdeps="-lCstd -lCrun"/postdeps=""/' \
    libtool.orig > libtool

make -j$CPUS


%install
make install DESTDIR=$RPM_BUILD_ROOT mkdir_p="mkdir -p"
rm $RPM_BUILD_ROOT%{_libdir}/*.la


%clean
rm -rf $RPM_BUILD_ROOT


%changelog
* Fri Sep 09 2005 - [email protected]
- make it not crash when built with libtool 1.5.20
* Wed Sep 07 2005 - [email protected]
- run autoconf; remove libtool hack -- no longer needed
* Fri Aug 05 2005 - [email protected]
- simplify spec file
* Fri Jan 28 2005 - [email protected]
- Fix the wrong description by script failure.
* Fri Jan 14 2005 - [email protected]
- Fix 5108760: Remove Epoch macro, causing dependency problem with YaST.
* Mon Aug 23 2004 - [email protected]
- Add Epoch macro to requires feild of the devel package.
  Under rpm4 rules it won't install without it.
* Fri Aug 20 2004 - [email protected]
- Delete *.la in %install so they are not reported as unpackaged files.
* Thu May 27 2004 - [email protected]
- added patch to compile with Forte
- hack libtool to work around a forte bug