dasher.spec
author hh150184
Tue, 24 Jan 2006 11:56:37 +0000
branchgnome-2-12
changeset 19207 b59a653a3329
parent 6056 0621144e1ff7
child 6628 013528515881
permissions -rw-r--r--
* evolution-jescs.spec: Bump to 2.4.4, Remove unused define evolution_imagesdir and evolution_libsdir, Remove hard code 1.2, 2.4. * Solaris/SUNWevolution-jescs.spec: Remove *.la under /usr/lib when install, s/evolution-data-server-1.2/evolution-data-server-*/g.

#
# spec file for package dasher
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:           dasher
License:	GPL
Group:		System/GUI/GNOME
Version:        3.2.18
Release:	1
Distribution:	Java Desktop System
Vendor:		Sun Microsystems, Inc.
Summary:	Predictive text entry system
Source:		http://ftp.gnome.org/pub/GNOME/sources/dasher/3.2/%{name}-%{version}.tar.bz2
Patch1:         dasher-01-trace.diff
URL:		http://www.gnome.org
BuildRoot:	%{_tmppath}/%{name}-%{version}-build
Docdir:		%{_defaultdocdir}/%{name}
Autoreqprov:	on

%define gtk2_version 2.3.1
%define GConf_version 2.4.0.1
%define libgnomeui_version 2.6.0
%define libwnck_version 2.6.0
%define gnome_speech_version 0.3.0

Requires:	gtk2 >= %{gtk2_version}
Requires:	GConf >= %{GConf_version}
Requires:	libgnomeui >= %{libgnomeui_version}
Requires:	libwnck >= %{libwnck_version}
Requires:	gnome-speech >= %{gnome_speech_version}
BuildRequires:  gtk2-devel >= %{gtk2_version}
BuildRequires:  GConf-devel >= %{GConf_version}
BuildRequires:  libgnomeui-devel >= %{libgnomeui_version}
BuildRequires:  libwnck-devel >= %{libwnck_version}
BuildRequires:  gnome-speech-devel >= %{gnome_speech_version}
BuildRequires:  intltool

%description
Dasher is a zooming predictive text entry system, designed for situations
where keyboard input is impractical (for instance, accessibility or PDAs). It
is usable with highly limited amounts of physical input while still allowing
high rates of text entry.

%prep
%setup -q
%patch1 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

aclocal $ACLOCAL_FLAGS
autoheader
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
	--prefix=%{_prefix} \
	--sysconfdir=%{_sysconfdir} \
	--mandir=%{_mandir}
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make -i install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, root)
%{_bindir}/*
%{_datadir}/applications
%{_datadir}/dasher
%{_datadir}/gnome/help
%{_datadir}/icons
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/man
%{_datadir}/omf

%changelog
* Fri Sep 30 2005 - [email protected]
- Add patch 1 to get dasher to compiler.  Got Trace.cpp from
  CVS head.  Seems to be a bug in dasher that this file isn't
  included in the compile, so submitted a bug to bugzilla.  
  I suspect Forte's stricter linking rules cause this issue
  on Solaris.

* Thu Sep 08 2005 - [email protected]
- Bump to 3.2.18.

* Tue May 24 2005 - [email protected]
- Initial spec