gnome-mag.spec
author hh150184
Tue, 24 Jan 2006 11:56:37 +0000
branchgnome-2-12
changeset 19207 b59a653a3329
parent 6080 4b30e2aa0fc7
child 6920 8a1f0dcb9c72
permissions -rw-r--r--
* evolution-jescs.spec: Bump to 2.4.4, Remove unused define evolution_imagesdir and evolution_libsdir, Remove hard code 1.2, 2.4. * Solaris/SUNWevolution-jescs.spec: Remove *.la under /usr/lib when install, s/evolution-data-server-1.2/evolution-data-server-*/g.

#
# spec file for package gnome-mag
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         gnome-mag
License:      LGPL
Group:        System/Libraries
Version:      0.12.2
Release:      201
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      GNOME magnifier
Source:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.12/%{name}-%{version}.tar.bz2
Source1:      magnifier.1.gz
Patch1:       gnome-mag-01-uninstalled.pc.diff
URL:          http://developer.gnome.org/projects/gap/
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on
Prereq:	      /sbin/ldconfig

%define gtk2_version 2.2.4
%define libbonobo_version 2.4.0
%define popt_version 1.6.4
%define at_spi_version 1.5.4

# Requirements
BuildRequires: gtk2-devel >= %{gtk2_version}
BuildRequires: libbonobo-devel >= %{libbonobo_version}
BuildRequires: popt-devel >= %{popt_version}
Requires:      gtk2 >= %{gtk2_version}
Requires:      libbonobo >= %{libbonobo_version}
Requires:      at-spi >= %at_spi_version

%description
gnome-mag is a screen magnification service using Bonobo.

%prep
%setup -q
%patch1 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

autoconf
CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}			\
            --sysconfdir=%{_sysconfdir}		\
	    --libdir=%{_libdir}			\
	    --bindir=%{_bindir}			\
	    --includedir=%{_includedir}		\
            --mandir=%{_mandir}
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man1
#clean up unpackaged files
rm $RPM_BUILD_ROOT%{_libdir}/*.la


%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%defattr(-,root,root)
%{_bindir}/*
%{_includedir}/gnome-mag-1.0/*/*
%{_libdir}/*.so*
%{_libdir}/bonobo/servers/GNOME_Magnifier.server
%{_libdir}/pkgconfig/*.pc
%{_datadir}/gnome-mag/*
%{_datadir}/idl/gnome-mag-1.0/GNOME_Magnifier.idl
%{_datadir}/locale/*/*/*
%{_mandir}/man1/*

%changelog
* Tue Oct 11 2005 - [email protected]
- Bump to 0.12.2

* Thu May 12 2005 - [email protected]
- Revved to 0.12.1, fixes #6199929.  Removed obsolete g11n patch.

* Fri Feb 04 2005 - [email protected]
- Revved to 0.11.14, fixes bugzilla bug #166282 which should be a P2
  bugster bug.

* Fri Jan 21 2005 - [email protected]
  Corrected dependencies - removed gnome-speech and gail dependencies,
  added at-spi dependency (for LoginHelper API) and popt dependency.

* Wed Jan 19 2005 - [email protected]
  Revved to 0.11.13, fixes for 618662, 6217152, 6205225, 6199929.

* Tue Dec 07 2004 - [email protected]
  Revved to 0.11.11, fixes for bugs 6192805, 6182499, 6182502.

* Fri Nov 19 2004 - [email protected]
- add --bindir=%{_bindir}, --libdir=%{_libdir} and --includedir=%{_includedir}
  to configure opts.

* Fri Nov 05 2004 - [email protected]
- Revved to 0.11.10.  Should improve bugtraq 5099413 further.

* Thu Oct 28 2004 - [email protected]
- Add magnifier.1 man page

* Wed Oct 06 2004 - [email protected]
- Removed patch, revved to 0.11.8.  Partial fix for bugtraq 5099413.

* Mon Sep 20 2004 - [email protected]
- Added patch gnome-mag-02-damage-fix.diff for bugtraq 5099413.

* Tue Aug 31 2004 - [email protected]
- Revved to 0.11.7, gives readable SourceDisplay and TargetDisplay
  params, and better debugging support for XDAMAGE.

* Tue Aug 31 2004 - [email protected]
- Revved to 0.11.5, to include LoginHelper support.

* Wed Aug 18 2004 - [email protected]
- removed --disable-gtk-doc since this isn't an option this module's
  configure takes.

* Tue Aug 17 2004 - [email protected]
- Updated to version 0.11.4, to fix bug #5083109.

* Fri Jul 30 2004 - [email protected]
- Updated to version 0.11.3, which includes a fix for
  the configure path to Damage and XFixes client libs,
  which are in /usr/openwin/sfw/lib for some reason.

* Tue Jul 12 2004 - [email protected]
- fixed packaging up for rpm4

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gnome-mag-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Tue May 18 2004 - <[email protected]>
- add patch 01 (uninstalled.pc)

* Fri May 14 2004 - <[email protected]>
- Bump to 0.11.2

* Wed May 12 2004 - [email protected]
- Updated l10n content to gnome-mag-l10n-po-1.1.tar.bz2

* Thu Apr 22 2004 - <[email protected]>
- Bump to 0.11.1

* Wed Mar 31 2004 - [email protected]
- replace tar jxf with the more solaris friendly
  bzcat piped through tar

* Mon Mar 29 2004 - [email protected]
- Adding gnome-mag-l10n-po-1.0.tar.bz2 l10n content

* Tue Mar 23 2004 - <[email protected]>
- Bump to 0.10.10

* Wed Feb 25 2004 - [email protected]
- Created new spec file for gnome-mag