gtksourceview.spec
author hh150184
Tue, 24 Jan 2006 11:56:37 +0000
branchgnome-2-12
changeset 19207 b59a653a3329
parent 6016 b54189f766bc
child 6418 7d38a3af9d6f
permissions -rw-r--r--
* evolution-jescs.spec: Bump to 2.4.4, Remove unused define evolution_imagesdir and evolution_libsdir, Remove hard code 1.2, 2.4. * Solaris/SUNWevolution-jescs.spec: Remove *.la under /usr/lib when install, s/evolution-data-server-1.2/evolution-data-server-*/g.

#
# spec file for package gtksourceview
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

Name:			gtksourceview
License:		GPL
Group:			System/Libraries
Version:		1.3.93
Release:		1
Distribution:		Java Desktop System
Vendor:			Sun Microsystems, Inc.
Summary:		Syntax highlighting text widget
Source:			http://ftp.gnome.org/pub/GNOME/sources/%{name}/1.3/%{name}-%{version}.tar.bz2
Source1:		libgtksourceview-1.0.3.gz
URL:			http://www.gnome.org/
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
Docdir:			%{_defaultdocdir}/doc
Autoreqprov:		on

%define libxml_version 2.5.0
%define gtk2_version 2.2.0
%define libgnomeprint_version 2.2.0
%define gnome_vfs_version 2.2.0

BuildRequires: gnome-vfs-devel >= %{gnome_vfs_version}
BuildRequires: gtk2-devel >= %{gtk2_version}
BuildRequires: libgnomeprint-devel >= %{libgnomeprint_version}
BuildRequires: libxml2-devel >= %{libxml_version}
BuildRequires: libgnomeprintui
Requires: gnome-vfs >= %{gnome_vfs_version}
Requires: gtk2 >= %{gtk2_version}
Requires: libgnomeprint >= %{libgnomeprint_version}
Requires: libxml2 >= %{libxml_version}
Requires: libgnomeprintui

%description
GtkSourceView is a text widget that extends the standard gtk+ 2.x text widget
GtkTextView.
 
It improves GtkTextView by implementing syntax highlighting and other features
typical of a source editor.

%package devel
Summary:		gtksourceview development files
Group:			Development/Libraries/X11
Requires:		%{name} = %{version}

%description devel
Development files for gtksourceview

%prep
%setup -q

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

aclocal $ACLOCAL_FLAGS
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}			\
	    --sysconfdir=%{_sysconfdir}		\
		--enable-gtk-doc
make -j $CPUS

%install
make install DESTDIR=$RPM_BUILD_ROOT
install -d $RPM_BUILD_ROOT%{_mandir}/man3
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man3

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root)
%doc AUTHORS COPYING ChangeLog MAINTAINERS NEWS README TODO
%{_libdir}/*.so.*
%{_datadir}/gtksourceview-1.0
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/gtk-doc/html/gtksourceview

%files devel
%defattr(-,root,root)
%{_includedir}/gtksourceview-*
%{_libdir}/pkgconfig
%{_libdir}/*.la
%{_libdir}/*.so
%{_mandir}/man3/*


%changelog
* Tue Sep 27 2005 - [email protected]
- Bump to 1.3.93.

* Mon Aug 15 2005 - [email protected]
- Bump to 1.3.91.

* Thu May 19 2005 - [email protected]
- Add aclocal and automake, needed for Solaris.

* Wed Jan 12 2005 - [email protected]
- Added gtksourceview-01-g11n-ai.diff for autoindent with localized chars
  Fixed 4937266

* Fri Dec 12 2004 - [email protected]
- Replacing the gtksourceview-02-gedit-undo-sun-keyboard.diff
  patch with the one eventually got into cvs head.

* Tue Nov 09 2004 - [email protected]
- Removed gtksourceview-01-g11n-ai.diff that causes #6191240, gedit hangs when
  typing RETURN key.

* Sat Oct 30 2004 - [email protected]
- Added gtksourceview-02-gedit-undo-sun-keyboard.diff to make undo key in
  sun keyboard work for gedit application. Fixes bug #6178291.
 
* Thu Oct 28 2004 - [email protected]
- Add libgtksourceview-1.0.3 man page

* Tue Oct 05 2004 - [email protected]
- Added gtksourceview-01-g11n-ai.diff for autoindent with localized chars
  Fixed 4937266

* Wed Aug 18 2004 - [email protected]
- added --enable-gtk-doc

* Tue Jul 20 2004 - [email protected]
- Bump to 1.0.1

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gtksourceview-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed May 12 2004 - [email protected]
- Updated l10n content to gtksourceview-l10n-po-1.1.tar.bz2

* Wed Mar 31 2004 - [email protected]
- replace tar jxf with the more solaris friendly
  bzcat piped through tar

* Mon Mar 29 2004 - [email protected]
- Adding gtksourceview-l10n-po-1.0.tar.bz2 l10n content

* Mon Feb 23 2004 - <[email protected]>
- Bump to 0.9.0 tarball, update %files

* Thu Jan 29 2004 - <[email protected]>
- Add dependency on libgnomeprintui

* Wed Dec 17 2003 - <[email protected]>
- Bump to 0.7.0 tarball

* Tue Oct 21 2003 - <[email protected]> 0.6.0-2
- Fixed missing Requires and BuildRequires, comments
  and license.

* Mon Oct 20 2003 - <[email protected]> 0.6.0-1
- Initial spec file.