howl.spec
author hh150184
Tue, 24 Jan 2006 11:56:37 +0000
branchgnome-2-12
changeset 19207 b59a653a3329
parent 5518 235b0b4aa324
permissions -rw-r--r--
* evolution-jescs.spec: Bump to 2.4.4, Remove unused define evolution_imagesdir and evolution_libsdir, Remove hard code 1.2, 2.4. * Solaris/SUNWevolution-jescs.spec: Remove *.la under /usr/lib when install, s/evolution-data-server-1.2/evolution-data-server-*/g.

#
# spec file for package howl
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         howl
License:      Other
Group:        System/Libraries
Version:      1.0.0
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Cross platform implementation of Zeroconf networking
Source:       http://www.porchdogsoft.com/download/%{name}-%{version}.tar.gz
URL:          http://www.porchdogsoft.com/products/howl/
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:	      %{_defaultdocdir}/doc
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%description
Howl is a cross-platform implementation of Zeroconf networking. Zeroconf brings 
a new ease of use to IP networking.

%package devel
Summary:      Cross platform implementation of Zeroconf networking
Group:        Development/Libraries
Requires:     %{name} = %{version}

%description devel
Howl is a cross-platform implementation of Zeroconf networking. Zeroconf brings 
a new ease of use to IP networking.

%prep
%setup -q

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi
CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}		\
            --sysconfdir=%{_sysconfdir} \
            --libexecdir=%{_libexecdir} \
	    --mandir=%{_mandir}		\
            --enable-gtk-doc
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
rm $RPM_BUILD_ROOT%{_libdir}/libhowl*.a
rm $RPM_BUILD_ROOT%{_libdir}/libhowl*.la
rm $RPM_BUILD_ROOT%{_libdir}/libmDNSResponder*.a
rm $RPM_BUILD_ROOT%{_libdir}/libmDNSResponder*.la

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%clean 
rm -rf $RPM_BUILD_ROOT

%files 
%defattr(-, root, root)
%{_bindir}/*
%{_libdir}/libhowl.so.*
/usr/lib/libmDNSResponder.so.*

%files devel
%defattr(-, root, root)
%{_includedir}/howl/*
%{_libdir}/pkgconfig/*
%{_libdir}/*.so
%{_datadir}/howl/*
%{_datadir}/man/*

%changelog
* Wed Jun 15 2005 - [email protected]
- Bump to 1.0.0

* Tue May 17 2005 - [email protected]
- add %{_libdir}/*.so to devel

* Thu May 12 2005 - [email protected]
- Initial spec file for howl.