libgnomecups.spec
author hh150184
Tue, 24 Jan 2006 11:56:37 +0000
branchgnome-2-12
changeset 19207 b59a653a3329
parent 6013 2197a1920785
permissions -rw-r--r--
* evolution-jescs.spec: Bump to 2.4.4, Remove unused define evolution_imagesdir and evolution_libsdir, Remove hard code 1.2, 2.4. * Solaris/SUNWevolution-jescs.spec: Remove *.la under /usr/lib when install, s/evolution-data-server-1.2/evolution-data-server-*/g.

#
# spec file for package libgnomecups
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:     	libgnomecups
License:        LGPL
Group:		System Environment/Libraries
Version: 	0.2.2
Release:	1
Distribution:	Java Desktop System
Vendor:		Sun Microsystems, Inc.
Summary:	GNOME CUPS Library 
Source:   	http://ftp.gnome.org/pub/GNOME/sources/libgnomecups/0.2/libgnomecups-%{version}.tar.bz2
Patch1:         libgnomecups-01-i18n-nautilus-printers.diff
URL:		http://www.gnome.org/
BuildRoot:	%{_tmppath}/%{name}-%{version}-build
Docdir:         %{_docdir}/doc
Autoreqprov:	on
Prereq:         /sbin/ldconfig

%define glib2_version 2.4.0
%define cups_version 1.1.20
%define openssl_version 0.9.7

Requires:	cups >= %{cups_version}
Requires:	cups-libs >= %{cups_version}

BuildRequires:	pkgconfig
BuildRequires:	cups-devel >= %{cups_version}
BuildRequires:	cups >= %{cups_version}
BuildRequires:  openssl-devel >= %{openssl_version}

%description
A library for accessing printers on a CUPS server.

%package devel
Summary:	GNOME CUPS Library Devel
Group:		System Environment/Libraries
Autoreqprov:    on

Requires:	%{name} >= %{version}
Requires:	glib2-devel >= %{glib2_version}
Requires:	cups-devel >= %{cups_version}

%description devel
Development headers and libraries for libgnomecups

%prep
%setup -q 
%patch1 -p1


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS"                 \
./configure --prefix=/usr 		\
	--sysconfdir=/etc 		\
	--infodir=/usr/info
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%defattr(-, root, root)
%doc AUTHORS ChangeLog COPYING NEWS README
%{_libdir}/l*.so.*
%{_datadir}/locale/*/LC_MESSAGES/*.mo

%files -n libgnomecups-devel
%defattr(-, root, root)
%{_libdir}/*.so
%{_includedir}/libgnomecups-1
%{_libdir}/pkgconfig/*.pc

%changelog
* Tue Sep 27 2005 - [email protected]
- Bump to 0.2.2

* Mon May 16 2005 - [email protected]
- Bump to 0.2.0

* Mon Nov 01 2004 - [email protected]
- Uprev tarball to 0.1.8. Didn't try to go beyond this so that compatible
  version of gnome-cups-manager can also be upreved.
  Merged libgnomecups-02-g11n-alllinguas.diff into
  libgnomecups-01-i18n-nautilus-printers.diff and also removed
  libgnomecups-03-remove-assertion.diff which is in 0.1.8 tarball.
 
* Fri Oct 08 2004 - [email protected]
- Added libgnomecups-03-remove-assertion.diff.
 
* Thu Oct 07 2004 - [email protected]
- Added libgnomecups-02-g11n-alllinguas.diff to add cs,hu locales

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to libgnomecups-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- port to rpm4

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed May 12 2004 - [email protected]
- Updated l10n content to libgnomecups-l10n-po-1.1.tar.bz2

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to libgnomecups-l10n-po-1.0.tar.bz2

* Thu Feb 19 2004 - <[email protected]>
- Distro to Cinnabar, add l10n 0.8
- Add libtoolize etc..
- Port patch from QS

* Thu Oct 09 2003 - <[email protected]>
- Updated to 0.1.6 to build for Quicksilver.

* Thu Aug 14 2003 - <[email protected]>
- remove *.a, *.la

* Fri Jul 11 2003 - [email protected]
- Fixed a bug in the actual communication with the cups server via
  http connection. The fix was found after having a chat with the original
  author, Dave Camp.
* Thu Jun 26 2003 - [email protected]
- Initial Sun release with cups integraion stuff