nautilus-open-terminal.spec
author hh150184
Tue, 24 Jan 2006 11:56:37 +0000
branchgnome-2-12
changeset 19207 b59a653a3329
parent 6116 ebf401500eee
child 8514 5a2ed0a547ed
permissions -rw-r--r--
* evolution-jescs.spec: Bump to 2.4.4, Remove unused define evolution_imagesdir and evolution_libsdir, Remove hard code 1.2, 2.4. * Solaris/SUNWevolution-jescs.spec: Remove *.la under /usr/lib when install, s/evolution-data-server-1.2/evolution-data-server-*/g.

#
# spec file for package nautilus-open-terminal
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         nautilus-open-terminal
License:      GPL
Group:        System/GUI/GNOME
Version:      0.6
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Nautilus terminal extension
Source:       http://manny.cluecoder.org/packages/nautilus-open-terminal/%{name}-%{version}.tar.gz
Patch1:       nautilus-open-terminal-01-werror.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on

%define nautilus_version 2.6.0
%define eel_version 2.6.0
%define gnome_desktop_version 2.9.91

Requires:	nautilus >= %{nautilus_version}
Requires:	eel >= %{eel_version}
Requires:	gnome-desktop >= %{gnome_desktop_version}
BuildRequires:  nautilus-devel >= %{nautilus_version}
BuildRequires:  eel-devel >= %{eel_version}
BuildRequires:  gnome-desktop-devel >= %{gnome_desktop_version}

%description
Nautilus extension allowing you to open a terminal in arbitrary folders.

%prep
%setup -q
%patch1 -p1

%build
libtoolize --force
aclocal $ACLOCAL_FLAGS
automake -a -c -f
autoconf

%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
	--prefix=%{_prefix} \
	--sysconfdir=%{_sysconfdir} \
	--mandir=%{_mandir}
make -j $CPUS

%install
make -i install DESTDIR=$RPM_BUILD_ROOT
rm -rf $RPM_BUILD_ROOT/%{_libdir}/nautilus/extensions-1.0/*.a
rm -rf $RPM_BUILD_ROOT/%{_libdir}/nautilus/extensions-1.0/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, root)
%{_libdir}/nautilus/extensions-1.0/*.so
%{_datadir}/locale/*/LC_MESSAGES/*.mo

%changelog
* Mon Oct 17 2005 - [email protected]
- Add werror patch

* Mon Oct 17 2005 - [email protected]
- Initial spec file