now.spec
author hh150184
Tue, 24 Jan 2006 11:56:37 +0000
branchgnome-2-12
changeset 19207 b59a653a3329
parent 6299 4b3aea37c890
child 6565 f18e682878be
permissions -rw-r--r--
* evolution-jescs.spec: Bump to 2.4.4, Remove unused define evolution_imagesdir and evolution_libsdir, Remove hard code 1.2, 2.4. * Solaris/SUNWevolution-jescs.spec: Remove *.la under /usr/lib when install, s/evolution-data-server-1.2/evolution-data-server-*/g.

#
# spec file for package now
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

Name:         now
License:      GPL
Group:        System/GUI/GNOME
Version:      1.0.d5
Release:      59
Distribution: Java Desktop System
Vendor:	      Sun Microsystems, Inc.
Summary:      The Sun Java System Calendar Server client applet
Source:       now-%{version}.tar.bz2
Patch1:       now-01-gmtoff.diff
Patch2:       now-02-g11n-i18n-date.diff
Patch3:	      now-03-g11n-i18n-ui.diff
Patch4:       now-04-prefs-about-tittle.diff
Patch5:       now-05-launch-using-keynav.diff
URL:          http://www.gnome.org/
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}
Autoreqprov:  on

%define gnome_panel_version 2.0.0
%define librsvg_version 2.2.0
%define libghttp_version 1.0.9
%define libical_version 0.23

Requires: gnome-panel >= %{gnome_panel_version}
Requires: librsvg >= %{librsvg_version}
Requires: libghttp >= %{libghttp_version}
Requires: libical >= %{libical_version}

%description
This package contains an applet which provides information from Sun Java System 
Calendar Server account on your panel.

%prep
%setup -q
# FIXME: should really regenerate the tarball and not patch this stuff
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
perl -pi -e 's/^AC_CONFIG_AUX_DIR/dnl AC_CONFIG_AUX_DIR/' configure.in

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

LC_ALL=
LANG=
export LC_ALL LANG
glib-gettextize --force --copy
intltoolize --force --copy --automake
libtoolize --force --copy
aclocal $ACLOCAL_FLAGS
autoheader
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
    --prefix=%{_prefix} \
    --libexecdir=%{_libexecdir} \
    --sysconfdir=%{_sysconfdir}

make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 
make install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL

%clean
rm -rf $RPM_BUILD_ROOT

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="now.schemas"
for S in $SCHEMAS; do
 gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%files
%defattr(-,root,root)
%doc AUTHORS ChangeLog COPYING NEWS README
%config %{_sysconfdir}/gconf/schemas/*.schemas
#%{_bindir}/now
%{_libdir}/bonobo/servers/*.server
%{_libexecdir}/*
%{_datadir}/pixmaps/*
%{_datadir}/gnome-2.0/ui/*.xml
%{_datadir}/icons/now/
%{_datadir}/locale/*
#%{_datadir}/gnome/*
#%{_datadir}/omf/*

%changelog
* Tue Nov 29 2005 - laca.com
- remove javahelp stuff

* Mon Jun 20 2005 - [email protected]
- Hack to mkdir of config/po so that intloolize works

* Fri Mar 11 2005 - [email protected]
- Add javahelp-convert as a build requirement.

* Thu Mar 10 2005 - [email protected]
- Added now-10-launch-using-keynav.diff to allow 
  user to launch the applet using keynav.
  Fixes bug #6232700.

* Mon Jan 17 2005 - [email protected]
- Added now-09-prefs-about-tittle.diff to change the 
  preferences and about dialog tittle. Fixes bug 5077204.

* Fri Jan 14 2005 - [email protected]
- Updated l10n help tarball for cinnabar-linux
                                                                                
* Fri Nov 05 2004 - [email protected]
- Updated now-07-g11n-i18n-ui.diff to fix 6184408

* Wed Nov 03 2004 - [email protected]
- Added patch to fix localization of date (now-07-g11n-i18n-date.diff)

* Thu Oct 28 2004 - [email protected]
- Updated l10n help tarball and added pt_BR

* Fri Oct 08 2004 - [email protected]
- Added back use of now-l10n-po-* tarballs

* Fri Oct 08 2004 - [email protected]
- Fix for help build (now-06-help-build.diff)

* Thu Oct 07 2004 - [email protected]
- Fix for tm_gmtoff for Solaris (now-06-gmtoff.diff)

* Wed Oct 06 2004 - [email protected]
- Fix for BugId 5085749 (no support for timezones)
- Fix for BugId 5069959 (no command line application)
- Merged now-l10n-po-1.5.tar.bz2
- Merged now-01-g11n-i18n-ui.diff
- Merged now-02-g11n-branding.diff
- Merged now-04-help.diff
- Merged now-05-g11n-allinguas.diff
- version 1.0.d5

* Thu Sep 16 2004 - [email protected]
- Added now-05-g11n-allinguas.diff to add cs,hu linguas

* Wed Sep 01 2004 - [email protected]
- Added javahelp-convert for now docs

* Tue Aug 31 2004 - [email protected]
- Added patch to implement Help invocation.

* Tue Aug 24 2004 - [email protected]
- Add %{_datadir}/gnome and %{_datadir}/omf as added by docs tarball.

* Fri Aug 20 2004 - [email protected]
- Integrated updated docs tarball from [email protected]

* Thu Aug 05 2004 - [email protected]
- Integrated docs tarball from [email protected]
- Added patch to add Makefiles for docs files.

* Wed Jul 14 2004 - [email protected]
- rpm4 fixes

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to now-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed May 12 2004 - [email protected]
- Updated l10n content to now-l10n-po-1.1.tar.bz2

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to now-l10n-po-1.0.tar.bz2

* Fri Mar 26 2004 - [email protected]
- added --libexecdir to configure args
* Thu Mar 04 2004 - takao.fujiwara.sun.com
- Added now-01-g11n-i18n-ui.diff, now-02-g11n-branding.diff to fix 4940829

* Thu Feb 19 2004 - <[email protected]>
- Updated the name of the calendar server in now.spec

* Wed Feb 18 2004 - <[email protected]>
- Update distro to cinnaber
- add l10n-0.8
- Patches 01 & 02 need porting...

* Thu Sep 25 2003 - <[email protected]>
- Fix for BugId 4914857
- Fix for BugId 4912313
- Cosmetic fixes in GUI
- version 1.0.d4

* Mon Sep 22 2003 - <[email protected]>
- Fix for BugId 4905844
- Fix for version in the About dialog
- version 1.0.d3

* Fri Jul 11 2003 - <[email protected]>
- Initial spec file