pyxml.spec
author hh150184
Tue, 24 Jan 2006 11:56:37 +0000
branchgnome-2-12
changeset 19207 b59a653a3329
parent 6215 2653e6560475
child 6923 45fbffcf5f44
permissions -rw-r--r--
* evolution-jescs.spec: Bump to 2.4.4, Remove unused define evolution_imagesdir and evolution_libsdir, Remove hard code 1.2, 2.4. * Solaris/SUNWevolution-jescs.spec: Remove *.la under /usr/lib when install, s/evolution-data-server-1.2/evolution-data-server-*/g.

#
# spec file for package pyxml
#
# includes module(s): pyxml
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%define pythonver 2.4

Name:         pyxml
License:      CNRI Python License
Group:        Development/Languages/Python
Version:      0.8.4
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Python XML module
Source:       http://umn.dl.sourceforge.net/sourceforge/pyxml/PyXML-0.8.4.tar.gz
URL:          http://pyxml.sourceforge.net/
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/doc
Autoreqprov:  off
Prereq:       /sbin/ldconfig
Requires:     python >= %{pythonver}
Requires:     expat
BuildRequires: python-devel >= %{pythonver}
BuildRequires: expat-devel

%description
A collection of tools useful for writing basic XML applications in Python,
along with documentation and sample code.
Features include (but are not limited to) SAX, DOM, the xmlproc validating
parser, an Expat interface.

%prep
%setup -q -n PyXML-%{version}

%install
python setup.py install --prefix=$RPM_BUILD_ROOT%{_prefix}

# move to vendor-packages
mkdir -p $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
mv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages/* \
   $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages/
rmdir $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-, root, root)
%{_bindir}
%{_libdir}/python%{majorver}/vendor-packages

%changelog
* Thu Oct 27 2005 - [email protected]
- initial version