startup-notification.spec
author hh150184
Tue, 24 Jan 2006 11:56:37 +0000
branchgnome-2-12
changeset 19207 b59a653a3329
parent 6018 4d3b80b8e43b
child 8564 df62c23d2955
permissions -rw-r--r--
* evolution-jescs.spec: Bump to 2.4.4, Remove unused define evolution_imagesdir and evolution_libsdir, Remove hard code 1.2, 2.4. * Solaris/SUNWevolution-jescs.spec: Remove *.la under /usr/lib when install, s/evolution-data-server-1.2/evolution-data-server-*/g.

#
# spec file for package startup-notification
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         startup-notification
License:      LGPL
Group:        System/Libraries
Version:      0.8
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Startup Notification Library
Source:       http://ftp.gnome.org/pub/GNOME/sources/startup-notification/0.8/%{name}-%{version}.tar.bz2
Patch:        startup-notification-01-__FUNCTION__.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%description
The startup-notification library contains a reference implementation of the startup notification
protocol, as defined on http://www.freedesktop.org.

%package devel
Summary:      Startup Notification Development Library
Group:        Development/Libraries

%description devel
The startup-notification library contains a reference implementation of the startup notification
protocol, as defined on http://www.freedesktop.org.

%prep
%setup -q
%patch -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CFLAGS="$RPM_OPT_FLAGS "			\
./configure --prefix=%{_prefix}			\
            --sysconfdir=%{_sysconfdir}
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*.la

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root)
%{_libdir}/libstartup-notification*so.*

%files devel
%defattr(-, root, root)
%{_libdir}/pkgconfig/*.pc
%{_libdir}/libstartup-notification*so
%{_includedir}/startup-notification-1.0/*

%changelog
* Fri May 06 2005 - [email protected]
- Bump to 0.8

* Wed Jul 07 2004 - [email protected]
- ported to rpm4

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Sun Feb 15 2004 - <[email protected]>
- add patch to change __FUNCTION__ to __func__ for Forte compatibility

* Thu Aug 14 2003 - <[email protected]>
- move lib*.so to -devel, remove *.a, *.la

* Thu May 13 2003 - [email protected]
- Created new spec file for startup-notification