xscreensaver.spec
author hh150184
Tue, 24 Jan 2006 11:56:37 +0000
branchgnome-2-12
changeset 19207 b59a653a3329
parent 5727 6d0bc2ce2cfb
permissions -rw-r--r--
* evolution-jescs.spec: Bump to 2.4.4, Remove unused define evolution_imagesdir and evolution_libsdir, Remove hard code 1.2, 2.4. * Solaris/SUNWevolution-jescs.spec: Remove *.la under /usr/lib when install, s/evolution-data-server-1.2/evolution-data-server-*/g.

#
# spec file for package xscreensaver
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:		xscreensaver
Version:	4.10
Release:	65
License:	BSD
Group:		Amusements/Graphics
Distribution:	Java Desktop System
Vendor:		Sun Microsystems, Inc.
Summary:	Screensaver and locker
Source:		http://www.jwz.org/xscreensaver/xscreensaver-4.10.tar.gz
Source1:	xscreensaver.pamd
Patch1:		xscreensaver-01-passwd-helper.diff
Patch2:		xscreensaver-02-customise-hacks.diff
Patch3:		xscreensaver-03-dot-desktop.diff
Patch4:		xscreensaver-04-demo-title.diff
Patch5:		xscreensaver-05-gtk-dialog.diff
Patch6:		xscreensaver-06-mnemonics.diff
Patch7:		xscreensaver-07-timebarfreezes.diff
Patch8:		xscreensaver-08-rootcachingpasswd.diff
Patch9:		xscreensaver-09-g11n-lockmsg.diff
Patch10:	xscreensaver-10-xinputextsegfault.diff
Patch11:	xscreensaver-11-DisableModeMessesLocking.diff
Patch12:	xscreensaver-12-InputMethodShowsHistoryinLockDialog.diff
Patch13:	xscreensaver-13-2scrat.diff
URL:		http://www.jwz.org/xscreensaver
BuildRoot:	%{_tmppath}/%{name}-%{version}-build
Docdir:		%{_defaultdocdir}/xscreensaver
Autoreqprov:	on

BuildRequires:	pam-devel
BuildRequires:	gtk2-devel
BuildRequires:  at-spi-devel

%description
A modular screen saver and locker for the X Window System.
Highly customizable: allows the use of any program that
can draw on the root window as a display mode.

%package hacks
Summary:	Screensaver display modes for the xscreensaver package
Group:		Amusements/Graphics
Requires:	%{name} = %{version}

%description hacks
A modular screen saver and locker for the X Window System.
Highly customizable: allows the use of any program that
can draw on the root window as a display mode.
More than 150 display modes are included in this package.

%prep
%setup -q
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1
%patch11 -p1
%patch12 -p1
%patch13 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

autoconf -f
CFLAGS="$RPM_OPT_FLAGS" \
./configure --prefix=%{_prefix} \
	      --mandir=%{_mandir} \
	      --with-configdir=%{_libdir}/xscreensaver/config \
	      --with-passwd-helper="/sbin/unix2_chkpwd" \
              --with-xshm-ext \
              --without-setuid-hacks \
              --enable-locking \
              --with-pam \
              --with-gnome \
              --with-shadow \
              --with-xf86vmode-ext=no
make -j $CPUS

%clean
rm -rf $RPM_BUILD_ROOT

%install
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
mkdir -p $RPM_BUILD_ROOT%{_datadir}
make  install_prefix=$RPM_BUILD_ROOT \
      install-strip

install -d -m 755 $RPM_BUILD_ROOT/etc/pam.d
install -m 644 %SOURCE1 $RPM_BUILD_ROOT/etc/pam.d/xscreensaver
#FIXME - find out what's deliberately omitted and what is accidentally unpackaged!
rm -f $RPM_BUILD_ROOT%{_datadir}/applications/screensaver-properties.desktop
rm -f $RPM_BUILD_ROOT%{_datadir}/control-center/Desktop/screensaver-properties.desktop
rm -f $RPM_BUILD_ROOT%{_datadir}/control-center/capplets/screensaver-properties.desktop
MANPAGES="xflame xjack xlyap xmatrix xrayswarm"
for i in $MANPAGES; do
	rm $RPM_BUILD_ROOT%{_mandir}/man1/$i.1
done

%post

pids=`pidof xscreensaver`
if [ -n "$pids" ]; then
  echo "sending SIGHUP to running xscreensaver ($pids)..." >&2
  kill -HUP $pids
fi

%files
%{_bindir}/*
%{_libexecdir}/*
%defattr(-,root,root)
%doc    README README.debugging
%config /usr/X11R6/lib/X11/app-defaults/XScreenSaver
%config /etc/pam.d/*
%{_datadir}/control-center-2.0/capplets/*.desktop
%{_datadir}/xscreensaver/*
%{_prefix}/share/locale/*/LC_MESSAGES/*.mo
%{_mandir}/man1/xscreensaver*

%files hacks
%{_libdir}/xscreensaver/*
%{_mandir}/man1/[a-wy-z]*
%{_mandir}/man1/x[st][pue]*

%changelog
* Tue Sep 06 2005 - [email protected]
- Add BuildRequires at-spi because it references its header files.

* Wed May 25 2005 - [email protected]
- Fix for Bug 6242023 docs are seen in virtual area, fix is to run ./configure
-  --with-xf86vmode-ext=no option. This option went into this file xscreensaver.spec

* Wed May 25 2005 - [email protected]
- Fix for Bug 6237901 better pam implementation is being taken out, causing issues with access

* Tue May 17 2005 - [email protected]
- Fix for Bug 6237901 better pam implementation

* Tue Mar 22 2005 - [email protected]
- Fix for Bug 6209377 xscreensaver is enabling input method in lock dialog

* Tue Mar 22 2005 - [email protected]
- Fix for bug 6221109 Chaning mode from disable screensaver messes locking 

* Wed Mar 10 2005 - [email protected]
- Fix for bug 6228023 xinputextension causing seg fault

* Fri Feb 18 2005 - [email protected]
- Fix for bug 6211020 [cinnabar 25][linux]unlocalized message in 'lock screen'

* Thu Feb 10 2005 - [email protected]
- Fix for bug 6205166 xscreensaver caches root passwd

* Thu Feb 10 2005 - [email protected]
- Fix for bug 6222171 timebar freezes, basically added passwdTimeoutEnabled to true in XScreensaver.ad.in

* Thu Oct 07 2004 - [email protected]
- Added xscreensaver-07-g11n-alllinguas.diff to include cs locale

* Wed Jul 14 2004 - [email protected]
- packaging fixed for rpm4

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to xscreensaver-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed May 12 2004 - [email protected]
- Updated l10n content to xscreensaver-l10n-po-1.1.tar.bz2

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to xscreensaver-l10n-po-1.0.tar.bz2

* Wed Aug 20 2003  [email protected]
- Edit default screensaver to be single and flag.

* Mon Jul 28 2003  [email protected]
- Add in gtk lock dialog thing. Feel the pain.

* Thu Jul 17 2003  Ghee Teo <[email protected]>
 - Removed the version and date information from the xscreensaver-demo
   window title.

* Mon Jul 14 2003  Laca Peter <[email protected]>
 - removed/disables some hacks
 - fixed .desktop files for the capplet
 - separated the hacks into xscreensaver-hacks-*.rpm

* Thu Jul 10 2003 - [email protected]
- Added .po tarball

* Mon Jun 23 2003  Laca Peter  <[email protected]>
  - added xscreensaver.pam and the passwd helper so unlock works.
  - dirty hacks with mkinstalldirs to make it build with our version
    of automake/autoconf.