alacarte.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 8592 6a75b69e59d3
child 8765 6514dbcb311e
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package gnome-menu-editor
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: harrylu
#
%define python_version 2.4

Name:         alacarte
Version:      0.10.1
Release:      1
Summary:      Simple menu editor for GNOME

Group:        System/GUI/GNOME
License:      GPL
URL:          http://www.realistanew.com/projects/alacarte/
Distribution: java-desktop-system
Vendor:       Sun Microsystems, Inc.
Source:       http://ftp.gnome.org/pub/GNOME/sources/alacarte/0.10/alacarte-%{version}.tar.bz2
# date:2006-08-23 bugster:6460249 owner:harrylu type:feature
Patch1:       alacarte-01-force-reload.diff
#date:2006-11-15 owner:calumb bugster:6489289 bugzilla:375629 type:bug
Patch2:	      alacarte-02-launch-menu-item.diff

BuildRoot:    %{_tmppath}/%{name}-%{version}-build

BuildRequires:  pygtk2.0-devel
BuildRequires: 	desktop-file-utils
BuildRequires:  gnome-menus-devel >= 2.15.4.1
BuildRequires:  perl-XML-Parser
Requires: 	pygtk2.0, gnome-python-gconf, gnome-python
Requires: 	python-gnome-menus
Obsoletes:      smeg
Provides:       smeg %{version}-%{release}

%description
Alacarte is a menu editor for GNOME that lets you get things done,
simply and quickly.

Just click and type to edit, add, and delete any menu entry.

%prep
%setup -q
%patch1 -p0
%patch2 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

glib-gettextize -f
libtoolize --copy --force
aclocal $ACLOCAL_FLAGS
automake -a -c -f 
autoconf

./configure --prefix=%{_prefix} --mandir=%{_mandir} \
            --libdir=%{_libdir}              \
            --libexecdir=%{_libexecdir}      \
            --sysconfdir=%{_sysconfdir}
make -j $CPUS \
    pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
    pythondir=%{_libdir}/python%{python_version}/vendor-packages

%install
rm -rf $RPM_BUILD_ROOT
make DESTDIR=$RPM_BUILD_ROOT install \
    pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
    pythondir=%{_libdir}/python%{python_version}/vendor-packages
find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.pyc" -exec rm -f {} ';'

%post
%update_menus
%update_icon_cache hicolor

%postun
%clean_menus
%clean_icon_cache hicolor

%clean
rm -rf $RPM_BUILD_ROOT

%files -f %{name}.lang
%defattr (-, root, root)
%doc README AUTHORS COPYING
%{_libdir}/python?.?/vendor-packages/*
%{_bindir}/*
%{_datadir}/applications/*
%{_datadir}/%name/*
%{_datadir}/icons/*
%{_libdir}/menu/%{name}

%changelog
* Fri Nov 17 2006 - [email protected]
- Change patch2 to use p1.
* Wed Nov 15 2006 - [email protected]
  Change menu item to match latest UI spec.
* Tue Oct 03 2006 - [email protected]
- Bump to 0.10.0.
* Mon Sep 04 2006 - [email protected]
- Bump to 0.10.0.
* Thu Aug 24 2006 - [email protected]
- remove autoheader call since there is AC_CONFIG_HEADER in configure.in
* Tue Aug 22 2006 - [email protected]
- Divide SFEgnome-menu-editor.spec into alacarte.spec
  and SUNWgnome-menu-editor.spec
* Wed Aug 16 2006 - [email protected]
- bump up to 0.9.90 and add patch alacarte-01-force-reload.diff to make
  it work on solaris.
* Wed Jul  5 2006 - [email protected]
- rename to gnome-menu-editor
- delete share subpkg
* Fri Apr 21 2006 - [email protected]
- Initial spec file