gnome-doc-utils.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 8530 ef62fbe8c956
child 9124 d1400552e59a
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package gnome-doc-utils
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: laca
#
Name:			gnome-doc-utils
License:		GPL
Group:			System/Libraries
Version:		0.8.0
Release:		1
Distribution:		Java Desktop System
Vendor:			Sun Microsystems, Inc.
Summary:		Documentation utilities for GNOME
Source:			http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.8/%{name}-%{version}.tar.bz2
URL:			http://www.gnome.org
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
Docdir:			%{_defaultdocdir}/%{name}
Autoreqprov:		on

%define libxml2_version 2.6.12
%define libxslt_version 1.1.8

Requires:	libxml2 >= %{libxml2_version}
Requires:	libxslt >= %{libxslt_version}

BuildRequires:	libxml2-devel >= %{libxml2_version}
BuildRequires:	libxslt-devel >= %{libxslt_version}

%description
This package contains a selection of utilities for managing documents 
in the GNOME desktop.

The xml2po program is used to convert between PO files and XML documents.
Within gnome-doc-utils, it is used primarily to translate documentation
written in the DocBook format. 

The gnome-doc-prepare script is used to initialize your source tree for 
using the gnome-doc-utils build utilities.  It can also be used to 
create a template document and the necessary supporting files and folders.

%prep
%setup -q

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CFLAGS="$RPM_OPT_FLAGS" ./configure $MYARCH_FLAGS \
        --prefix=%{_prefix} \
        --sysconfdir=%{_sysconfdir} \
	--localstatedir=%{_localstatedir}/lib \
	--disable-scrollkeeper

make -j $CPUS

%install
make prefix=$RPM_BUILD_ROOT%{_prefix} sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} install

#man pages
mv -f $RPM_BUILD_ROOT/%{_prefix}/man $RPM_BUILD_ROOT/%{_datadir}/man

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, root)
%{_bindir}/gnome-doc-prepare
%{_bindir}/xml2po
%{_libdir}/pkgconfig/*
%{_mandir}/man1/*
%{_datadir}/aclocal/*
%{_datadir}/gnome-doc-utils/*
%{_datadir}/gnome/help/*
%{_datadir}/omf/*
%{_datadir}/xml/*
%{_datadir}/xml2po/*

%changelog
* Tue Sep 05 2006 - [email protected]
- Bump to 0.8.0.
* Tue Aug 08 2006 - [email protected]
- Bump to 0.7.2.
* Wed Jul 21 2006 - [email protected]
- Bump to 0.7.1.
* Mon Jul 10 2006 - [email protected]
- Bump to 0.6.1.
* Sun Mar 12 2006 - [email protected]
- Bump to 0.6.0.
* Mon Feb 27 2006 - [email protected]
- Bump to 0.5.7.
* Sun Feb 19 2006 - [email protected]
- Bump to 0.5.6.
* Mon Feb 13 2006 - [email protected]
- Bump to 0.5.5.
* Tue Jan 31 2006 - [email protected]
- Bump to 0.5.4.
* Thu Dec 22 2005 - [email protected]
- Bump to 0.5.2.
* Tue Nov 29 2005 - [email protected]
- Bump to 0.4.4.
* Wed Oct 26 2005 - [email protected]
- Bump to 0.4.3.
* Thu Sep 29 2005 - [email protected]
- Bump to 0.4.2.
* Thu Sep 08 2005 - [email protected]
- Bump to 0.4.1 since this contains some fixes that cause things
  to break for Solaris in 0.4.0. 
* Mon Aug 15 2005 - [email protected]
- Bump to 0.3.2.
* Thu Jun 09 2005 - [email protected]
- Update so that builds
* Wed May 18 2005 - [email protected]
- Initial spec of gnome-doc-utils