gnome-keyring-manager.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 8530 ef62fbe8c956
child 8798 6447d9f540d5
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package gnome-keyring-manager
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: dkenny
#
Name:         gnome-keyring-manager
License:      GPL
Group:        System/GUI/GNOME
Version:      2.16.0
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      GNOME Keyring Manager
Source:       http://ftp.gnome.org/pub/GNOME/sources/gnome-keyring-manager/2.16/%{name}-%{version}.tar.bz2
Patch1:       gnome-keyring-manager-01-Wall-remove.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on

%define gtk2_version 2.6.0
%define libglade_version 2.0.0
%define libgnomeui_version 2.6.0
%define gnome_keyring_version 0.3.2
%define scrollkeeper_version 0.3.12

Requires:	gtk2 >= %{gtk2_version}
Requires:	libgnomeui >= %{libgnomeui_version}
Requires:	libglade >= %{libglade_version}
Requires:       gnome-keyring >= %{gnome_keyring_version}
BuildRequires:  gtk2-devel >= %{gtk2_version}
BuildRequires:  libgnomeui-devel >= %{libgnomeui_version}
BuildRequires:  libglade-devel >= %{libglade_version}
BuildRequires:  gnome-keyring-devel >= %{gnome_keyring_version}
BuildRequires:  scrollkeeper >= %{scrollkeeper_version}

%description
Keyring manager for the GNOME desktop.

%prep
%setup -q
%patch1 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

# Don't need these steps for released tarball.
%ifos DISABLE
libtoolize --force
aclocal $ACLOCAL_FLAGS 
autoheader
automake -a -c -f
autoconf
%endif
CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
	--prefix=%{_prefix} \
	--sysconfdir=%{_sysconfdir} \
	--mandir=%{_mandir} \
	--enable-compile-warnings=no
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make -i install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
rm -rf $RPM_BUILD_ROOT/var/lib/scrollkeeper
rmdir $RPM_BUILD_ROOT/var/lib
rmdir $RPM_BUILD_ROOT/var

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="gnome-keyring-manager.schemas"
for S in $SCHEMAS; do
        gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, root)
%{_bindir}/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/applications/
%{_datadir}/gnome-keyring-manager/
%{_datadir}/gnome/help/
%{_datadir}/omf/
%{_mandir}/*
%{_sysconfdir}/gconf/schemas/

%changelog
* Tue Sep 05 2006 - [email protected]
- Bump to 2.16.0.
* Tue Aug 22 2006 - [email protected]
- Bump to 2.15.92.
* Thu Jul 27 2006 - [email protected]
- Remove scrollkeeper files form $RPM_BUILD_ROOT
* Mon Mar 13 2006 - [email protected]
- Bump to 2.14.0.
* Sat Sep 17 2005 - [email protected]
- Bump to 2.12.0
* Mon Sep 05 2005 - [email protected]
- Bump to 2.11.92.
* Thu Aug 18 2005 - [email protected]
- Initial spec for gnome-keyring-manager