gnome-pilot.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 8581 2a42a769ce54
child 8697 30665472acf2
child 18995 3ca07a20e44c
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package gnome-pilot
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: jyu_mit
#
Name:     	gnome-pilot
License:        GPL/LGPL
Group:		Applications/Communications
Version: 	2.0.13
Release:	1
Distribution:   Java Desktop System
Vendor:		Sun Microsystems, Inc.
Summary:	PalmOS link utilities
Source:		http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.0/%{name}-%{version}.tar.bz2
Source1:        gpilot-install-file.1.gz
Source2:        gpilotd-control-applet.1.gz
Patch1:         gnome-pilot-01-all-in-one.diff
Patch2:         gnome-pilot-02-pilot-link-version.diff
Patch3:         gnome-pilot-03-capplet-install.diff
Patch4:         gnome-pilot-04-remove-nouse-libs.diff
Patch5:         gnome-pilot-05-disable-gob-check.diff
Patch6:         gnome-pilot-06-winicons-multihead.diff
#date:2006-11-15 owner:calumb bugster:6489289 bugzilla:375639 type:bug
Patch7:         gnome-pilot-07-launch-menu-item.diff
URL:		http://ftp.gnome.org/pub/GNOME/sources/gnome-pilot
BuildRoot:	%{_tmppath}/%{name}-%{version}-root
Docdir:         %{_defaultdocdir}/gnome-pilot
Autoreqprov:    on
Prereq:         GConf

%define pilot_link_version 0.11.8 
%define scrollkeeper_version 0.3.14
%define gnome_panel_version 2.6.1

Requires:	gnome-panel >= %{gnome_panel_version}
Requires:       pilot-link >= %{pilot_link_version}
BuildRequires:	scrollkeeper >= %{scrollkeeper_version}
BuildRequires:	pilot-link-devel >= %{pilot_link_version}

%description
GNOME Pilot is a collection of programs and daemons for using 
Palm OS-based systems with GNOME, the complete user-friendly desktop 
based entirely on free software.

%package -n gnome-pilot-devel
Summary:	Pilot development header files.
Group:		Development/Libraries
Requires:	gnome-pilot = %{version}-%{release}
Requires:	pilot-link-devel >= %{pilot_link_version}

%description -n gnome-pilot-devel
GNOME Pilot is a collection of programs and daemons for using 
Palm OS-based systems with GNOME, the complete user-friendly desktop 
based entirely on free software.

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

LC_ALL=
LANG=
export LC_ALL LANG
libtoolize --force
aclocal $ACLOCAL_FLAGS
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS"				\
./configure  --prefix=%{_prefix}		\
	     --sysconfdir=%{_sysconfdir}	\
	     --mandir=%{_mandir}		\
	     --libexecdir=%{_libexecdir}        \
	     --localstatedir=/var		\
	     --disable-pilotlinktest

make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
rm -rf $RPM_BUILD_ROOT%{_mandir}/man1
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/man1

rm $RPM_BUILD_ROOT%{_libdir}/gnome-pilot/conduits/*.a
rm $RPM_BUILD_ROOT%{_libdir}/gnome-pilot/conduits/*.la
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="pilot.schemas"
for S in $SCHEMAS; do
	gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%files
%defattr(-, root, root)
%{_datadir}/locale/*/LC_MESSAGES/*
%{_datadir}/applications/*
%{_datadir}/idl/*
%{_datadir}/mime-info/*
%{_datadir}/pixmaps/*
%{_bindir}/*
%{_libexecdir}/*
%{_libdir}/bonobo/servers/*
%{_libdir}/gnome-pilot/conduits/*.so
%dir %{_datadir}/gnome-pilot
%dir %{_datadir}/gnome-pilot/glade
%{_datadir}/gnome-pilot/conduits
%{_datadir}/gnome-pilot/glade/*.png
%{_datadir}/gnome-pilot/glade/*.glade
%{_datadir}/gnome-pilot/*.xml
%{_datadir}/gnome/help/*
%{_datadir}/omf/*
%{_sysconfdir}/gconf/schemas/pilot.schemas
%{_libdir}/*.so.*
%{_mandir}/man1/*

%files -n gnome-pilot-devel
%defattr(-, root, root)
%{_includedir}/*
%{_libdir}/pkgconfig/*
%{_libdir}/*.so

%changelog
* Wed Nov 15 2006 - [email protected]
- Patch menu item to match latest UI spec.

* Wed Oct 24 2006 - [email protected]
- Add patch to fix #6437924, and fix up some of the window icons so they look
  a little more consistent. This is bugzilla #364589.

* Wed Jun 28 2006 - [email protected].
- Add patch gnome-pilot-04-remove-nouse-libs.diff to fix #6434263.
- Add patch gnome-pilot-05-disable-gob-check.diff to remove gob build dependency.

* Tue Jun 06 2006 - [email protected]
- Remove patch gnome-pilot-01-configure-in.diff and reorder,
  build require gob2.

* Mon Mar 20 2006 - [email protected]
- Install capplet in the right directory - #313203

* Tue Jan 10 2006 - [email protected]
- Replace patches by pdasync.prc team:
  deleted: gnome-pilot-01-menu-entry.diff
           gnome-pilot-02-g11n-i18n-ui.diff
           gnome-pilot-03-automake-fix.diff
  added  : gnome-pilot-01-configure-in.diff
           gnome-pilot-02-all-in-one.diff

* Tue Nov 29 2005 - laca.com
- remove javahelp stuff

* Tue May 17 2005 - [email protected]
- Port to 2.0.13

* Fri Feb 11 2005 - [email protected]
- Added patch to make help button in gnome-pilot settings point to 
  correct location.Fixes bug 6225082

* Mon Jan 31 2005 - [email protected]
- Increased the Release number by 200. The problem is that the release
  counter has been reset during  the JDS 3 release cycle but the version
  number has not changed. This causes an update problem because the version
  in JDS 2 appears to be newer than this version. Fixes 6222834.

* Wed Jan 26 2005 - [email protected]
- Update docs with Linux specific tarball from [email protected].

* Fri Jan 14 2005 - [email protected]
- Updated l10n help tarball for cinnabar-linux
                                                                                
* Wed Nov 17 2004 - [email protected]
- #6195855, install correct man page

* Thu Oct 28 2004 - [email protected]
- Add gpilot-install-file.1, gpilotd-control-applet.1 man pages

* Wed Aug 25 2004 - [email protected]
- Added l10n help files with patch

* Thu Aug 19 2004 - [email protected]
- Integrated updated docs tarball from [email protected].

* Mon Aug 16 2004 - [email protected] 
- Help invocation for the applet is implemented.  

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gnome-pilot-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- ported to rpm4
                                                                                
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed Jun 09 2004 - [email protected]
- Integrated docs and associated patch from [email protected]

* Wed May 12 2004 - [email protected]
- Updated l10n content to gnome-pilot-l10n-po-1.1.tar.bz2

* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris

* Thu Apr 01 2004 - [email protected]
- Javahelp conversion

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to gnome-pilot-l10n-po-1.0.tar.bz2

* Tue Mar 16 2004 - [email protected]
- add patch5 to fix build with newer versions of automake
- add --libexecdir

* Fri Mar 05 2004 - [email protected]
- Modified %files section in spec file to fix 4932068
- Changed gnome-pilot-04-trans-pilot-menu.diff to gnome-pilot-04-g11n-i18n-ui.diff

* Wed Feb 18 2004 - [email protected]
- Updated distro to Cinnabar, added l10n stuff
- Port patchs 03/04, and libtoolize it

* Fri Oct 31 2003 - [email protected]
- Remove the Sun Settings keyword from the 
  menu entry patch.

* Fri Oct 10 2003 - [email protected]
- upgrade deps versions

* Fri Oct 03 2003 - <[email protected]>
- remove man pages

* Thu Aug 14 2003 - <[email protected]>
- remove *.a, *.la

* Mon Aug 01 2003 - [email protected]
- Add some menu categorization

* Mon Jul 28 2003 - [email protected]
- Updated POTFILES.in

* Fri Jul 28 2003 - [email protected]
- Install the applet as part of the main
  package. There is no reason to have an 
  extra package for this one.

* Fri Jul 25 2003 - [email protected]
- Base package requires pilot-link

* Thu Jul 24 2003 - <[email protected]>
- Initial version