gtkhtml.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 8564 df62c23d2955
child 8644 03a152fd5cf6
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package gtkhtml
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: jefftsai
#
Name:         gtkhtml
License:      LGPL
Group:        System/Libraries/GNOME
Version:      3.12.1
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Library for HTML support in Evolution
Source:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.12/%{name}-%{version}.tar.bz2
# date:2006-11-13 bugster:6448891 bugzilla:349773 owner:xz159989 type:bug
Patch1:       gtkhtml-01-backward-finding.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/gtkhtml
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%define major_version 3.8

%define libgnomeprint_version 2.3.0
%define libgnomeprintui_version 2.3.0
%define libgnomeui_version 2.4.0.1
%define libsoup_version 2.2.0

Requires:       libgnomeui >= %{libgnomeui_version}
Requires:       libgnomeprint >= %{libgnomeprint_version}
Requires:       libgnomeprintui >= %{libgnomeprintui_version}
Requires:       libsoup >= %{libsoup_version}

BuildRequires:  libgnomeui-devel >= %{libgnomeui_version}
BuildRequires:  libgnomeprintui-devel >= %{libgnomeprintui_version}
BuildRequires:  libgnomeprint-devel >= %{libgnomeprint_version}
BuildRequires:  libsoup-devel >= %{libsoup_version}

%description
gtkhtml is a library providing HTML support for Evolution.

%package devel
Summary:      Development Library for HTML support in Evolution
Group:        Development/Libraries/GNOME
Autoreqprov:  on
Requires:     %name = %version
BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: libgnomeprintui-devel >= %{libgnomeprint_version}
BuildRequires: libgnomeprint-devel >= %{libgnomeprintui_version}
BuildRequires: libsoup-devel >= %{libsoup_version}

%description devel
This package contains the development libraries for gtkhtml, a 
library providing HTML support for Evolution.

%prep
%setup -q
%patch1 -p1

%build
libtoolize --force
intltoolize --copy --force --automake
aclocal $ACLOCAL_FLAGS
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
    --prefix=%{_prefix} \
    --libexecdir=%{_libexecdir} \
    --sysconfdir=%{_sysconfdir}

make

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make -i install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%defattr (-, root, root)
%doc AUTHORS COPYING ChangeLog NEWS README
%{_libdir}/*.so.*
%{_libdir}/bonobo/servers/*.server
%{_libdir}/gtkhtml/*.so
%{_datadir}/gtkhtml-%{major_version}/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo

%files devel
%defattr (-, root, root)
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
%{_includedir}/libgtkhtml-%{major_version}/*

%changelog
* Mon Nov 13 2006 - [email protected]
- Add a patch for bugster 6448891.
* Mon Oct 02 2006 - [email protected]
- Bump to 3.12.1.
* Mon Sep 04 2006 - [email protected]
- Bump to 3.12.0.
* Tue Aug 22 2006 - [email protected]
- Bump to 3.11.92.
* Tue Aug 08 2006 - [email protected]
- Bump to 3.11.91.
* Mon Jul 24 2006 - [email protected]
- Bump to 3.11.90.1.
* Fri Jul 20 2006 - [email protected]
- Bump to 3.11.4.
* Tue May 30 2006 - [email protected]
- Bump to 3.10.2.
* Mon Apr 10 2006 - [email protected]
- Bump to 3.10.1.
* Tue Apr 04 2006 - [email protected]
- Remove .a/.la files in linux spec. 
* Thu Mar 30 2006 - [email protected]
- Alter "remove *.a/*.la files part" to SUNWevolution-libs.spec
* Mon Mar 13 2006 - [email protected]
- Bump to 3.10.0.
* Tue Feb 28 2006 - [email protected]
- Bump to 3.9.92.
* Tue Feb 14 2006 - [email protected]
- Bump to 3.9.91.
* Fri Feb  3 2006 - [email protected]
- Bump to 3.9.90.1.
* Mon Jan 30 2006 - [email protected]
- Bump to 3.9.90.
* Thu Jan 19 2006 - [email protected]
- Bump to 3.9.5.
* Wed Jan 04 2006 - [email protected]
- Bump to 3.9.4.
* Wed Dec 21 2005 - [email protected]
- Correct Source filed.
* Tue Dec 19 2005 - [email protected]
- Bump to 3.9.3.
* Thu Dec 01 2005 - [email protected]
- Call intltoolize, needed to process intltool-*.in.
* Tue Nov 29 2005 - [email protected]
- Bump to 3.8.2.
* Mon Oct 10 2005 - [email protected]
- Bump to 3.8.1.
* Wed Sep  7 2005 - [email protected]
- Bump to 3.8.0.
* Wed Aug 31 2005 - [email protected]
- Remove Patch1 since it is already there.
* Wed Aug 31 2005 - [email protected]
- Bump 3.7.7.
* Mon Aug 15 2005 - [email protected]
- Bump 3.7.6.
* Tue Jul 12 2005 - [email protected]
- Add patch to build on Solaris (remove 'return' from void function).
  Bugzilla #309785. Remove when tarball bumped.
* Tue May 17 2005 - [email protected]
- Bump to 3.6.2
* Tue Nov 23 2004 - [email protected]
- Bump to 3.2.3
* Thu Jun 17 2004 - [email protected]
- rpm4'ified
* Tue Jun 08 2004 - [email protected]
- Bump to 3.1.16
* Fri May 21 2004 - [email protected]
- Bump to 3.1.14
* Tue Apr 20 2004 - [email protected]
- Bump to 3.1.12
* Mon Apr 19 2004 - [email protected]
- Initial spec file for gtkhtml 3.1.x