intltool.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 19073 09f5bf6611e6
child 8727 956a77624b8c
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package intltool 
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: laca
#
Name:			intltool 
License:		GPL
Group:			Development/Tools/Other 
BuildArchitectures:	noarch
Version:		0.35.0
Release:		1
Distribution:		Java Desktop System
Vendor:			Sun Microsystems, Inc.
Summary:		Translation Tools for GNOME Internationalization
Source:			http://ftp.gnome.org/pub/GNOME/sources/intltool/0.35/intltool-%{version}.tar.bz2
# date:2006-05-02 owner:laca type:bug bugzilla:341985
Patch1:                 intltool-01-intltoolize-exit-1.diff
# date:2006-07-13 owner:laca type:bug
# FIXME: is this still needed?
Patch2:                 intltool-02-ALL_LINGUAS.diff
Source1:                intltool-extract.1.gz
Source2:                intltool-merge.1.gz
Source3:                intltool-prepare.1.gz
Source4:                intltool-unicodify.1.gz
Source5:                intltool-update.1.gz
Source6:                intltoolize.1.gz
URL:			http://www.gnome.org
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
Docdir: 		%{_defaultdocdir}/doc
Autoreqprov:		on

%description
intltool is a collection of tools for the GNOME Internationalization Developer
Framework. Data available in XML files (.oaf, .desktop, .sheet, etc.) can be 
extracted into PO files and, after translating, the new info will be written back
into the XML files.

%define INSTALL install -m755 -s
%define INSTALL_SCRIPT install -m755
%define INSTALL_DIR install -d -m755
%define INSTALL_DATA install -m644

%prep
%setup -q
%patch1 -p1
%patch2 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

./configure --prefix=%{_prefix} 	\
	    --mandir=%{_mandir}
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE4 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE5 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE6 $RPM_BUILD_ROOT%{_mandir}/man1

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-, root, root)
%defattr(0555, root, root)
%{_prefix}/bin
%defattr (0444, root, root)
%{_mandir}/man1/*
%{_mandir}/man8/*
%defattr(0755,root,root) 
%{_datadir}/%{name}
%{_datadir}/aclocal/

%changelog
* Thu Jul 13 2006 - [email protected]
- add patch ALL_LINGUAS.diff that removes the \n's from ALL_LINGUAS in
  IT_PROG_INTLTOOL
* Wed Jul 12 2006 - [email protected]
- bump to 0.35.0
* Wed Feb  8 2006 - [email protected]
- Bump to 0.34.2.
* Mon Aug 15 2005 - [email protected]
- Bump to 0.34.1.
* Fri May 06 2005 - [email protected]
- Bump to 0.33
* Fri Nov 05 2004 - [email protected]
- Added intltool-01-g11n-icon.diff to support .icon files. Fix CR 6191220
- Added intltool-02-g11n-space.diff to fix space attributes. bugzilla 151017.
* Thu Oct 21 2004 - [email protected]
- Updated "Source" to current version.
* Thu Oct 21 2004 - [email protected]
- Bump to 0.31, remove patch-01 , #6179699
* Wed Jul 07 2004 - [email protected]
- Ported to rpm4
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds
* Tue Mar 16 2004 - [email protected]
- Added intltool-01-g11n-handle-blacket.diff to fix 4996253
* Thu Feb 05 2004 - Matt Keenan <[email protected]>
- Bump to 0.30
* Mon Dec 15 2003 - Glynn Foster <[email protected]>
- Bump to 0.28
* Mon Oct 13 2003 - Matt Keenan  <[email protected]>
- Man pages update
* Thu Oct 09 2003 - Matt Keenan  <[email protected]>
- Man pages
* Fri Jul 04 2003 - Ghee Teo  <[email protected]>
- Fixes a directory permission for %{_datadir}/aclocal because of
  an incorrect macros being used under files section
* Tue May 13 2003 - [email protected]
- Initial release