nimbus.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 8564 df62c23d2955
child 8967 d091b85464bd
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package nimbus
#
# Copyright (c) 2006 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: erwannc
#
Name:         nimbus
Summary:      Engine for GTK2 Nimbus Theme
Version:      0.0.4
%define tarball_version %{version}
Release:      1
License:      LGPL
Distribution: Java Desktop System
Vendor:	      Sun Microsystems, Inc.
Group:        System/GUI/GNOME
Source:       %{name}-%{tarball_version}.tar.bz2
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
URL:          http://www.sun.com/software/javadesktopsystem/
Patch1:	      nimbus-01-icon-name-mapping-hack.diff

%define gtk2_version 2.4.0
%define intltool_version 0.30
BuildRequires: gtk2 >= %{gtk2_version}
BuildRequires: intltool >= %{intltool_version}

%description
This package contains the Nimbus theme engine for GTK2

%prep
%setup -q -n %name-%tarball_version
%patch1 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS -I .
automake -a -c -f
autoconf
CFLAGS="$RPM_OPT_FLAGS"
./autogen.sh --prefix=%{_prefix}  \
	     --libdir=%{_prefix}/%_lib \
	     --sysconfdir=%{_sysconfdir} 
make -j $CPUS
cd -

%install
make DESTDIR=$RPM_BUILD_ROOT install
rm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/engines/*.a
rm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/engines/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-, root, root)
%{_libdir}/gtk-2.0/*/engines/*.so
%{_datadir}/themes/*
%{_datadir}/icons/*
%{_datadir}/locale/*
%{_datadir}/pixmaps/*

%changelog
* Fri Jul 21 2006 - [email protected]
- Add patch to comment out the redefine of an enum.

* Mon May 12 2006 Erwann Chenede - <[email protected]>
- initial implementation of the spec file