orca.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 19079 4ca5c7d71b85
child 8682 ccc7ded6e039
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package orca
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: dcarbery
#
Name:           orca
License:        LGPL
Group:          System/Library
Version:        2.17.2
Release:        1
Distribution:   Java Desktop System
Vendor:	        Sun Microsystems, Inc.
Summary:        Orca Screen Reader/Magnifier
Source:         http://ftp.gnome.org/pub/GNOME/sources/orca/2.17/orca-%{version}.tar.bz2
URL:            http://www.gnome.org
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Docdir:         %{_defaultdocdir}/doc
Autoreqprov:    on

%define python_version 2.4
%define pyorbit_version 2.0.1
%define pygtk2_version 2.6.2
%define gnome_python_version 2.6.2
%define brltty_version 3.6.1

Requires: pygtk2 >= %{pygtk2_version}
Requires: pyorbit >= %{pyorbit_version}
Requires: gnome-python >= %{gnome_python_version}
Requires: brltty >= %{brltty_version}

BuildRequires: pygtk2-devel >= %{pygtk2_version}
BuildRequires: pyorbit-devel >= %{pyorbit_version}
BuildRequires: gnome-python-devel >= %{gnome_python_version}

%description
Orca a scriptable screen reader/magnifier that is under development.
As such it is highly unstable and undergoes frequent changes.
To read more about Orca, please refer to the "Programmer's Guide" in
the docs/programmers-guide directory.

%prep
%setup -q -n orca-%{version}

%build
libtoolize --force
glib-gettextize --copy --force
aclocal $ACLOCAL_FLAGS -I .
autoconf
autoheader
automake -a -c -f
CFLAGS="$RPM_OPT_FLAGS"                         \
./configure     --prefix=%{_prefix}             \
                --libdir=%{_libdir}             \
                --bindir=%{_bindir}             \
                --datadir=%{_datadir}           \
                --sysconfdir=%{_sysconfdir}

# FIXME: hack: stop the build from looping
touch po/stamp-it

make \
    pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
    pythondir=%{_libdir}/python%{python_version}/vendor-packages

%install
rm -rf $RPM_BUILD_ROOT
make DESTDIR=$RPM_BUILD_ROOT install \
    pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
    pythondir=%{_libdir}/python%{python_version}/vendor-packages
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm -f {} ';'

%clean
rm -rf $RPM_BUILD_ROOT

%post

%postun

%files
%defattr(-, root, root)
%{_libdir}/python?.?/vendor-packages/orca
%{_bindir}/orca
%{_bindir}/orca-setup
%{_datadir}/locale

%doc AUTHORS NEWS README ChangeLog

%changelog
* Thu Nov 23 2006 - [email protected]
- Bump to 2.17.2.
* Mon Sep 04 2006 - [email protected]
- Bump to 1.0.0.
* Tue Aug 21 2006 - [email protected]
- Bump to 0.9.0.
* Tue Aug 08 2006 - [email protected]
- Bump to 0.2.8.
* Mon Jul 24 2006 - [email protected]
- Bump to 0.2.7.
* Wed Jul 12 2006 - [email protected]
- Update to 0.2.6
* Wed Jun 14 2006 - [email protected]
- Update to 0.2.5
* Tue May 02 2006 - [email protected]
- Remove unneeded intltoolize call.
* Sat Mar 18 2006 - [email protected]
- Bump to 0.2.2.
* Thu Feb 23 2006 - [email protected]
- Use bzip source tarball. It's smaller.
* Thu Feb 23 2006 - [email protected]
- Update to orca-0.2.1
* Tue Feb 14 2006 - [email protected]
- Add hack to fix infinite loop problem in po/Makefile.
* Wed Nov 30 2005 - [email protected]
- Update to orca-0.2.0
* Thu Oct 27 2005 - [email protected]
- move from site-packages to vendor-packages
* Thu Sep 15 2005 - [email protected]
- autotoolize
- add patch bindir.diff
* Mon Aug 15 2005 - [email protected]
- Initial Sun release