totem.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 19079 4ca5c7d71b85
child 8709 b1d6def4fe33
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package totem
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: yippi
#
Name:         totem
License:      GPL
Group:        System/GUI/GNOME
Version:      2.17.3
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Totem Multimedia Player
Source:       http://ftp.gnome.org/pub/GNOME/sources/totem/2.17/%{name}-%{version}.tar.bz2
Patch1:       totem-01-use-jmplay-for-wav-mp3.diff
Patch2:       totem-02-menu-entry.diff
Patch3:       totem-03-uninstalled-pc.diff
Patch4:       totem-04-fixcd.diff
Patch5:       totem-05-moz-plugin.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on

%define	libgnomeui_version			2.6.0
%define	gstreamer_version               	0.8.1
%define gstreamer_plugins_version       	0.8.1
%define gnome_desktop_version                   2.6.1

Requires:       libgnomeui >= %{libgnomeui_version}
Requires:       gstreamer >= %{gstreamer_version}
Requires:       gstreamer-plugins >= %{gstreamer_plugins_version}
Requires:       gnome-desktop >= %{gnome_desktop_version}
Requires:       iso-codes
BuildRequires:  libgnomeui-devel >= %{libgnomeui_version}
BuildRequires:  gstreamer-devel >= %{gstreamer_version}
BuildRequires:  gstreamer-plugins-devel >= %{gstreamer_plugins_version}
BuildRequires:  gnome-desktop-devel >= %{gnome_desktop_version}

%description
Totem is multimeida player for the GNOME desktop, allowing you to play CDs, DVDS and a 
wide range of multimedia formats

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

if test "x$x_includes" = "x"; then
 x_includes="/usr/X11/include"
fi

if test "x$x_libraries" = "x"; then
 x_libraries="/usr/X11/lib"
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS
autoheader
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS"	\
./configure \
	--prefix=%{_prefix} \
	--sysconfdir=%{_sysconfdir} \
        --libdir=%{_libdir}         \
        --bindir=%{_bindir}         \
	--libexecdir=%{_libexecdir} \
	--mandir=%{_mandir}         \
	--localstatedir=/var/lib    \
	--enable-gstreamer	    \
	--disable-lirc              \
        --x-includes="$x_includes"  \
        --x-libraries="$x_libraries" 
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make -i install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
rm $RPM_BUILD_ROOT%{_datadir}/totem/vanity.glade
rm $RPM_BUILD_ROOT%{_datadir}/totem/vanity.png
rm $RPM_BUILD_ROOT%{_datadir}/pixmaps/vanity.png

# 6227253: Change xml file in totem-C.omf from totem.xml to sample_apps_info.xml
# (part of gnome-user-docs).
sed 's/totem.C.totem.xml/sample_apps_info\/C\/sample_apps_info.xml/' $RPM_BUILD_ROOT%{_datadir}/omf/totem/totem-C.omf >/tmp/totem-C.omf
rm $RPM_BUILD_ROOT%{_datadir}/omf/totem/totem-C.omf
mv /tmp/totem-C.omf $RPM_BUILD_ROOT%{_datadir}/omf/totem/totem-C.omf

# Remove empty directory
rmdir $RPM_BUILD_ROOT%{_datadir}/pixmaps


%clean
rm -rf $RPM_BUILD_ROOT

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="totem.schemas totem-video-thumbnail.schemas"
for S in $SCHEMAS; do
        gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%files
%defattr (-, root, root)
%{_bindir}/*
%{_sysconfdir}/gconf/schemas
%{_libdir}/*
%{_libexecdir}/*
%{_datadir}/applications
%{_datadir}/gnome/help/totem/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/omf/totem/*
%{_datadir}/pixmaps/*
%{_datadir}/totem/*
%{_mandir}/man1/totem*
%{_includedir}/totem/*

%changelog
* Thu Nov 23 2006 - [email protected]
- Bump to 2.17.3.

* Tue Oct 03 2006 - [email protected]
- Remove 'rm' lines from %install as the files listed are not installed.

* Mon Oct 02 2006 - [email protected]
- Bump to 2.16.2.
- Remove '-f' from 'rm' calls to force failure when source changes need
  attention.

* Fri Sep 08 2006 - [email protected]
- Bump to 2.16.1.

* Mon Sep 04 2006 - [email protected]
- Bump to 2.16.0.

* Tue Aug 22 2006 - [email protected]
- Bump to 1.5.92.
- Remove upstream patch, 05-automake-conditional, renumber rest.

* Thu Aug 17 2006 - [email protected]
- Add patch, 06-moz-plugin, to get mozilla plugin to build.

* Wed Aug 16 2006 - [email protected]
- Add patch, 05-automake-conditional, to fix an automake issue. #351617.

* Mon Aug 14 2006 - [email protected]
- Bump to 1.5.91.

* Fri Jul 28 2006 - [email protected]
- Bump to 1.5.90.

* Thu Jul 13 2006 - [email protected]
- Patch to fix totem so it passes the CD device name to GStreamer on Solaris.

* Wed Jun 21 2006 - [email protected]
- Bump to 1.5.2.

* Mon May 01 2006 - [email protected]
- Added uninstalled.pc file to totem so that rhythmbox can be built in same
  package, since rhythmbox depends on totem.

* Fri Apr 28 2006 - [email protected]
- Add patch to call it 'Totem Movie Player' from
  now on.

* Mon Mar 13 2006 - [email protected]
- Bump to 1.4.0.

* Wed Mar  1 2006 - [email protected]
- Bump to 1.3.92.

* Mon Feb 13 2006 - [email protected]
- Bump to 1.3.91.

* Sun Jan 29 2006 - [email protected]
- Bump to 1.3.90

* Mon Jan 23 2006 - [email protected]
- Remove obsolete patch, 03-fixfunc.

* Fri Jan 20 2006 - [email protected]
- Bump to 1.3.1.

* Tue Jan 03 2006 - [email protected]
- Remove obsolete patch, 01-desktop.sh; renumber remainder.
- Remove obsolete patch, 02-menu-entry.

* Tue Dec 20 2005 - [email protected]
- Bump to 1.3.0

* Tue Nov 29 2005 - laca.com
- remove javahelp stuff

* Tue Sep 27 2005 - [email protected]
- Bump to 1.2.0.
- Fix patch4 so it compiles against latest code.

* Tue Sep 27 2005 - [email protected]
- Bump to 1.1.5.

* Mon Sep 12 2005 - [email protected]
- add patch desktop.sh.diff: changes echo -n to printf as echo -n doesn't
  work on Solaris

* Tue Aug 16 2005 - [email protected]
- Bump to 1.1.4.

* Tue Jul 12 2005 - [email protected]
- Add patch 5 to build CD-ROM code (src/totem-disc.c) on Solaris.
  http://bugzilla.gnome.org/show_bug.cgi?id=310149

* Thu Jun 16 2005 - [email protected]
- Bump to 1.0.3

* Thu Jun 09 2005 - [email protected]
- Bump to 1.0.1
- Remove patchs 02, 03, 04
- Rename patch 05 to 03

* Thu May 05 2005 - [email protected]
- 6227253: Change xml file in totem-C.omf from totem.xml to
  sample_apps_info.xml (part of gnome-user-docs). Bit of a hack but a very easy
  one to maintain.

* Fri Feb 25 2005 - [email protected]
- Added dummy l10n help files to follow base update

* Mon Feb 14 2005 - [email protected]
- Integrate docs tarball (totem-docs-0.1) from [email protected].

* Thu Feb 10 2005 - [email protected]
- 6227304 : install german help correctly

* Wed Jan 19 2005 - [email protected]
- Add Javahelp convert #6197736

* Sun Nov 14 2004 - [email protected]
- add --bindir=%{_bindir} and --libdir=%{_libdir} to configure opts

* Fri Oct 29 2004 - [email protected]
- Add missing deps

* Fri Oct 01 2004 - [email protected]
- Added '--x-libraries' option in configure to fix bug 5081938

* Sat Sep 11 2004 - [email protected]
- Move Solaris specific LDFLAGS to the Solaris spec file

* Fri Sep 10 2004 - [email protected]
- Set LDFLAGS so Xrandr and Xrender can be found.

* Fri Sep 03 2004 - [email protected]
- Added patch 05 to let jmplay handle wav and mp3 files.
  Fixes bugtraq #5093284.

* Mon Jul 19 2004 - [email protected]
- Added patch 04 so that icons get displayed on Solaris.
  Patch approved by totem maintainer.

* Fri Jul 16 2004 - [email protected]
- Added patch 03 to support building on Solaris.

* Wed Jul 14 2004 - [email protected]
- packaging fixes for rpm4

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to totem-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed May 12 2004 - [email protected]
- Updated l10n content to totem-l10n-po-1.1.tar.bz2

* Mon Apr 26 2004 - [email protected]
- Bump to 0.99.11

* Thu Apr 15 2004 - [email protected]
- Bump to 0.99.10, and remove Ghee's temporary workaround 
  patch.

* Tue Apr 06 2004 - [email protected]
- Created a totem-03-temporary-workaround-build.diff to resolve the
  hardcoded  GST_MAJORMINOR=0.7 problem. This patch should be removed
  once a new release totem is available.

* Wed Mar 31 2004 - [email protected]
- replace tar jxf with the more solaris friendly
  bzcat piped through tar

* Mon Mar 29 2004 - [email protected]
- Adding totem-l10n-po-1.0.tar.bz2 l10n content

* Fri Feb 13 2004 - [email protected]
- Bump tarball to 0.99.9, redo patch 01

* Mon Jan 12 2004 - [email protected]
- Bump tarball to 0.99.8, patch for compile errors

* Fri Nov 14 2003 - [email protected]
- Re add the desktop patch to change the menu entry.

* Fri Oct 31 2003 - [email protected]
- Remove the Sun Supported keyword from the 
  desktop file, since we're no longer going with the Extras
  menu.

* Wed Oct 22 2003 - [email protected]
- Update to 0.99.7

* Fri Oct 13 2003 - [email protected]
- Update to 0.99.6

* Thu Aug 14 2003 - [email protected]
- Removed totem totem.applications and totem.keys so that jmplay can 
  become the default media player.

* Sat Aug 02 2003 - [email protected]
- Update menu entry.

* Fri Jul 25 2003 - [email protected]
- Initial Sun release