SUNWgst-python.spec
author daniell
Wed, 13 Oct 2010 16:43:58 +0000
branchopensolaris-2009-06
changeset 20159 f18a6979f732
parent 14202 fc80c50f84e9
permissions -rw-r--r--
6965295 [CVE-2010-1205/CVE-2010-2249] Multiple security issues in libpng 1.2 versions before 1.2.44

#
# spec file for package SUNWgst-python
#
# Copyright 2009 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: dkenny
#
%include Solaris.inc

Name:                    SUNWgst-python
Summary:                 Python bindings for the GStreamer streaming media framework
URL:                     http://gstreamer.freedesktop.org/src/gst-python/
Version:                 0.10.13
Source:                  http://gstreamer.freedesktop.org/src/gst-python/gst-python-%{version}.tar.bz2
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build
Requires:                SUNWPython
Requires:                SUNWgnome-python-libs
Requires:                SUNWgnome-media
BuildRequires:           SUNWgnome-python-libs-devel
BuildRequires:           SUNWgnome-media-devel
BuildRequires:           SUNWpython-setuptools

%include default-depend.inc

%define pythonver 2.4

%prep
%setup -q -n gst-python-%version

%build
export PYTHON=/usr/bin/python%{pythonver}
export PKG_CONFIG_PATH=/usr/lib/python%{pythonver}/pkgconfig
./configure --prefix=%{_prefix}
make

%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT

# move to vendor-packages
mkdir -p $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
mv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages/* \
   $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages/
rmdir $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages

rm $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages/*.la

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/python%{pythonver}/vendor-packages/gst-0.10/*
%{_libdir}/python%{pythonver}/vendor-packages/pygst.pth
%{_libdir}/python%{pythonver}/vendor-packages/pygst.py
%{_libdir}/python%{pythonver}/vendor-packages/*.so
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/gst-python
%doc AUTHORS README
%doc(bzip2) COPYING ChangeLog NEWS
%dir %attr (0755, root, other) %{_datadir}/doc

%changelog
* Tue Feb 17 2009 - [email protected]
- set PYTHON and PKG_CONFIG_PATH so the correct python version and
  dependencies are picked up
* Thu Dec 11 2008 - [email protected]
- Bump to 0.10.13.
* Fri Sep 12 2008 - [email protected]
- Update copyright
* Wed Jul 16 2008 - [email protected]
- Update %files for newly delivered library.
* Thu Jun 19 2008 - [email protected]
- Bump to 0.10.12.
* Thu Mar 20 2008 - [email protected]
- Bump to 0.10.11.
* Tue Mar 18 2008 - [email protected]
- Add Build/Requires for SUNWgnome-python-libs and SUNWgnome-media.
* Tue Feb 12 2008 - [email protected]
- initial version