specs/scim-input-pad.spec
changeset 706 ca594d31f781
parent 705 c5b0af57a88c
child 707 dfbe6c035259
equal deleted inserted replaced
705:c5b0af57a88c 706:ca594d31f781
     1 %include Solaris.inc
       
     2 
       
     3 %define src_name scim-input-pad
       
     4 %define src_url http://jaist.dl.sourceforge.net/sourceforge/scim
       
     5 
       
     6 Summary:	Smart Common Input Method Framework - Input Pad
       
     7 SUNW_BaseDir:   %{_basedir}
       
     8 Name:		SUNWscim-input-pad
       
     9 Version: 	0.1.1
       
    10 Release:	1
       
    11 License: 	GPL
       
    12 Source: 	%{src_name}-%{version}.tar.gz
       
    13 Patch1:		scim-input-pad-%{version}-on-nv-ss11-patch.diff
       
    14 BuildRoot:      %{_tmppath}/%{src_name}-%{version}-build
       
    15 
       
    16 %include default-depend.inc
       
    17 Requires: SUNWgnome-base-libs
       
    18 Requires: SUNWscim
       
    19 BuildRequires: SUNWgnome-base-libs-devel
       
    20 BuildRequires: SUNWscim-devel
       
    21 
       
    22 %prep
       
    23 %setup -q -n %{src_name}-%{version}
       
    24 %patch1 -p0
       
    25 
       
    26 %build
       
    27 export CXX="${CXX} -norunpath"
       
    28 export CFLAGS="%optflags -DMSG_NOSIGNAL=0"
       
    29 export CXXFLAGS="%cxx_optflags -DMSG_NOSIGNAL=0"
       
    30 ./bootstrap
       
    31 ./configure --prefix=%{_prefix}                 \
       
    32             --sysconfdir=%{_sysconfdir}         \
       
    33             --disable-debug
       
    34 make
       
    35 
       
    36 %install
       
    37 rm -rf ${RPM_BUILD_ROOT}
       
    38 DESTDIR=${RPM_BUILD_ROOT} make install
       
    39 find ${RPM_BUILD_ROOT} -name "*.a" -exec rm  {} \; -print
       
    40 find ${RPM_BUILD_ROOT} -name "*.la" -exec rm {} \; -print
       
    41 
       
    42 %{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
       
    43 
       
    44 %post
       
    45 gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/gtk.immodules
       
    46 
       
    47 %clean
       
    48 rm -rf ${RPM_BUILD_ROOT}
       
    49 
       
    50 %files 
       
    51 %defattr(-, root, bin)
       
    52 %{_bindir}/*
       
    53 %{_libdir}/*
       
    54 %dir %attr (0755, root, sys) %{_datadir}
       
    55 %attr (0755, root, other) %{_datadir}/locale
       
    56 %{_datadir}/scim/*
       
    57