dbus.spec
author dermotm
Mon, 24 Jul 2006 12:30:39 +0000
branchgnome-2-10
changeset 19949 94f49bf19351
parent 19693 ecfa915b40d9
permissions -rw-r--r--
access control test #4

#
# spec file for package dbus
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         dbus
License:      Other
Group:        System/Libraries
Version:      0.23.4
Release:      2
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Simple IPC library based on messages
Source:       http://dbus.freedesktop.org/releases/%{name}-%{version}.tar.gz
URL:          http://www.freedesktop.org/wiki/Software/dbus
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:	      %{_defaultdocdir}/doc
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%define glib2_version 2.6.4
%define libxml2_version 2.6.19
BuildRequires: glib2-devel >= %glib2_version
BuildRequires: libxml2-devel >= %libxml2_version
Requires: glib2 >= %glib2_version
Requires: libxml2 >= %libxml2_version

%description
D-BUS is a message bus system, a simple way for applications to talk to one another.

D-BUS supplies both a system daemon (for events such as "new hardware device added" 
or "printer queue changed") and a per-user-login-session daemon (for general IPC 
needs among user applications). Also, the message bus is built on top of a general 
one-to-one message passing framework, which can be used by any two apps to communicate 
directly (without going through the message bus daemon). 

%package devel
Summary:      Simple IPC library based on messages
Group:        Development/Libraries
Requires:     %{name} = %{version}

%description devel
D-BUS is a message bus system, a simple way for applications to talk to one another.

D-BUS supplies both a system daemon (for events such as "new hardware device added" 
or "printer queue changed") and a per-user-login-session daemon (for general IPC 
needs among user applications). Also, the message bus is built on top of a general 
one-to-one message passing framework, which can be used by any two apps to communicate 
directly (without going through the message bus daemon). 

%prep
%setup -q

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi
CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}		\
            --sysconfdir=%{_sysconfdir} \
            --libexecdir=%{_libexecdir} \
	    --mandir=%{_mandir}
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
rm $RPM_BUILD_ROOT%{_libdir}/libdbus-1*.a
rm $RPM_BUILD_ROOT%{_libdir}/libdbus-1*.la
rm $RPM_BUILD_ROOT%{_libdir}/libdbus-glib-1*.a
rm $RPM_BUILD_ROOT%{_libdir}/libdbus-glib-1*.la

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%clean 
rm -rf $RPM_BUILD_ROOT

%files 
%defattr(-, root, root)
%config %{_sysconfdir}/dbus-1/session.conf
%config %{_sysconfdir}/dbus-1/system.conf
%{_bindir}/*
%{_libdir}/libdbus-1.so.*
%{_libdir}/libdbus-glib-1.so.*
%{_datadir}/man/*

%files devel
%defattr(-, root, root)
%{_libdir}/*.so
%{_includedir}/dbus-1.0/*
%{_libdir}/dbus-1.0/*
%{_libdir}/pkgconfig/*

%changelog
* Mon Jun 20 2005 - [email protected]
- dbus 0.23 is actually shipped with gnome 2.10 so bumping down tarball

* Thu Jun 09 2005 - [email protected]
- add buildrequires glib2, libxml2
* Thu May 12 2005 - [email protected]
- Initial spec file for dbus.