eog.spec
author dermotm
Mon, 24 Jul 2006 12:30:39 +0000
branchgnome-2-10
changeset 19949 94f49bf19351
parent 19838 42a3a4365a3b
permissions -rw-r--r--
access control test #4

#
# spec file for package eog
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         eog
License:      GPL
Group:        System/GUI/GNOME
Version:      2.10.0
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Eye Of GNOME Image Viewer
Source:       http://ftp.gnome.org/pub/GNOME/sources/eog/2.10/eog-%{version}.tar.bz2
Source1:      eog.1.gz
Patch1:       eog-01-full-screen-show.diff
Patch2:       eog-02-jpeg.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/doc
Autoreqprov:  on

%define libgnomeui_version 2.5.90
%define libgnomeprintui_version 2.6.0
%define scrollkeeper_version 0.3.12
%define eel_version 2.5.90

Requires:	libgnomeui >= %{libgnomeui_version}
Requires:	libgnomeprintui >= %{libgnomeprintui_version}
Requires:       eel > %{eel_version}
Prereq:         GConf
BuildRequires:	libgnomeui-devel >= %{libgnomeui_version}
BuildRequires:	libgnomeprintui-devel >= %{libgnomeprintui_version}
BuildRequires:	eel-devel >= %{eel_version}
BuildRequires:	scrollkeeper >= %{scrollkeeper_version}
BuildRequires:	intltool

%description
The "Eye of GNOME" is a very fast picture viewer, which can either be used as a 
plugin for Nautilus, or as a standalone application. This version of EOG is 
compiled for the GNOME 2.0 Desktop platform.

%prep
%setup -q
%patch1 -p1
%patch2 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

gnome-doc-common
libtoolize --force
aclocal $ACLOCAL_FLAGS
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}		\
	    --sysconfdir=%{_sysconfdir} \
	    --libexecdir=%{_libexecdir}
make -j $CPUS

%install
rm -rf $RPM_BUILD_ROOT
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make DESTDIR=$RPM_BUILD_ROOT install
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL  
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man1
#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/

%clean
rm -rf $RPM_BUILD_ROOT

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="eog.schemas"
for S in $SCHEMAS; do
        gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%files
%defattr (-, root, root)
%{_bindir}/*
%{_sysconfdir}/gconf/schemas/eog.schemas
%{_datadir}/applications/eog.desktop
%{_datadir}/eog/*
%{_datadir}/gnome/help/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/omf/eog/*
%{_datadir}/pixmaps/*
%{_datadir}/man/man1/*

%changelog
* Thu Aug 04 2005 - [email protected]
- removed patch image-save-as.diff, fix now in gnome-vfs

* Thu Jun 23 2005 - [email protected]
- Fix files getting deleted when doing a save as. Fixes #6288517

* Thu May 19 2005 - [email protected]
- Bump to 2.10.0

* Fri May 05 2005 - [email protected]
- updating l10n po tarball to 1.15. Fixing CR 6265841

* Mon Mar 21 2005 - [email protected]
- Added eog-06-full-screen-show.diff to see that gtk_grab_add is
  done only when no other widget holds the grab.
  Fixes bug #6238888.

* Mon Mar 07 2005 - [email protected]
* 6233036: Add Source6 to specify Linux version of docs tarball.

* Thu Mar 03 2005 - [email protected]
- Added eog-05-multihead-functionality.diff to 
  make eog functional on a multihead system.
  Fixes bug #4893502.

* Tue Feb 22 2005 - [email protected]
* Correct name of docs tarball.

* Mon Feb 21 2005 - [email protected]
- Correct commit of Jan 25 to update docs tarball to 0.4.

* Tue Feb 08 2005 - [email protected]
- Updated eog-02-print-preview.diff to see that the print-preview window 
  does not diminish in size when invoked multiple times. Fixes bug #6221186.

* Tue Jan 25 2005 - [email protected]
- Update docs with Linux specific tarball from [email protected].

* Fri Jan 14 2005 - [email protected]
- Updated l10n help tarball for cinnabar-linux

* Wed Dec 22 2004 - [email protected]
- Added eog-04-g11n-i18n-ui.diff to localize eog printer dialog. Fix bug 6174164

* Wed Aug 25 2004 - [email protected]
- Added l10n help contents with patch

* Mon Aug 16 2004 - [email protected]
- Updated /usr/share/gnome/help/eog/*/*.xml to 0644 for Solaris integration 

* Thu Aug 05 2004 - [email protected]
- Incorporate new docs tarball from [email protected].

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to eog-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Thu Jun 10 2004 - [email protected]
- Added patch for print preview.

* Fri May 28 2004 - [email protected]
- Incorporate new docs tarball from [email protected].

* Thu May 13 2004 - [email protected]
- Added patch eog-01-image-collection-viewer.diff to provide viewer_label
  for Image Collection Viewer. Fixes bugtraq bug#5043908. Also the changes 
  have been committed to community CVS HEAD on May 12 2004 
  (bugzilla bug#142347)

* Wed May 12 2004 - [email protected]
- Updated l10n content to eog-l10n-po-1.1.tar.bz2

* Fri May 07 2004 - [email protected]
- Bump to 2.6.1

* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris

* Fri Apr 09 2004 - [email protected]
- Change the way the build directory is cleaned so that eog and
  gthumb can be built into the same Solaris package.

* Tue Apr 06 2004 - [email protected]
- Bump to 2.6.0

* Thu Apr 01 2004 - [email protected]
- Javahelp conversion

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to eog-l10n-po-1.0.tar.bz2

* Mon Mar 01 2004 - <[email protected]>
- add $ACLOCAL_FLAGS to aclocal args

* Fri Feb 06 2004 - <[email protected]>
- Bump tarball to 2.5.4 because of intltool (OrigTree) Failures
- Remove patch1 and patch2 no longer needed
- bump l10n release

* Thu Jan 29 2004 - <[email protected]>
- add patch 02 for intltool-merge and dep. on intltool

* Wed Dec 17 2003 - <[email protected]>
- Bump to 2.5.1

* Fri Oct 31 2003 - <[email protected]>
- Remove potfiles patch [not needed] and Sun Support 
  keyword patch, since we're no longer using the Extras
  menu.

- Update to 2.4.0
* Fri Oct 10 2003 - <[email protected]>
- Update to 2.4.0

* Fri Sep 26 2003 - <[email protected]>
- Integrate Sun docs

* Fri Aug 07 2003 - <[email protected]>
- Add mnemonics to some menu items.

* Fri Aug 01 2003 - <[email protected]>
- Add recent files support

* Wed Jul 30 2003 - <[email protected]>
- New tarball

* Mon Jul 28 2003 - <[email protected]>
- Change menu entry.

* Wed Jul 09 2003 - <[email protected]>
- add in sun po files

* Wed Jul 02 2003 - [email protected]
- Fix up the install of the glade file to stop things
  crashing

* Wed May 14 2003 - [email protected]
- initial release