ggv.spec
author dermotm
Mon, 24 Jul 2006 12:30:39 +0000
branchgnome-2-10
changeset 19949 94f49bf19351
parent 19838 42a3a4365a3b
permissions -rw-r--r--
access control test #4

#
# spec file for package ggv
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         ggv
License:      GPL
Group:        System/GUI/GNOME
Version:      2.8.4
Release:      1
Distribution: Java Desktop System
Vendor:	      Sun Microsystems, Inc.
Summary:      GNOME Ghostview
Source:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.8/%{name}-%{version}.tar.bz2
Source1:      ggv.1.gz
Patch1:       ggv-01-menu-entry.diff
Patch2:       ggv-02-solaris-print-path-issue.diff
Patch3:       ggv-03-orientation.diff
Patch4:	      ggv-04-convert-uri-to-display-name.diff
Patch5:       ggv-05-zoom-factor.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on
Prereq:       GConf

%define libgnomeui_version 2.2.0
%define scrollkeeper_version 0.3.11

BuildRequires: scrollkeeper >= %{scrollkeeper_version}
BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: intltool
Requires:      libgnomeui >= %{libgnomeui_version}

%description
Tool to view PostScript and PDF documents.

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS
automake -a -c -f
autoconf

%ifos solaris
%define xlibdir /usr/openwin/lib
%else
%define xlibdir /usr/X11R6/lib
%endif

CFLAGS="$RPM_OPT_FLAGS" \
LIBS=-L%{xlibdir} ./configure \
    --prefix=%{_prefix} \
    --libexecdir=%{_libexecdir}/ggv \
    --localstatedir=%{_localstatedir} \
    --sysconfdir=%{_sysconfdir}
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man1

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="ggv.schemas"
for S in $SCHEMAS; do
	gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root)
%doc AUTHORS COPYING ChangeLog NEWS README
%{_sysconfdir}/gconf/schemas/ggv.schemas
%{_datadir}/omf/ggv/*.omf
%{_datadir}/pixmaps/*.png
%{_datadir}/pixmaps/ggv/*
%{_datadir}/applications/ggv.desktop
%{_datadir}/idl/Ggv.idl
%{_prefix}/bin/*
%{_libexecdir}/ggv/*
%{_libdir}/bonobo/servers/*.server
%{_datadir}/gnome-2.0/ui/*.xml
%{_datadir}/gnome/help/ggv/*/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_mandir}/man1/*

%changelog
* Fri May 06 2005 [email protected]
- Updated ggv-05-convert-uri-to-display-name.diff
  use utf-8 encoded file, instead of uri name, Fixed 5053231.

* Mon May 02 2005 - [email protected]
- Added ggv-07-orientation.diff to fix the issue with
  'Document Orientation'. Fixes bug #6259272.

* Tue Jan 25 2005 - [email protected]
- Update docs with Linux specific tarball from [email protected].

* Fri Jan 14 2005 - [email protected]
- Updated l10n help tarball for cinnabar-linux

* Fri Nov 05 2004 [email protected]
- needless emitting of changed signal in combobox
  when the widget is getting populated. Also
  don't update gconf if the value that we get
  is same as what gconf already has.
  Fixes #5072172

* Wed Nov 02 2004 [email protected]
- Added ggv-05-convert-uri-to-display-name.diff
  use utf-8 encoded file, instead of uri name, Fixed 5053231.

* Wed Aug 25 2004 [email protected]
- Added l10n online help with patch

* Tue Aug 17 2004 [email protected]
- Added patch ggv-03-disconnect-sm-connection.diff to disable the
  session manager connection for ggv-postscript-viewer.
  Fix for bugtraq bug #5072112.

* Thu Aug 05 2004 [email protected]
- Incorporate new docs tarball from [email protected].

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to ggv-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Fri Jun 25 2004 - [email protected]
- Added patch ggv-02-solaris-print-path-issue.diff to fix ggv crash while
  printing in Solaris. Fix for bugtraq bug:5061197.

* Wed Jun 02 2004 [email protected]
- Incorporate new docs tarball from [email protected].

* Wed May 12 2004 - [email protected]
- Updated l10n content to ggv-l10n-po-1.1.tar.bz2

* Mon Apr 19 2004 - [email protected]
- Bump to 2.6.1

* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris

* Thu Apr 01 2004 - [email protected]
- javahelp conversion

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to ggv-l10n-po-1.0.tar.bz2

* Wed Mar 24 2004 - [email protected]
- Bump to 2.6.0

* Fri Mar 19 2004 - [email protected]
- Bump to 2.5.99.1 and remove duplicate sources solaris 
  build patch as it's now upstream.

* Fri Feb 06 2004 - <[email protected]>
- Bump to 2.5.3, remove ggv-02-intltool-merge.diff

* Thu Jan 29 2004 - <[email protected]>
- patch 02 for intltool-merge and dep. on intltool

* Fri Jan 09 2004 - <[email protected]>
- new version: 2.5.1

* Wed Dec 17 2003 - <[email protected]>
- Bump to 2.5.0

* Fri Oct 31 2003 - <[email protected]>
- Remove the Sun Supported part of the menu 
  entry patch.

* Fri Sep 26 2003 - <[email protected]>
- Intergate Sun docs

* Wed Jul 31 2003 - <[email protected]>
- Add recent files support.

* Wed Jul 30 2003 - <[email protected]>
- New tarball. Bump version, reset release.

* Tue Jul 21 2003 - <[email protected]>
- Update menu entry to something a little nicer.

* Wed Jul 09 2003 - <[email protected]>
- add in sun po files

* Thu May 08 2003 - [email protected]
- Created new spec file for ggv