gnome-spell.spec
author dermotm
Mon, 24 Jul 2006 12:30:39 +0000
branchgnome-2-10
changeset 19949 94f49bf19351
parent 19719 d184ca39d269
permissions -rw-r--r--
access control test #4

#
# spec file for package gnome-spell
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%define t_suffix -build38-linux-cb
%{?nightly:%define t_suffix -%(TZ=GMT date +%Y%m%d)}

Name:     	gnome-spell
Version: 	1.0.4
Release:	388
Vendor:		Sun Microsystems, Inc.
Distribution:	Java Desktop System
Copyright:	GPL
BuildRoot:	%{_tmppath}/%{name}-%{version}-build
Docdir:         %{_datadir}/doc
Autoreqprov:    on
URL:		http://www.sun.com/software/javadesktopsystem/
Source:		%{name}-%{version}%{t_suffix}.tar.bz2
Source1:	mkinstalldirs
Summary:	GNOME spell checking component
Group:		Applications/Text

%define aspell_version 0.50.3
%define libgnomeui_version 2.6.1
Requires:       aspell >= %{aspell_version}
BuildRequires:  aspell-devel >= %{aspell_version}
Requires:       libgnomeui >= %libgnomeui_version
BuildRequires:  libgnomeui-devel >= %libgnomeui_version

%description
Gnome Spell is GNOME/Bonobo component for spell checking. It
contains the GNOME::Spell::Dictionary object, which provides a spell
checking dictionary (see Spell.idl for exact API definition). It is
based on pspell.

%files
%defattr(-, root, root)
%doc AUTHORS ChangeLog COPYING NEWS README
%dir %{_libdir}/gnome-spell
%{_libdir}/gnome-spell/*.so
%{_datadir}/control-center-2.0/icons/*
%{_datadir}/gnome-spell-1.0.4
%{_datadir}/idl/*
%{_libdir}/bonobo/servers/*
%{_prefix}/*/locale/*/LC_MESSAGES/*

%prep
%setup  -q -n %{name}-%{version}
cp %SOURCE1 .


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

%ifos linux
    export LDFLAGS="-lstdc++"
%endif

aclocal $ACLOCAL_FLAGS
libtoolize --force
glib-gettextize --force --copy
intltoolize --force --automake
autoheader
automake -a -f -c --gnu
autoconf
./configure \
    --prefix=%{_prefix} \
    --sysconfdir=%{_sysconfdir} \
    --mandir=%{_mandir} \
    --infodir=%{_datadir}/info \
    --localstatedir=/var \
    --disable-static

make -j $CPUS

%install
make install DESTDIR=$RPM_BUILD_ROOT
#clean up unpackaged files
rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a
rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%changelog
* Fri Aug 05 2005 - [email protected]
- simplify spec file

* Mon Jun 20 2005 - [email protected]
- Bump source tarball to build 38 (linux)

* Mon Jun 06 2005 - [email protected]
- Bump source tarball to build 37 (linux)

* Mon May 23 2005 - [email protected]
- Bump source tarball to build 36 (linux)

* Mon May 09 2005 - [email protected]
- Bump source tarball to build 35 (linux)

* Mon Apr 25 2005 - [email protected]
- Bump source tarball to build 34 (linux)

* Mon Apr 11 2005 - [email protected]
- Bump source tarball to build 33 (linux)

* Mon Mar 28 2005 - [email protected]
- Bump source tarball to build 32 (linux)

* Mon Mar 14 2005 - [email protected]
- Bump source tarball to build 31 (linux)

* Mon Feb 28 2005 - [email protected]
- Bump source tarball to build 30 (linux)

* Mon Feb 14 2005 - [email protected]
- Bump source tarball to build 29 (linux)

* Mon Jan 31 2005 - [email protected]
- Bump source tarball to build 28 (linux)

* Fri Jan 28 2005 - [email protected]
- Fix the wrong description by script failure.

* Mon Jan 17 2005 - [email protected]
- Bump source tarball to build 27 (linux)

* Tue Jan 04 2005 - [email protected]
- Bump source tarball to build 26 (linux)

* Mon Dec 13 2004 - [email protected]
- Bump source tarball to build 25 (linux)

* Mon Nov 29 2004 - [email protected]
- Bump source tarball to build 24

* Mon Nov 15 2004 - [email protected]
- Bump source tarball to build 23.

* Mon Nov 01 2004 - [email protected]
- bump src tarball to build22

* Wed Oct 27 2004 - [email protected]
- add libgnomeui dependency

* Tue Oct 26 2004 - [email protected]
- disable building static libs

* Mon Oct 18 2004 - [email protected]
- bump src tarball to build21

* Mon Oct 11 2004 - [email protected]
- bump src tarball to build20b

* Mon Oct 04 2004 - [email protected]
- change aspell dep. version to 0.50.3

* Mon Sep 20 2004 - [email protected]
- bump src tarball to build19

* Mon Sep 06 2004 - [email protected]
- bump src tarball to build18

* Mon Aug 23 2004 - [email protected]
- bump src tarball to build17

* Mon Aug 09 2004 - [email protected]
- bump src tarball to build16

* Mon Jul 26 2004 - [email protected]
- bump src tarball to build15

* Tue Jul 13 2004 - [email protected]
- ported to sles 9, add build requirement on
  aspell-devel. Remove unpackaged files.

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gnome-spell-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Fri Jun 25 2004 - [email protected]
- bump src tarball to build13
* Thu Jun 10 2004 - [email protected]
- bump src tarball to build12
* Sun May 30 2004 - [email protected]
- bump src tarball to build11
* Fri May 28 2004 - [email protected]
- add -lstdc++ to LDFLAGS on Linux
* Thu May 27 2004 - [email protected]
- add mkinstalldirs to the source tree
* Fri May 14 2004 - [email protected]
- bump src tarball to build10
* Wed May 12 2004 - [email protected]
- replace tar jxf with the more solaris friendly
  bzcat piped through tar
* Wed May 12 2004 - [email protected]
- Adding gnome-spell-l10n-po-1.1.tar.bz2 l10n content
* Fri Apr 30 2004 - [email protected]
- bump src tarball to build09